<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.nowgrenada.com/xmlrpc.php" />
    <title>Managing Council elected to lead work of Grenada Chess Federation | NOW Grenada</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* allerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }


	/* Custom CSS */
	.bsaProContainer .bsaProHeader {
    display: none;
}

.owl-controls {
    display: none !important;
} 

#bsa-block-720—300 {
max-width: 300px;
}

@media only screen and (min-width: 900px) {
.bsaPopupClose {
    position: absolute;
    cursor: pointer;
    top: 150px;
    right: 320px;
    width: 25px;
    height: 25px;
    background: url(../../img/close-black.png) white center center no-repeat;
}
}

</style>	<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
		<script type="text/javascript">var theChampDefaultLang = 'en_GB', theChampCloseIconPath = 'https://www.nowgrenada.com/wp-content/plugins/super-socializer/images/close.png';var heateorSsSDKBlockedMsg = `Your browser is blocking some features of this website. Please follow the instructions at <a href=\'http://support.heateor.com/browser-blocking-social-features/\' target=\'_blank\' style=\'color:#33a9d8\'>http://support.heateor.com/browser-blocking-social-features/</a> to unblock these.`</script>
		<script> var theChampSiteUrl = 'https://www.nowgrenada.com', theChampVerified = 0, theChampEmailPopup = 0; </script>
		<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.heateor_ss_mobile_footer{display:none;}@media screen and (max-width:783px){i.theChampTCBackground{background-color:white!important}div.the_champ_bottom_sharing{width:100%!important;left:0!important;}div.the_champ_bottom_sharing li{width:11.111111111111% !important;}div.the_champ_bottom_sharing .theChampSharing{width: 100% !important;}div.the_champ_bottom_sharing div.theChampTotalShareCount{font-size:1em!important;line-height:28px!important}div.the_champ_bottom_sharing div.theChampTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_ss_mobile_footer{display:block;height:40px;}.the_champ_bottom_sharing{padding:0!important;display:block!important;width: auto!important;bottom:-2px!important;top: auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height: inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right: 1.1em !important}}</style>
	            <script type="text/javascript"> var jnews_ajax_url = 'https://www.nowgrenada.com/?ajax-request=jnews'; </script>
            
<!-- All in One SEO Pack 2.12.1 by Michael Torbert of Semper Fi Web Design[989,1081] -->
<meta name="description"  content="&quot;A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.&quot;" />

<link rel="canonical" href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/" />
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Feed" href="https://www.nowgrenada.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Comments Feed" href="https://www.nowgrenada.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Managing Council elected to lead work of Grenada Chess Federation Comments Feed" href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.nowgrenada.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='https://www.nowgrenada.com/wp-content/plugins/awesome-weather/awesome-weather.css' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/user-panel.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/all.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/animate.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/chart.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_owl_carousel_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/bsa.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/material-design.css' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/ui-datapicker.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-css.css' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.nowgrenada.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='jnews-parent-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/super-socializer/css/front.css' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-dynamic-style-css'  href='https://www.nowgrenada.com/wp-content/uploads/jeg/jeg-YozO2NStc8.css' type='text/css' media='all' />
<link rel='stylesheet' id='otw-shortcode-css'  href='https://www.nowgrenada.com/wp-content/plugins/lists-shortcode-and-widget//include/otw_components/otw_shortcode/css/otw_shortcode.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/thickbox/thickbox.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/underscore.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/shortcode.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-admin/js/media-upload.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/script.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.viewportchecker.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/chart.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/bsa.carousel.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.simplyscroll.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/custom.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.nowgrenada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nowgrenada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nowgrenada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Barbados willing to divest some of its LIAT shares' href='https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab' />
<link rel='next' title='CCJ dismisses application against Barbados' href='https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/' />

<link rel='shortlink' href='https://www.nowgrenada.com/?p=57843' />
<link rel="alternate" type="application/json+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F&#038;format=xml" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.nowgrenada.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e0fbff27-0ea3-4e3f-a8d9-a4c7eac9ccc8';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "NOW Grenada";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing to nowgrenada.com!";
oneSignal_options['welcomeNotification']['url'] = "https://www.nowgrenada.com";
oneSignal_options['path'] = "https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4463433a-b41c-4a34-809b-879a9d93883b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'wants to show Notifications';
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Example Notification Title';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Notifications will appear on your desktop';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Example Notification';
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = 'Notifications will appear on your mobile';
oneSignal_options['promptOptions']['exampleNotificationCaption'] = '(you can unsubscribe anytime)';
oneSignal_options['promptOptions']['acceptButtonText'] = 'CONTINUE';
oneSignal_options['promptOptions']['cancelButtonText'] = 'NO THANKS';
oneSignal_options['promptOptions']['siteName'] = 'http://www.nowgrenada.com';
oneSignal_options['promptOptions']['autoAcceptTitle'] = 'Click Allow';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-75x75.png" sizes="32x32" />
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" />
		<style type="text/css" id="wp-custom-css">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</style>
		<style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1512030979094{padding-top: 20px !important;padding-bottom: 20px !important;background-color: #212121 !important;}.vc_custom_1551598731654{margin-bottom: 0px !important;}</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<!-- START - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="NOW Grenada"/>
  <meta property="og:title" content="Managing Council elected to lead work of Grenada Chess Federation"/>
  <meta property="og:url" content="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="“A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.”"/>
  <meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"/>
  <meta property="og:image:url" content="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"/>
  <meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"/>
  <meta property="article:published_time" content="2019-05-20T09:00:02-04:00"/>
  <meta property="article:modified_time" content="2019-05-20T06:55:41-04:00" />
  <meta property="og:updated_time" content="2019-05-20T06:55:41-04:00" />
  <meta property="article:section" content="Press Release"/>
  <meta property="article:section" content="Sports"/>
  <meta property="article:publisher" content="https://www.facebook.com/NowGrenada/"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Managing Council elected to lead work of Grenada Chess Federation"/>
  <meta itemprop="headline" content="Managing Council elected to lead work of Grenada Chess Federation"/>
  <meta itemprop="description" content="“A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.”"/>
  <meta itemprop="image" content="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"/>
  <meta itemprop="datePublished" content="2019-05-20"/>
  <meta itemprop="dateModified" content="2019-05-20T06:55:41-04:00" />
  <meta itemprop="author" content="NOW Grenada"/>
  <!--<meta itemprop="publisher" content="NOW Grenada"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Managing Council elected to lead work of Grenada Chess Federation"/>
  <meta name="twitter:url" content="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"/>
  <meta name="twitter:description" content="“A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.”"/>
  <meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@nowgrenada"/>
 <!-- SEO -->
  <meta name="description" content="“A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.”"/>
  <meta name="publisher" content="NOW Grenada"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
	
</head>
<body class="post-template-default single single-post postid-57843 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-5.7 vc_responsive">

    
            <div id="jeg_sidecontent">
            <div class="jeg_side_heading">
                <ul class="jeg_side_tabs">
                    <li data-tab-content="tab1" data-sort='latest' class="active">Latest</li>                </ul>
                <div class="jeg_side_feed_cat_wrapper">
                                    </div>
                <script> var side_feed = {"paged":1,"post_type":"post","exclude_post":57843,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":12,"number_post":12,"pagination_mode":"loadmore"}; </script>            </div>

            <div class="sidecontent_postwrapper">
                <div class="jeg_sidefeed">
                    <div class="jeg_post jeg_pl_md_box active " data-id="57843" data-sequence="0">
                        <div class="overlay_container">
                            <div class="jeg_thumb">
                                
                                <a class="ajax" href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Managing Council elected to lead work of Grenada Chess Federation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640-360x180.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                            </div>
                            <div class="jeg_postblock_content">
                                <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">Managing Council elected to lead work of Grenada Chess Federation</a></h2>
                                <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                            </div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57860" data-sequence="1">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Grenada Constitution Reform : The CCJ Convicts Itself!" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg 240w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-150x150.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-144x144.jpg 144w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-38x38.jpg 38w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-186x186.jpg 186w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-184x184.jpg 184w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/">CCJ dismisses application against Barbados</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57852" data-sequence="2">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="59" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg 400w, https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline-150x117.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline-300x234.jpg 300w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 10 hours ago</div></div>
                        </div>
                    </div><div class="jeg_ad jnews_sidefeed_ads"><div class='ads-wrapper jeg_ad_sidecontent '></div></div><div class="jeg_post jeg_pl_xs_3  " data-id="57846" data-sequence="3">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 10 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57849" data-sequence="4">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Rescued Venezuelan from missing pirogue brought to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/A-photograph-from-Robert-Richards-Facebook-page-shows-a-man-said-to-be-a-Venezuelan-in-distress-in-waters-off-Chaguaramas-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/A-photograph-from-Robert-Richards-Facebook-page-shows-a-man-said-to-be-a-Venezuelan-in-distress-in-waters-off-Chaguaramas-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/A-photograph-from-Robert-Richards-Facebook-page-shows-a-man-said-to-be-a-Venezuelan-in-distress-in-waters-off-Chaguaramas-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab">Rescued Venezuelan from missing pirogue brought to Grenada</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 11 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57839" data-sequence="5">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Prime Minister impressed with Renegade Rum Distillery project" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-150x147.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-300x294.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-768x753.jpg 768w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-100x100.jpg 100w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-750x736.jpg 750w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/">Prime Minister impressed with Renegade Rum Distillery project</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57836" data-sequence="6">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/">Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57833" data-sequence="7">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="53" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="RGPF" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/01/RGPF-e1473361423708.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/">Police confirm the death of a St David resident</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57794" data-sequence="8">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Screenshot-2019-05-16-at-1.37.53-PM-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/Screenshot-2019-05-16-at-1.37.53-PM-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Screenshot-2019-05-16-at-1.37.53-PM-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/">Sociologist’s novel challenges the narrative surrounding homosexuality in Grenada</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57816" data-sequence="9">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Prime Minister turns sod for low-income housing project in Beausejour" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/">Prime Minister turns sod for low-income housing project in Beausejour</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57823" data-sequence="10">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Maurice-Bishop-left-and-Fidel-Castro-at-May-Day-rally-in-Cuba-1980-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/Maurice-Bishop-left-and-Fidel-Castro-at-May-Day-rally-in-Cuba-1980-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/Maurice-Bishop-left-and-Fidel-Castro-at-May-Day-rally-in-Cuba-1980-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab">The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57763" data-sequence="11">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="57806" data-sequence="12">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="50" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="NIS paid more than it collected for the first 6 months of 2018" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada-150x100.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada-300x200.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada-768x511.jpg 768w, https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada-450x300.jpg 450w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/">Updated NIS Improvement and Sustainability Plan public education schedule</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 4 days ago</div></div>
                        </div>
                    </div>                </div>
                <div class="sidefeed_loadmore">
                    <button class="btn " data-end="End of Content" data-loading="Loading..." data-loadmore="Load More">
                        Load More                    </button>
                </div>
            </div>
            <div class="jeg_sidefeed_overlay">
                <div class='preloader_type preloader_dot'>
                    <div class="sidefeed-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="sidefeed-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="sidefeed-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
        </div>


    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/" style="padding: 0 0 0 0;">
	    	    <img src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2@2x.png 2x" alt="NOW Grenada">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '><div class='ads_shortcode'><div id="bsa-html" class="bsaProContainer bsaProContainer-10 bsa-html bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Footer 468x60</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=10" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=15&bsa_pro_url=http://netherlands.co.gd" target="_blank"><img class="netherlands-ad" src="https://www.nowgrenada.com/wp-content/uploads/2017/12/banner468x60Netherlands1.gif" title="Netherlands" styles="margin-bottom: 25px !important;"/>
<div class="spacer"></div>
</a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56 bgnav" data-item-row="default" ><a href="http://nowgrenada.com">Front Page</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container size-500 "><img width="231" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Rescued Venezuelan from missing pirogue brought to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/A-photograph-from-Robert-Richards-Facebook-page-shows-a-man-said-to-be-a-Venezuelan-in-distress-in-waters-off-Chaguaramas-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab">Rescued Venezuelan from missing pirogue brought to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister impressed with Renegade Rum Distillery project" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/">Prime Minister impressed with Renegade Rum Distillery project</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/"><div class="thumbnail-container size-500 "><img width="257" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/01/RGPF-e1473361423708.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/">Police confirm the death of a St David resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="NIS paid more than it collected for the first 6 months of 2018" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/">Updated NIS Improvement and Sustainability Plan public education schedule</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/anti-money-laundering-commission-commences-registration-of-working-partners/"><div class="thumbnail-container size-500 "><img width="265" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Cash Transactions for Government this Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/12/1479313567_ef265ccc06.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/anti-money-laundering-commission-commences-registration-of-working-partners/">Anti-Money Laundering Commission commences registration of working partners</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian secondary school girls set to shine in ICT Hackathon" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Caribbean-Girls-Hack-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/">Grenadian secondary school girls set to shine in ICT Hackathon</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/public-notice-from-the-anti-money-laundering-and-combating-terrorism-financing-commission/"><div class="thumbnail-container size-500 "><img width="185" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/public-notice-from-the-anti-money-laundering-and-combating-terrorism-financing-commission/">Public notice from the Anti-Money Laundering and Combating Terrorism Financing Commission</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-55527" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Managing Council elected to lead work of Grenada Chess Federation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">Managing Council elected to lead work of Grenada Chess Federation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenada-registers-its-first-para-athlete/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada registers its first para-athlete" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Ishonacharles-javilin-thrower-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenada-registers-its-first-para-athlete/">Grenada registers its first para-athlete</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="St David retains RightStart/GCA Under 19 championship title" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/2019-Champs-St.-David-with-Bank-Representatives-and-GCA-Officials-RS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/">St David retains RightStart/GCA Under 19 championship title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-sailor-aims-to-circumnavigate-the-globe/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian sailor aims to circumnavigate the globe" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IMG_2279-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-sailor-aims-to-circumnavigate-the-globe/">Grenadian sailor aims to circumnavigate the globe</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/nypd-officers-visit-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="NYPD officers visit Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/nypd-officers-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/nypd-officers-visit-grenada/">NYPD officers visit Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/physical-education-teachers-attend-para-sport-workshops-in-peru/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Paralympics Excited About the Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/08/Grenada-Paralympics-Committee.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/physical-education-teachers-attend-para-sport-workshops-in-peru/">Physical Education teachers attend para sport workshops in Peru</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.dailymail.co.uk/news/article-6973537/Leicester-City-midfielder-Hamza-Choudhury-apologises-racist-sexist-tweets-resurface.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Hamza Choudhury apologises after racist and sexist tweets resurface" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/Leicester-City-midfielder-Hamza-Choudhury--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.dailymail.co.uk/news/article-6973537/Leicester-City-midfielder-Hamza-Choudhury-apologises-racist-sexist-tweets-resurface.html#new_tab">Hamza Choudhury apologises after racist and sexist tweets resurface</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/04/national-learn-to-swim-week-2019/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Learn to Swim Week 2019" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/Deb-Eastwood-with-Results-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/04/national-learn-to-swim-week-2019/">National Learn to Swim Week 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/04/boxing-association-of-grenada-agm/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Boxing Association of Grenada AGM" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/20190427_211520-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/04/boxing-association-of-grenada-agm/">Boxing Association of Grenada AGM</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister turns sod for low-income housing project in Beausejour" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/">Prime Minister turns sod for low-income housing project in Beausejour</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian secondary school girls set to shine in ICT Hackathon" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Caribbean-Girls-Hack-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/">Grenadian secondary school girls set to shine in ICT Hackathon</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/missing-teen-jeanelle-paul/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Missing Teen: Jeanelle Paul" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Jeanelle-Paul-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/missing-teen-jeanelle-paul/">Missing Teen: Jeanelle Paul</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="St David retains RightStart/GCA Under 19 championship title" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/2019-Champs-St.-David-with-Bank-Representatives-and-GCA-Officials-RS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/">St David retains RightStart/GCA Under 19 championship title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/the-nature-conservancy-targets-students-for-conservation-awareness-during-reef-week/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The Nature Conservancy targets students for conservation awareness during Reef Week " data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/a320330f-3301-4074-b62c-a574a5ff167e-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/the-nature-conservancy-targets-students-for-conservation-awareness-during-reef-week/">The Nature Conservancy targets students for conservation awareness during Reef Week </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.caribbeanlifenews.com/stories/2019/5/2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian honoured at gala event of Independent United Order of Mechanics" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/ss-2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl02_z-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.caribbeanlifenews.com/stories/2019/5/2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl.html#new_tab">Grenadian honoured at gala event of Independent United Order of Mechanics</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://sflcn.com/grenada-to-debut-culinary-team-at-taste-of-the-caribbean-competition/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada to debut culinary team at Taste of the Caribbean Competition" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Grenada-National-Culinary-Team-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://sflcn.com/grenada-to-debut-culinary-team-at-taste-of-the-caribbean-competition/#new_tab">Grenada to debut culinary team at Taste of the Caribbean Competition</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-statement-on-the-passing-of-pamela-james/"><div class="thumbnail-container size-500 "><img width="288" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Candlelight Memorial at Tercentenary Park" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/10/candle_Candle_light_4010.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-statement-on-the-passing-of-pamela-james/">Prime Minister Statement on the passing of Pamela James</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/">Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Screenshot-2019-05-16-at-1.37.53-PM-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/">Sociologist’s novel challenges the narrative surrounding homosexuality in Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/returning-the-town-of-st-george-to-its-former-glory/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Returning the Town of St George to its former glory " data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IMG_2424-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/returning-the-town-of-st-george-to-its-former-glory/">Returning the Town of St George to its former glory </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/conference-to-commemorate-40th-anniversary-of-the-grenada-revolution/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Conference to commemorate 40th anniversary of the Grenada Revolution" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/uwi-sgu-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/conference-to-commemorate-40th-anniversary-of-the-grenada-revolution/">Conference to commemorate 40th anniversary of the Grenada Revolution</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ird-and-promoters-discuss-the-entertainment-industry-and-taxes/"><div class="thumbnail-container size-500 "><img width="265" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="ird" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/10/1479313567_ef265ccc06-300x204.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ird-and-promoters-discuss-the-entertainment-industry-and-taxes/">IRD and promoters discuss the entertainment industry and taxes</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.forbes.com/sites/daphneewingchow/2019/05/14/there-is-a-growing-market-for-nutraceuticals-in-integrated-cancer-treatment-in-the-caribbean/#6b4d68c2204b#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Nutraceuticals in integrated cancer treatment in the Caribbean" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/turmeric-3251560_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.forbes.com/sites/daphneewingchow/2019/05/14/there-is-a-growing-market-for-nutraceuticals-in-integrated-cancer-treatment-in-the-caribbean/#6b4d68c2204b#new_tab">Nutraceuticals in integrated cancer treatment in the Caribbean</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/option-of-abortion-for-a-child-conceived-through-rape-not-discussed-by-cabinet/"><div class="thumbnail-container size-500 "><img width="237" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="“Fighting Poverty is a Moral fight of our Time”" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/Minister-Thomas-1-e1430940635590.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/option-of-abortion-for-a-child-conceived-through-rape-not-discussed-by-cabinet/">Option of abortion for a child conceived through rape not discussed by cabinet</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/twrf-celebrates-silver-anniversary-with-book-launch/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="tWRF celebrates Silver Anniversary with book launch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Her-Excellency-Dame-Cecile-La-Grenade-with-Dr-Angus-Friday-and-pannist-Mkendu-De-Gale-to-her-left-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/twrf-celebrates-silver-anniversary-with-book-launch/">tWRF celebrates Silver Anniversary with book launch</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Maurice-Bishop-left-and-Fidel-Castro-at-May-Day-rally-in-Cuba-1980-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab">The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ndc-heartbeat-our-best-prospect-for-growth-remains-a-secret/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ndc-heartbeat-our-best-prospect-for-growth-remains-a-secret/">NDC Heartbeat: Our best prospect for growth remains a secret </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-vi/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-vi/">Minding Your Legal Affairs XV: The employee’s rights Part VI</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/opening-statement-by-minister-for-foreign-affairs-peter-david-at-cofcor/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opening Statement by Minister for Foreign Affairs, Peter David at COFCOR" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/safe_image-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/opening-statement-by-minister-for-foreign-affairs-peter-david-at-cofcor/">Opening Statement by Minister for Foreign Affairs, Peter David at COFCOR</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://news.artnet.com/opinion/venice-biennale-financial-risk-1544065#new_tab"><div class="thumbnail-container size-500 "><img width="320" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada prepares for Biennale di Venezia" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/08/grenada-2018-artists.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://news.artnet.com/opinion/venice-biennale-financial-risk-1544065#new_tab">Great creative achievements demand great sacrifice</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/failed-coup-attempt-aided-by-us/"><div class="thumbnail-container size-500 "><img width="221" height="163" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Calypso Tent for SpiceMas 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/arlie-gill-e1397837815415.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/failed-coup-attempt-aided-by-us/">Failed coup attempt aided by US</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-v/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-v/">Minding Your Legal Affairs XV: The employee’s rights Part V</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/vote-now-best-caribbean-travel-blog-posting/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Vote now: Best Caribbean Travel Blog Posting" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/02-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/vote-now-best-caribbean-travel-blog-posting/">Vote now: Best Caribbean Travel Blog Posting</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/oil-gas-our-patrimony-governments-secret-part-2/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/oil-gas-our-patrimony-governments-secret-part-2/">Oil &#038; gas, Our patrimony. Government’s secret Part 2</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-56527" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Constitution Reform : The CCJ Convicts Itself!" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/">CCJ dismisses application against Barbados</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Managing Council elected to lead work of Grenada Chess Federation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">Managing Council elected to lead work of Grenada Chess Federation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container size-500 "><img width="231" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister impressed with Renegade Rum Distillery project" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/">Prime Minister impressed with Renegade Rum Distillery project</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/">Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/"><div class="thumbnail-container size-500 "><img width="257" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/01/RGPF-e1473361423708.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/">Police confirm the death of a St David resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister turns sod for low-income housing project in Beausejour" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/">Prime Minister turns sod for low-income housing project in Beausejour</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-12022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li id="menu-item-10298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li id="menu-item-24260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56 bgnav" data-item-row="default" ><a href="http://nowgrenada.com">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container size-500 "><img width="231" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Rescued Venezuelan from missing pirogue brought to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/A-photograph-from-Robert-Richards-Facebook-page-shows-a-man-said-to-be-a-Venezuelan-in-distress-in-waters-off-Chaguaramas-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/05/19/vzuelan-rescued-off-chaguaramas/#new_tab">Rescued Venezuelan from missing pirogue brought to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister impressed with Renegade Rum Distillery project" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/">Prime Minister impressed with Renegade Rum Distillery project</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/"><div class="thumbnail-container size-500 "><img width="257" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/01/RGPF-e1473361423708.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/">Police confirm the death of a St David resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="NIS paid more than it collected for the first 6 months of 2018" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/08/Office-of-NIS-Grenada.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/updated-nis-improvement-and-sustainability-plan-public-education-schedule/">Updated NIS Improvement and Sustainability Plan public education schedule</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/anti-money-laundering-commission-commences-registration-of-working-partners/"><div class="thumbnail-container size-500 "><img width="265" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Cash Transactions for Government this Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/12/1479313567_ef265ccc06.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/anti-money-laundering-commission-commences-registration-of-working-partners/">Anti-Money Laundering Commission commences registration of working partners</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian secondary school girls set to shine in ICT Hackathon" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Caribbean-Girls-Hack-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/">Grenadian secondary school girls set to shine in ICT Hackathon</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/public-notice-from-the-anti-money-laundering-and-combating-terrorism-financing-commission/"><div class="thumbnail-container size-500 "><img width="185" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/public-notice-from-the-anti-money-laundering-and-combating-terrorism-financing-commission/">Public notice from the Anti-Money Laundering and Combating Terrorism Financing Commission</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Managing Council elected to lead work of Grenada Chess Federation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">Managing Council elected to lead work of Grenada Chess Federation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenada-registers-its-first-para-athlete/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada registers its first para-athlete" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Ishonacharles-javilin-thrower-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenada-registers-its-first-para-athlete/">Grenada registers its first para-athlete</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="St David retains RightStart/GCA Under 19 championship title" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/2019-Champs-St.-David-with-Bank-Representatives-and-GCA-Officials-RS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/">St David retains RightStart/GCA Under 19 championship title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-sailor-aims-to-circumnavigate-the-globe/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian sailor aims to circumnavigate the globe" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IMG_2279-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-sailor-aims-to-circumnavigate-the-globe/">Grenadian sailor aims to circumnavigate the globe</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/nypd-officers-visit-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="NYPD officers visit Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/nypd-officers-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/nypd-officers-visit-grenada/">NYPD officers visit Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/physical-education-teachers-attend-para-sport-workshops-in-peru/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Paralympics Excited About the Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/08/Grenada-Paralympics-Committee.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/physical-education-teachers-attend-para-sport-workshops-in-peru/">Physical Education teachers attend para sport workshops in Peru</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.dailymail.co.uk/news/article-6973537/Leicester-City-midfielder-Hamza-Choudhury-apologises-racist-sexist-tweets-resurface.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Hamza Choudhury apologises after racist and sexist tweets resurface" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/Leicester-City-midfielder-Hamza-Choudhury--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.dailymail.co.uk/news/article-6973537/Leicester-City-midfielder-Hamza-Choudhury-apologises-racist-sexist-tweets-resurface.html#new_tab">Hamza Choudhury apologises after racist and sexist tweets resurface</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/04/national-learn-to-swim-week-2019/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Learn to Swim Week 2019" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/Deb-Eastwood-with-Results-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/04/national-learn-to-swim-week-2019/">National Learn to Swim Week 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/04/boxing-association-of-grenada-agm/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Boxing Association of Grenada AGM" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/20190427_211520-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/04/boxing-association-of-grenada-agm/">Boxing Association of Grenada AGM</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister turns sod for low-income housing project in Beausejour" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/">Prime Minister turns sod for low-income housing project in Beausejour</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian secondary school girls set to shine in ICT Hackathon" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Caribbean-Girls-Hack-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/grenadian-secondary-school-girls-set-to-shine-in-ict-hackathon/">Grenadian secondary school girls set to shine in ICT Hackathon</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/missing-teen-jeanelle-paul/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Missing Teen: Jeanelle Paul" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Jeanelle-Paul-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/missing-teen-jeanelle-paul/">Missing Teen: Jeanelle Paul</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="St David retains RightStart/GCA Under 19 championship title" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/2019-Champs-St.-David-with-Bank-Representatives-and-GCA-Officials-RS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/st-david-retains-rightstart-gca-under-19-championship-title/">St David retains RightStart/GCA Under 19 championship title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/the-nature-conservancy-targets-students-for-conservation-awareness-during-reef-week/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The Nature Conservancy targets students for conservation awareness during Reef Week " data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/a320330f-3301-4074-b62c-a574a5ff167e-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/the-nature-conservancy-targets-students-for-conservation-awareness-during-reef-week/">The Nature Conservancy targets students for conservation awareness during Reef Week </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.caribbeanlifenews.com/stories/2019/5/2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian honoured at gala event of Independent United Order of Mechanics" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/ss-2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl02_z-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.caribbeanlifenews.com/stories/2019/5/2019-05-10-nk-brooklyn-district-grand-lodge-gala-cl.html#new_tab">Grenadian honoured at gala event of Independent United Order of Mechanics</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://sflcn.com/grenada-to-debut-culinary-team-at-taste-of-the-caribbean-competition/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada to debut culinary team at Taste of the Caribbean Competition" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Grenada-National-Culinary-Team-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://sflcn.com/grenada-to-debut-culinary-team-at-taste-of-the-caribbean-competition/#new_tab">Grenada to debut culinary team at Taste of the Caribbean Competition</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-statement-on-the-passing-of-pamela-james/"><div class="thumbnail-container size-500 "><img width="288" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Candlelight Memorial at Tercentenary Park" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/10/candle_Candle_light_4010.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-statement-on-the-passing-of-pamela-james/">Prime Minister Statement on the passing of Pamela James</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/">Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Screenshot-2019-05-16-at-1.37.53-PM-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/sociologists-novel-challenges-the-narrative-surrounding-homosexuality-in-grenada/">Sociologist’s novel challenges the narrative surrounding homosexuality in Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/returning-the-town-of-st-george-to-its-former-glory/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Returning the Town of St George to its former glory " data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IMG_2424-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/returning-the-town-of-st-george-to-its-former-glory/">Returning the Town of St George to its former glory </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/conference-to-commemorate-40th-anniversary-of-the-grenada-revolution/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Conference to commemorate 40th anniversary of the Grenada Revolution" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/uwi-sgu-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/conference-to-commemorate-40th-anniversary-of-the-grenada-revolution/">Conference to commemorate 40th anniversary of the Grenada Revolution</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ird-and-promoters-discuss-the-entertainment-industry-and-taxes/"><div class="thumbnail-container size-500 "><img width="265" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="ird" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/10/1479313567_ef265ccc06-300x204.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ird-and-promoters-discuss-the-entertainment-industry-and-taxes/">IRD and promoters discuss the entertainment industry and taxes</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.forbes.com/sites/daphneewingchow/2019/05/14/there-is-a-growing-market-for-nutraceuticals-in-integrated-cancer-treatment-in-the-caribbean/#6b4d68c2204b#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Nutraceuticals in integrated cancer treatment in the Caribbean" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/turmeric-3251560_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.forbes.com/sites/daphneewingchow/2019/05/14/there-is-a-growing-market-for-nutraceuticals-in-integrated-cancer-treatment-in-the-caribbean/#6b4d68c2204b#new_tab">Nutraceuticals in integrated cancer treatment in the Caribbean</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/option-of-abortion-for-a-child-conceived-through-rape-not-discussed-by-cabinet/"><div class="thumbnail-container size-500 "><img width="237" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="“Fighting Poverty is a Moral fight of our Time”" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/Minister-Thomas-1-e1430940635590.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/option-of-abortion-for-a-child-conceived-through-rape-not-discussed-by-cabinet/">Option of abortion for a child conceived through rape not discussed by cabinet</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/twrf-celebrates-silver-anniversary-with-book-launch/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="tWRF celebrates Silver Anniversary with book launch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Her-Excellency-Dame-Cecile-La-Grenade-with-Dr-Angus-Friday-and-pannist-Mkendu-De-Gale-to-her-left-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/twrf-celebrates-silver-anniversary-with-book-launch/">tWRF celebrates Silver Anniversary with book launch</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Maurice-Bishop-left-and-Fidel-Castro-at-May-Day-rally-in-Cuba-1980-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.stlucianewsonline.com/the-spirit-of-maurice-bishop-and-the-caricom-foreign-ministers-meeting-in-grenada-letter/#new_tab">The spirit of Maurice Bishop and the Caricom foreign ministers meeting in Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ndc-heartbeat-our-best-prospect-for-growth-remains-a-secret/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ndc-heartbeat-our-best-prospect-for-growth-remains-a-secret/">NDC Heartbeat: Our best prospect for growth remains a secret </a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-vi/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-vi/">Minding Your Legal Affairs XV: The employee’s rights Part VI</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/opening-statement-by-minister-for-foreign-affairs-peter-david-at-cofcor/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opening Statement by Minister for Foreign Affairs, Peter David at COFCOR" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/safe_image-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/opening-statement-by-minister-for-foreign-affairs-peter-david-at-cofcor/">Opening Statement by Minister for Foreign Affairs, Peter David at COFCOR</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://news.artnet.com/opinion/venice-biennale-financial-risk-1544065#new_tab"><div class="thumbnail-container size-500 "><img width="320" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada prepares for Biennale di Venezia" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/08/grenada-2018-artists.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://news.artnet.com/opinion/venice-biennale-financial-risk-1544065#new_tab">Great creative achievements demand great sacrifice</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/failed-coup-attempt-aided-by-us/"><div class="thumbnail-container size-500 "><img width="221" height="163" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Calypso Tent for SpiceMas 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/arlie-gill-e1397837815415.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/failed-coup-attempt-aided-by-us/">Failed coup attempt aided by US</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-v/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/minding-your-legal-affairs-xv-the-employees-rights-part-v/">Minding Your Legal Affairs XV: The employee’s rights Part V</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/vote-now-best-caribbean-travel-blog-posting/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Vote now: Best Caribbean Travel Blog Posting" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/02-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/vote-now-best-caribbean-travel-blog-posting/">Vote now: Best Caribbean Travel Blog Posting</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/oil-gas-our-patrimony-governments-secret-part-2/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/oil-gas-our-patrimony-governments-secret-part-2/">Oil &#038; gas, Our patrimony. Government’s secret Part 2</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Constitution Reform : The CCJ Convicts Itself!" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/">CCJ dismisses application against Barbados</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Managing Council elected to lead work of Grenada Chess Federation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">Managing Council elected to lead work of Grenada Chess Federation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container size-500 "><img width="231" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister impressed with Renegade Rum Distillery project" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-Tours-Renegade-Rum-Distillery-Project-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-impressed-with-renegade-rum-distillery-project/">Prime Minister impressed with Renegade Rum Distillery project</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Patricia-Scotland-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/commonwealth-secretary-statement-for-international-day-against-homophobia-transphobia-and-biphobia/">Commonwealth Secretary statement for International Day Against Homophobia, Transphobia and Biphobia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/"><div class="thumbnail-container size-500 "><img width="257" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/01/RGPF-e1473361423708.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/police-confirm-the-death-of-a-st-david-resident/">Police confirm the death of a St David resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Prime Minister turns sod for low-income housing project in Beausejour" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/Prime-Minister-and-Chinese-Ambassador-share-a-handshake-at-sod-turning-ceremony-in-Beausejour-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/prime-minister-turns-sod-for-low-income-housing-project-in-beausejour/">Prime Minister turns sod for low-income housing project in Beausejour</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="17 May is International Day Against Homophobia, Biphobia and Transphobia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/IDAHOT-GrenCHAP-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/05/17-may-is-international-day-against-homophobia-biphobia-and-transphobia/">17 May is International Day Against Homophobia, Biphobia and Transphobia</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/">
		        <img src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile@2x.png 2x" alt="NOW Grenada">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap post-autoload "  data-url="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/" data-title="Managing Council elected to lead work of Grenada Chess Federation" data-id="57843"  data-prev="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
<div id="vpp">
 
					<div class="bsaPopupWrapperBg bsaPopupWrapperBg-20 bsaHidden" style="display:none"></div>

					<div class="bsaPopupWrapper bsaPopupWrapper-20 bsaHidden" style="display:none">

						<div class="bsaPopupWrapperInner">
				<div id="bsa-html" class="bsaProContainer bsaProContainer-20 bsa-html bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=70&bsa_pro_url=https://www.thecommunalcu.com/" target="_blank"><video controls autoplay style="width:100%;">
<source src="https://www.nowgrenada.com/wp-content/uploads/2019/05/CCCU-MOBILE-BANKING-TVC4.mp4" width="1280px" height="720px" type="video/mp4">
</video></a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-20');
								var number_show_ads = "0";
								var number_hide_ads = "20";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div><span class="bsaPopupClose bsaPopupClose-20"></span></div>					<script>
						(function ($) {
							var ads = "1";
							if ( ads > 0 ) {
								var bsaPopupWrapperBg = $(".bsaPopupWrapperBg-20");
								var bsaPopupWrapper = $(".bsaPopupWrapper-20");
								var bsaBody = $("body");
								if (bsaPopupWrapper.hasClass('bsaClosed') === false) {
									setTimeout(function () {
//										bsaBody.css({
//											"overflow": "hidden",
//											"height": ( bsaBody.hasClass("logged-in") ) ? $(window).height() - 32 : $(window).height()
//										});
										bsaPopupWrapper.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
										bsaPopupWrapperBg.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
									}, 0);
								}
								$(document).ready(function () {
									var bsaPopupClose = $(".bsaPopupClose-20");
									bsaPopupClose.click(function () {
										bsaBody.css({"overflow": "visible", "height": "auto"});
										bsaPopupClose.addClass("animated zoomOut");
										bsaPopupWrapper.removeClass("fadeIn").addClass("animated fadeOut bsaClosed").fadeOut();
										bsaPopupWrapperBg.removeClass("fadeIn").addClass("animated fadeOut").fadeOut();
									});
									var number_close = "20";
									var number_show = "3";
									if ( number_close > 0 ) {
										bsaPopupWrapperBg.removeClass('animated');
										bsaPopupWrapper.removeClass('animated');
										setTimeout(function () {
											bsaPopupWrapperBg.fadeOut();
											bsaPopupWrapper.fadeOut();
										}, number_close * 1000);
									}
									if ( number_show > 0 ) {
										if ( number_show === 1000 ) {
											bsaPopupClose.remove();
										} else {
											bsaPopupClose.hide();
											setTimeout(function () {
												bsaPopupClose.fadeIn();
											}, number_show * 1000);
										}
									}
								});
							}
						})(jQuery);
					</script>
					<style>
																		.bsaPopupWrapperBg-20 {
							background-color: rgba(255,255,255,0.7);
						}
											</style>
				 </div> 
    <div class="container">
 
        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>
 
        <div class="row">
            <div class="jeg_main_content col-md-8">

               <div class="jeg_inner_content">

<div id="newad">
 <div id="bsa-block-720--300" class="bsaProContainer bsaProContainer-1 bsa-block-720--300 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Header</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=1" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=2&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1513607924-antillean-comp-plus-720x300_web-1.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "1";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "720";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-1 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-1');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					 </div>
                     
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                                                    </div>
                         
                        <div class="entry-header">

                            
                            <h1 class="jeg_post_title">Managing Council elected to lead work of Grenada Chess Federation</h1>
 
                             
                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

    <div class="meta_left">
        
                    <div class="jeg_meta_date">
                <a href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/">20 May 2019</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="https://www.nowgrenada.com/category/press-release/" rel="category tag">Press Release</a>, <a href="https://www.nowgrenada.com/category/sports/" rel="category tag">Sports</a>                </span>
            </div>
        
	    <div class="jeg_meta_reading_time">
			            <span>
			            	2 min read
			            </span>
			        </div>    </div>

    <div class="meta_right">
                    </div>
</div>
</div>
                        </div>
 
                        <div class="jeg_featured featured_image"><a href="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg"><img src="https://www.nowgrenada.com/wp-content/uploads/2019/05/chess-3839146_640.jpg" alt=""></a></div>                        <div class="now_featured_caption">
                                                </div>
                         
                        <div class="jeg_share_top_container"></div> 
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div> 
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Managing+Council+elected+to+lead+work+of+Grenada+Chess+Federation&url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="whatsapp://send?text=Managing+Council+elected+to+lead+work+of+Grenada+Chess+Federation%0Ahttps%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" rel='nofollow'  data-action="share/whatsapp/share"  class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
                <div class="share-secondary">
                    <a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" rel='nofollow'  class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="mailto:?subject=Managing+Council+elected+to+lead+work+of+Grenada+Chess+Federation&amp;body=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F05%2Fmanaging-council-elected-to-lead-work-of-grenada-chess-federation%2F" rel='nofollow'  class="jeg_btn-email "><i class="fa fa-envelope"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
            </div></div>                            </div>
 
                            <div class="content-inner ">
                                <p><strong>A managing council has been elected to lead the work of the Grenada Chess Federation (GCF) for the next 2 years.</strong></p>
<p>The managing council comprises Ruggles Ferguson – President; Carlyle Glean Jr. – Vice President; Kinna Marrast-Victor – General Secretary; Raheem Smith – Assistant General Secretary; Jarelle Amade – Treasurer; Terrance Smith – Assistant Treasurer; Nicole Gellineau – Public Relations Officer (PRO); and Terrance Slocombe – Assistant PRO.</p>
<p>The election of the managing council took place at a specially convened meeting on 16 May 2019 at the Grenada Olympic House. It follows the launch of the federation on 28 February 2019, during the visit to Grenada of Grandmaster Nigel Short MBE, the most celebrated chess player in the United Kingdom, once ranked No.3 in the world. An interim committee led the work of the federation following the 28 February launch.</p>
<p>The 16 May meeting also approved and adopted a Constitution for the GCF which will be seeking registration as a Not for Profit company, with all it funds to be used in the promotion and development of chess throughout Grenada, Carriacou and Petite Martinique.</p>
<p>President of the <a href="http://jamchess.com/" target="_blank" rel="noopener noreferrer">Jamaica Chess Federation</a>, Ian Wilkinson QC, who addressed the meeting via telephone, congratulated the GCF on its initiative and urged that much focus be given to the development of chess in schools as was done in Jamaica. Wilkinson, who is an honorary Vice President of the <a href="https://www.fide.com/" target="_blank" rel="noopener noreferrer">World Chess Federation</a> (FIDE) and the author of 2 books on chess, noted that in the past 10 years over 50,000 new players have emerged in Jamaica, chess being the fastest growing sport there.</p>
<p>The objectives of the GCF, as outlined in its new constitution, include protecting and advancing the interest of chess in Grenada Carriacou and Petite Martinique, and promoting chess in schools and communities.</p>
<p>Four committees have been established to facilitate the work of the federation: Tournaments, Marketing and Public Relations, Chess in Schools and Communities and Fundraising. Nicole Gellineau, in her capacity as PRO, heads the Marketing and Public Relations Committee, while Kwabena Amen and Jessie Greene head the Chess in Schools and Communities and the Tournament committees respectively. Someone is soon to be identified to head the Fundraising Committee.</p>
<p>High on the agenda of the newly launched federation is seeking affiliation with the Grenada Olympic Committee and the World Chess Federation.</p>
<p><em>Grenada Chess Federation</em></p>
                                 
                                 
                                                                <div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.nowgrenada.com/tag/grenada-chess-federation/" rel="tag">grenada chess federation</a><a href="https://www.nowgrenada.com/tag/ian-wilkinson/" rel="tag">ian wilkinson</a><a href="https://www.nowgrenada.com/tag/jamaica-chess-federation/" rel="tag">jamaica chess federation</a><a href="https://www.nowgrenada.com/tag/world-chess-federation/" rel="tag">world chess federation</a></div>
                                                            </div>

<!--Footer Banner by Andel March 28 2019 -->

 
                            <div class="jeg_share_bottom_container"></div> 
                                                    </div>
 
                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div  class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_57843_0_5ce32a0d808b6   " data-unique="jnews_module_57843_0_5ce32a0d808b6">
                <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
                    <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
                    
                </div>
                <div class="jeg_block_container">
                
                <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag"> 
                    <article class="jeg_post jeg_pl_md_5 post-57860 post type-post status-publish format-standard has-post-thumbnail hentry category-law category-press-release tag-caribbean-court-of-justice tag-glennor-gilbert tag-heads-of-government tag-lynnel-gilbert tag-revised-treaty-of-chaguaramas tag-right-to-freedom-of-movement tag-royston-gilbert tag-tamika-gilbert">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/"><div class="thumbnail-container animate-lazy  size-715 "><img width="240" height="240" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Grenada Constitution Reform : The CCJ Convicts Itself!" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj.jpg 240w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-150x150.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-144x144.jpg 144w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-38x38.jpg 38w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-186x186.jpg 186w, https://www.nowgrenada.com/wp-content/uploads/2014/06/ccj-184x184.jpg 184w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/law/" class="category-law">Law</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/">CCJ dismisses application against Barbados</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/05/ccj-dismisses-application-against-barbados/" ><i class="fa fa-clock-o"></i> 20 May 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-57852 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-politics category-press-release tag-antigua-observer tag-gaston-browne tag-liat tag-mia-mottley tag-shares">
                <div class="jeg_thumb">
                    
                    <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab"><div class="thumbnail-container animate-lazy  size-715 "><img width="321" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="PM Mitchell Suggests Ways To Make LIAT Successful" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline.jpg 400w, https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline-150x117.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2013/06/LIAT-Virtual-Airline-300x234.jpg 300w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/business/" class="category-business">Business</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab">Barbados willing to divest some of its LIAT shares</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab" ><i class="fa fa-clock-o"></i> 20 May 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-57846 post type-post status-publish format-standard has-post-thumbnail hentry category-agriculture category-environment category-press-release tag-bats tag-bees tag-biodiversity tag-butterflies tag-food-security tag-hummingbirds tag-pollinators tag-sustainable-development-goals tag-united-nations">
                <div class="jeg_thumb">
                    
                    <a href="https://www.un.org/en/events/beeday/#new_tab"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="World Bee Day 20 May" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-350x250.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-350x250.jpg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/05/animal-1685868_640-120x86.jpg 120w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/agriculture/" class="category-agriculture">Agriculture</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.un.org/en/events/beeday/#new_tab">World Bee Day 20 May</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.un.org/en/events/beeday/#new_tab" ><i class="fa fa-clock-o"></i> 20 May 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                <div class="jeg_block_loadmore ">
                    <a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a>
                </div>
                
            </div>
                
                <script>var jnews_module_57843_0_5ce32a0d808b6 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":57843,"include_category":"4923,12758,5180,8671,6,14,42,43,19395","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":"3","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_22"};</script>
            </div></div><div class='jnews-autoload-splitter'  data-url="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/" data-title="Managing Council elected to lead work of Grenada Chess Federation" data-id="57843"  data-prev="https://antiguaobserver.com/barbados-willing-to-divest-some-of-its-liat-shares/#new_tab" ></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.nowgrenada.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='57843' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="dbca114369" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="138"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
                    
<!--FB Comments by Andel March 12 2019 -->
<div style="" id="the_champ_fb_commenting"><div class="fb-comments" data-href="https://www.nowgrenada.com/2019/05/managing-council-elected-to-lead-work-of-grenada-chess-federation/" data-numposts="" data-width="100%" ></div></div><script type="text/javascript" src="//connect.facebook.net/en_GB/sdk.js
    "></script><script>FB.init({xfbml:1,version: "v3.2"});</script>
                </div>
            </div>
            
<div class="jeg_sidebar   col-md-4">
    <div class="widget widget_text" id="text-2">			<div class="textwidget"><p><div id="bsa-block-300--250" class="bsaProContainer bsaProContainer-8 bsa-block-300--250 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Sidebar 300x250</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=8" target="_blank" style="color:" rel="noopener noreferrer"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=12&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1514819661-Grenlec_WebBNR_EV_300x250_motion.gif&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "8";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "250";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-8 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-8');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					<br />
<!-- Article Sidebar 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x90--><br />
<br />
<!-- Article Sidebar 300x300 --><br />
<div id="bsa-block-300--300" class="bsaProContainer bsaProContainer-16 bsa-block-300--300 bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=73&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1557838732-GrenFresh-ad-GM.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "16";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-16');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</p>
<p><!-- Article Sidebar 300x750 --><br />
</p>
</div>
		</div><div class="widget_text widget widget_custom_html" id="custom_html-7"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget_text widget widget_custom_html" id="custom_html-6"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget widget_awesomeweatherwidget" id="awesomeweatherwidget-4"><div id="awesome-weather-grenada-gd" class="awesome-weather-wrap awecf awe_tall temp6 awe_with_stats awe-code-801 awe-desc-few-clouds awe-preset-cloudy darken" style=" color: #ffffff; "><div class="awesome-weather-cover" style='background-image: url(https://www.nowgrenada.com/wp-content/plugins/awesome-weather/img/awe-backgrounds/cloudy.jpg);'><div class="awesome-weather-header">Grenada</div><div class="awesome-weather-current-temp"><strong>29<sup>&deg;</sup></strong></div><!-- /.awesome-weather-current-temp --><div class="awesome-weather-todays-stats"><div class="awe_desc">few clouds</div><div class="awe_humidty">humidity: 70%</div><div class="awe_wind">wind: 5m/s ESE</div><div class="awe_highlow">H 29 &bull; L 28</div></div><!-- /.awesome-weather-todays-stats --><div class="awesome-weather-forecast awe_days_4 awecf">
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">29<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Tue</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Wed</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Thu</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Fri</div>
				</div></div><!-- /.awesome-weather-forecast --><div class="awesome-weather-attribution">Weather from OpenWeatherMap</div></div><!-- /.awesome-weather-cover --></div> <!-- /.awesome-weather-wrap --></div></div>        </div>
 
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>
 
    </div>
</div>                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-57843 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-5.7 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_custom">
    <div class="jeg_container">
        <div class="jeg_content">
            <div class="jeg_vc_content">
                <div data-vc-full-width="true" data-vc-full-width-init="false" class="row vc_row vc_custom_1512030979094 vc_row-has-fill jnews_5ce32a0d88e1e footer_dark"><div class="jeg-vc-wrapper"><div class="footer_left wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper">
	<div class="wpb_text_column wpb_content_element  vc_custom_1551598731654 copyright" >
		<div class="wpb_wrapper">
			<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>

		</div>
	</div>
</div></div><div class="footer_right wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper"><div  class='jeg_social_icon_block socials_widget jnews_module_57843_1_5ce32a0d89a94 nobg '><a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div>
            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56"><a href="http://nowgrenada.com">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.nowgrenada.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55527"><a href="https://www.nowgrenada.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://www.nowgrenada.com/category/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273"><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527"><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297"><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022"><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298"><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260"><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = []</script><div class="jnews-cookie-law-policy">This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a>. <button data-expire="100" class="btn btn-cookie">I Agree</button></div><div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/datepicker.min.js'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"d MM yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-auto-load-post/assets/js/jquery.autoload.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-js.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/hoverIntent.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","lang":"en_GB","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"57843","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"1","autoload_limit":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/html5shiv.min.js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/page-links-to/js/new-tab.min.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/super-socializer/js/front/social_login/general.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div></body>
</html>

<!-- Dynamic page generated in 0.529 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-05-20 18:28:29 -->

<!-- super cache -->