<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.nowgrenada.com/xmlrpc.php" />
    <title>Grenadian participates in US Government-Sponsored International Visitor Leadership Programme | NOW Grenada</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* allerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }


	/* Custom CSS */
	.bsaProContainer .bsaProHeader {
    display: none;
}

.owl-controls {
    display: none !important;
} 

#bsa-block-720—300 {
max-width: 300px;
}

@media only screen and (min-width: 900px) {
.bsaPopupClose {
    position: absolute;
    cursor: pointer;
    top: 150px;
    right: 320px;
    width: 25px;
    height: 25px;
    background: url(../../img/close-black.png) white center center no-repeat;
}
}

</style>	<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
		<script type="text/javascript">var theChampDefaultLang = 'en_GB', theChampCloseIconPath = 'https://www.nowgrenada.com/wp-content/plugins/super-socializer/images/close.png';var heateorSsSDKBlockedMsg = `Your browser is blocking some features of this website. Please follow the instructions at <a href=\'http://support.heateor.com/browser-blocking-social-features/\' target=\'_blank\' style=\'color:#33a9d8\'>http://support.heateor.com/browser-blocking-social-features/</a> to unblock these.`</script>
		<script> var theChampSiteUrl = 'https://www.nowgrenada.com', theChampVerified = 0, theChampEmailPopup = 0; </script>
		<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.heateor_ss_mobile_footer{display:none;}@media screen and (max-width:783px){i.theChampTCBackground{background-color:white!important}div.the_champ_bottom_sharing{width:100%!important;left:0!important;}div.the_champ_bottom_sharing li{width:11.111111111111% !important;}div.the_champ_bottom_sharing .theChampSharing{width: 100% !important;}div.the_champ_bottom_sharing div.theChampTotalShareCount{font-size:1em!important;line-height:28px!important}div.the_champ_bottom_sharing div.theChampTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_ss_mobile_footer{display:block;height:40px;}.the_champ_bottom_sharing{padding:0!important;display:block!important;width: auto!important;bottom:-2px!important;top: auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height: inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right: 1.1em !important}}</style>
	            <script type="text/javascript"> var jnews_ajax_url = 'https://www.nowgrenada.com/?ajax-request=jnews'; </script>
            
<!-- All in One SEO Pack 3.1.1 by Michael Torbert of Semper Fi Web Design[989,1108] -->
<meta name="description"  content="&quot;Brendon La Touche is currently in the United States participating on the US Department of State&#039;s International Visitor Leadership Programme (IVLP).&quot;" />

<link rel="canonical" href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Feed" href="https://www.nowgrenada.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Comments Feed" href="https://www.nowgrenada.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Grenadian participates in US Government-Sponsored International Visitor Leadership Programme Comments Feed" href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.nowgrenada.com/wp-includes/css/dist/block-library/style.min.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='https://www.nowgrenada.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/style.css?v=4.1&#038;ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/user-panel.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/all.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/animate.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/chart.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_owl_carousel_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/bsa.carousel.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/material-design.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.nowgrenada.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='jnews-parent-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/style.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/super-socializer/css/front.css?ver=7.12.30' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.3' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jeg-dynamic-style-css'  href='https://www.nowgrenada.com/wp-content/uploads/jeg/jeg-uKqO0nrEYp.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='otw-shortcode-css'  href='https://www.nowgrenada.com/wp-content/plugins/lists-shortcode-and-widget//include/otw_components/otw_shortcode/css/otw_shortcode.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/shortcode.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-admin/js/media-upload.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/script.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/chart.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/bsa.carousel.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/custom.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.nowgrenada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nowgrenada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nowgrenada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Public Notice: Parliamentary Elections Office' href='https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/' />
<link rel='next' title='Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit' href='https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/' />

<link rel='shortlink' href='https://www.nowgrenada.com/?p=59341' />
<link rel="alternate" type="application/json+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F&#038;format=xml" />
<!-- Analytics by WP-Statistics v12.6.7 - https://wp-statistics.com/ -->
<script>var WP_Statistics_http = new XMLHttpRequest();WP_Statistics_http.open('POST', 'https://www.nowgrenada.com/wp-json/wpstatistics/v1/hit?_=1562640819', true);WP_Statistics_http.setRequestHeader("Content-Type", "application/x-www-form-urlencoded");WP_Statistics_http.send("wp_statistics_hit=" + JSON.stringify({"base":"https://www.nowgrenada.com/wp-json","browser":"Chrome","platform":"Windows","version":"10.0","referred":"https://www.nowgrenada.com","api":"wp-json","ip":"34.236.154.136","hash_ip":"#hash#8fa73143461adfb73c1ce4e5aa0a42c39b11e650","exclude":"","exclude_reason":"","ua":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36","track_all":"1","timestamp":"1562626419","search_query":"","current_page_type":"post","current_page_id":"59341","page_uri":"/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/","user_id":"0"}));</script>
      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.nowgrenada.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e0fbff27-0ea3-4e3f-a8d9-a4c7eac9ccc8';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "NOW Grenada";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing to nowgrenada.com!";
oneSignal_options['welcomeNotification']['url'] = "https://www.nowgrenada.com";
oneSignal_options['path'] = "https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4463433a-b41c-4a34-809b-879a9d93883b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'wants to show Notifications';
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Example Notification Title';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Notifications will appear on your desktop';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Example Notification';
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = 'Notifications will appear on your mobile';
oneSignal_options['promptOptions']['exampleNotificationCaption'] = '(you can unsubscribe anytime)';
oneSignal_options['promptOptions']['acceptButtonText'] = 'CONTINUE';
oneSignal_options['promptOptions']['cancelButtonText'] = 'NO THANKS';
oneSignal_options['promptOptions']['siteName'] = 'http://www.nowgrenada.com';
oneSignal_options['promptOptions']['autoAcceptTitle'] = 'Click Allow';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-75x75.png" sizes="32x32" />
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.nowgrenada.com/wp-content/uploads/2019/03/fav-e1551811155633-300x300.png" />
		<style type="text/css" id="wp-custom-css">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</style>
		<style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1512030979094{padding-top: 20px !important;padding-bottom: 20px !important;background-color: #212121 !important;}.vc_custom_1551598731654{margin-bottom: 0px !important;}</style><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<!-- START - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="NOW Grenada"/>
  <meta property="og:title" content="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme"/>
  <meta property="og:url" content="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="“Brendon La Touche is currently in the United States participating on the US Department of State’s International Visitor Leadership Programme (IVLP).”"/>
  <meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"/>
  <meta property="og:image:url" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"/>
  <meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"/>
  <meta property="article:published_time" content="2019-07-08T17:37:18-04:00"/>
  <meta property="article:modified_time" content="2019-07-08T17:37:18-04:00" />
  <meta property="og:updated_time" content="2019-07-08T17:37:18-04:00" />
  <meta property="article:section" content="Law"/>
  <meta property="article:section" content="Press Release"/>
  <meta property="article:publisher" content="https://www.facebook.com/NowGrenada/"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme"/>
  <meta itemprop="headline" content="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme"/>
  <meta itemprop="description" content="“Brendon La Touche is currently in the United States participating on the US Department of State’s International Visitor Leadership Programme (IVLP).”"/>
  <meta itemprop="image" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"/>
  <meta itemprop="datePublished" content="2019-07-08"/>
  <meta itemprop="dateModified" content="2019-07-08T17:37:18-04:00" />
  <meta itemprop="author" content="NOW Grenada"/>
  <!--<meta itemprop="publisher" content="NOW Grenada"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme"/>
  <meta name="twitter:url" content="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/"/>
  <meta name="twitter:description" content="“Brendon La Touche is currently in the United States participating on the US Department of State’s International Visitor Leadership Programme (IVLP).”"/>
  <meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@nowgrenada"/>
 <!-- SEO -->
  <meta name="description" content="“Brendon La Touche is currently in the United States participating on the US Department of State’s International Visitor Leadership Programme (IVLP).”"/>
  <meta name="publisher" content="NOW Grenada"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
	
</head>
<body class="post-template-default single single-post postid-59341 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.3 vc_responsive">

    
            <div id="jeg_sidecontent">
            <div class="jeg_side_heading">
                <ul class="jeg_side_tabs">
                    <li data-tab-content="tab1" data-sort='latest' class="active">Latest</li>                </ul>
                <div class="jeg_side_feed_cat_wrapper">
                                    </div>
                <script> var side_feed = {"paged":1,"post_type":"post","exclude_post":59341,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":12,"number_post":12,"pagination_mode":"loadmore"}; </script>            </div>

            <div class="sidecontent_postwrapper">
                <div class="jeg_sidefeed">
                    <div class="jeg_post jeg_pl_md_box active " data-id="59341" data-sequence="0">
                        <div class="overlay_container">
                            <div class="jeg_thumb">
                                
                                <a class="ajax" href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10-360x180.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10-360x180.jpg 360w, https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10-750x375.jpg 750w" data-expand="700" /></div></a>
                            </div>
                            <div class="jeg_postblock_content">
                                <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/">Grenadian participates in US Government-Sponsored International Visitor Leadership Programme</a></h2>
                                <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 5 hours ago</div></div>
                            </div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59344" data-sequence="1">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-100x100.jpg 100w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-571x570.jpg 571w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/">Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 5 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59265" data-sequence="2">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="70" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="New Acting Chief Education Officer" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg 596w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826-150x140.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826-300x280.jpg 300w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/">Public Notice: Parliamentary Elections Office</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 6 hours ago</div></div>
                        </div>
                    </div><div class="jeg_ad jnews_sidefeed_ads"><div class='ads-wrapper jeg_ad_sidecontent '></div></div><div class="jeg_post jeg_pl_xs_3  " data-id="59328" data-sequence="3">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 8 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59314" data-sequence="4">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Father Mallaghan’s Home for Boys receives financial support to start poultry rearing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/">Father Mallaghan’s Home for Boys receives financial support to start poultry rearing</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 8 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59299" data-sequence="5">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="New Dimension dedicates Pan Xpression win to fallen comrade" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2894-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2894-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2894-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/">New Dimension dedicates Pan Xpression win to fallen comrade</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59296" data-sequence="6">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="60" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="CARICOM examines the free movement of Haitians" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada.jpg 400w, https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada-150x120.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada-300x240.jpg 300w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab">Credible accounts of gross human rights violations in Haiti must be addressed by CARICOM</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 11 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59293" data-sequence="7">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Waterwheels, windmills and aqueducts of Grenada and Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/">Waterwheels, windmills and aqueducts of Grenada and Carriacou</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 12 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59279" data-sequence="8">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Jamaica stands firm against push by other Caricom states" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/jamaica-flag-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/jamaica-flag-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/jamaica-flag-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab">Jamaica stands firm against push by other Caricom states</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 day ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59274" data-sequence="9">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="56" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="22% Decline in Cruise Passengers Recorded for 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal-150x112.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal-300x225.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal-600x450.jpg 600w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab">Call for Caribbean governments to tax cruise sector more and tax air passengers less</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59271" data-sequence="10">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Quebec’s only official celebration of Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab">Quebec’s only official celebration of Grenada</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="53358" data-sequence="11">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/this-day-in-history-32-2-2/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="56" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="This Day in History" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/07/image003.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/07/image003.png 500w, https://www.nowgrenada.com/wp-content/uploads/2013/07/image003-150x111.png 150w, https://www.nowgrenada.com/wp-content/uploads/2013/07/image003-300x223.png 300w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/this-day-in-history-32-2-2/">This Day in History</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="59256" data-sequence="12">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="56" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Ridge to Reef and MNIB launch Pest Management Project" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641-150x113.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641-300x225.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641-768x576.jpg 768w, https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641-600x450.jpg 600w, https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641-770x578.jpg 770w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/">Work towards developing governance structure for Grenada’s soursop industry</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 days ago</div></div>
                        </div>
                    </div>                </div>
                <div class="sidefeed_loadmore">
                    <button class="btn " data-end="End of Content" data-loading="Loading..." data-loadmore="Load More">
                        Load More                    </button>
                </div>
            </div>
            <div class="jeg_sidefeed_overlay">
                <div class='preloader_type preloader_dot'>
                    <div class="sidefeed-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="sidefeed-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="sidefeed-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
        </div>


    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/" style="padding: 0 0 0 0;">
	    	    <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2@2x.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_logo_desktop2@2x.png 2x" data-dark-src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '><div class='ads_shortcode'><div id="bsa-html" class="bsaProContainer bsaProContainer-10 bsa-html bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Footer 468x60</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=10" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=15&bsa_pro_url=http://netherlands.co.gd" target="_blank"><img class="netherlands-ad" src="https://www.nowgrenada.com/wp-content/uploads/2017/12/banner468x60Netherlands1.gif" title="Netherlands" styles="margin-bottom: 25px !important;"/>
<div class="spacer"></div>
</a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56 bgnav" data-item-row="default" ><a href="http://nowgrenada.com">Front Page</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Father Mallaghan’s Home for Boys receives financial support to start poultry rearing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/">Father Mallaghan’s Home for Boys receives financial support to start poultry rearing</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab"><div class="thumbnail-container size-500 "><img width="299" height="168" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Jamaica stands firm against push by other Caricom states" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/jamaica-flag.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab">Jamaica stands firm against push by other Caricom states</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="22% Decline in Cruise Passengers Recorded for 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab">Call for Caribbean governments to tax cruise sector more and tax air passengers less</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Ridge to Reef and MNIB launch Pest Management Project" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/">Work towards developing governance structure for Grenada’s soursop industry</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Focus on soursop, nutmeg and cocoa for plant distribution season" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/PLANT-PHOTO-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/">Focus on soursop, nutmeg and cocoa for plant distribution season</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GTA and partners complete major cleanup of the St George’s Market" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/GTA-and-Partners-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/">GTA and partners complete major cleanup of the St George’s Market</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FCCA Foundation Competitions Call for Entries" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/FCCA_3_.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/">FCCA Foundation for the Caribbean 2019 Children’s Essay Contest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/imf-executive-board-concludes-2019-article-iv-consultation-with-grenada/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="IMF Assisting PFM Revision" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/04/IMF-logo-e1463149259947.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/imf-executive-board-concludes-2019-article-iv-consultation-with-grenada/">IMF Executive Board Concludes 2019 Article IV Consultation with Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-55527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenada-takes-4-medals-at-the-2019-cccan-swim-championship/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada takes 4 Medals at the 2019 CCCAN Swim Championship" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/f014654f-079a-4eac-9e5f-45036e364481-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenada-takes-4-medals-at-the-2019-cccan-swim-championship/">Grenada takes 4 Medals at the 2019 CCCAN Swim Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/spice-girlz-to-defend-their-wifa-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GFA delegation attends FIFA and CONCACAF Congress in France" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Grenada-Football-Association-at-90-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/spice-girlz-to-defend-their-wifa-title/">Spice Girlz to defend their WIFA title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/">14-member swim team competes at CCCAN in Barbados</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/the-energy-of-gouyave-history-of-sports-in-the-parish-of-st-john/"><div class="thumbnail-container size-500 "><img width="354" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The energy of Gouyave: History of sports in the parish of St John" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/IMG-20190620-WA0013-1-354x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/the-energy-of-gouyave-history-of-sports-in-the-parish-of-st-john/">The energy of Gouyave: History of sports in the parish of St John</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/gnba-holds-general-election/"><div class="thumbnail-container size-500 "><img width="318" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GNBA holds general election" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/GNBA-318x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/gnba-holds-general-election/">GNBA holds general election</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/grenadas-future-champions-at-inter-primary-school-swim-meet-2019/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada’s Future Champions at Inter-primary School Swim Meet, 2019" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/CIBCSwimMeet-Champ-Girls-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/grenadas-future-champions-at-inter-primary-school-swim-meet-2019/">Grenada’s Future Champions at Inter-primary School Swim Meet, 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/mt-cinnamon-sponsors-school-learn-to-swim-week-again/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Mt Cinnamon sponsors school Learn to Swim Week again!" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Mark-Scott-Director-Mt.-Cinnamon-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/mt-cinnamon-sponsors-school-learn-to-swim-week-again/">Mt Cinnamon sponsors school Learn to Swim Week again!</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/spice-girls-announced-for-oecs-netball-series/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Girls announced for OECS Netball Series" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/SPICE_GIRLS_OECS_SENIOR_TEAM_GRN-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/spice-girls-announced-for-oecs-netball-series/">Spice Girls announced for OECS Netball Series</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://girlsinsports758.wixsite.com/girlsinsports/home/grenadian-basketballer-sasha-mcvean#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian basketballer Sashanna Mcvean" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Sashanna-Mcvean-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://girlsinsports758.wixsite.com/girlsinsports/home/grenadian-basketballer-sasha-mcvean#new_tab">Grenadian basketballer Sashanna Mcvean</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Father Mallaghan’s Home for Boys receives financial support to start poultry rearing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/">Father Mallaghan’s Home for Boys receives financial support to start poultry rearing</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GTA and partners complete major cleanup of the St George’s Market" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/GTA-and-Partners-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/">GTA and partners complete major cleanup of the St George’s Market</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FCCA Foundation Competitions Call for Entries" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/FCCA_3_.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/">FCCA Foundation for the Caribbean 2019 Children’s Essay Contest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Visitor to Prison Caught With Marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/prison.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/">New rehabilitation programme launches at Her Majesty’s Prisons</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/radisson-grenada-renovates-some-of-pams-infrastructure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Radisson Grenada renovates some of PAM’s infrastructure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2815-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/radisson-grenada-renovates-some-of-pams-infrastructure/">Radisson Grenada renovates some of PAM’s infrastructure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.newsshopper.co.uk/news/17741373.plaque-unveiled-at-lewisham-police-station-for-kick-it-out-co-founder/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian Asquith Gibbes commemorative plaque at Lewisham Police Station" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Asquith-Gibbes--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.newsshopper.co.uk/news/17741373.plaque-unveiled-at-lewisham-police-station-for-kick-it-out-co-founder/#new_tab">Grenadian Asquith Gibbes commemorative plaque at Lewisham Police Station</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/pure-grenada-culinary-team-returns-with-caribbean-national-team-bronze/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Pure Grenada culinary team returns with Caribbean National Team bronze" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/IMG_2708-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/pure-grenada-culinary-team-returns-with-caribbean-national-team-bronze/">Pure Grenada culinary team returns with Caribbean National Team bronze</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/">14-member swim team competes at CCCAN in Barbados</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Dimension dedicates Pan Xpression win to fallen comrade" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2894-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/">New Dimension dedicates Pan Xpression win to fallen comrade</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Waterwheels, windmills and aqueducts of Grenada and Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/">Waterwheels, windmills and aqueducts of Grenada and Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Quebec’s only official celebration of Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab">Quebec’s only official celebration of Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Visitor to Prison Caught With Marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/prison.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/">New rehabilitation programme launches at Her Majesty’s Prisons</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.caribbeanlifenews.com/stories/2019/7/2019-07-05-nk-kings-county-caribbean-heritage-month-cl.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Kings County Brooklyn courts celebrate 3rd Annual Caribbean Heritage Month" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/2019-07-05-nk-kings-county-caribbean-heritage-month-cl01_z-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.caribbeanlifenews.com/stories/2019/7/2019-07-05-nk-kings-county-caribbean-heritage-month-cl.html#new_tab">Kings County Brooklyn courts celebrate 3rd Annual Caribbean Heritage Month</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenada-participates-in-international-festival-of-geography/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada participates in International Festival of Geography" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/44050100_2740669099292512_5535558811219132416_o-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenada-participates-in-international-festival-of-geography/">Grenada participates in International Festival of Geography</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/rgpf-carnival-operations-include-execution-of-commitment-warrants-and-fine-collection/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF carnival operations include execution of commitment warrants and fine collection" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/ACP-Prince-surrounded-by-other-high-ranking-officers-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/rgpf-carnival-operations-include-execution-of-commitment-warrants-and-fine-collection/">RGPF carnival operations include execution of commitment warrants and fine collection</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/island-life-with-ginger-rankin/"><div class="thumbnail-container size-500 "><img width="333" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Island Life with Ginger Rankin" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/spice-island-1-333x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/island-life-with-ginger-rankin/">Island Life with Ginger Rankin</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.essence.com/feature/vanessa-james-history-carnival-fete/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Vanessa James goes behind the fete to discover the history of carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Grenada-Spicemas.-The-famous-Jab-Jab-experinece-on-Jouvert-Morning-Photog-Arthur-Daniel20-copy-1-1200x800-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.essence.com/feature/vanessa-james-history-carnival-fete/#new_tab">Vanessa James goes behind the fete to discover the history of carnival</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab"><div class="thumbnail-container size-500 "><img width="225" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="CARICOM examines the free movement of Haitians" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab">Credible accounts of gross human rights violations in Haiti must be addressed by CARICOM</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/ndc-heartbeat-our-crumbling-infrastructure/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/ndc-heartbeat-our-crumbling-infrastructure/">NDC Heartbeat: Our crumbling infrastructure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/ndc-heartbeat-theyve-started-a-fight-cant-afford-it/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/ndc-heartbeat-theyve-started-a-fight-cant-afford-it/">NDC Heartbeat: They’ve started a fight &#038; can’t afford it</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/minding-your-legal-affairs-what-happens-when-you-give-a-mortgage-over-your-property/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/minding-your-legal-affairs-what-happens-when-you-give-a-mortgage-over-your-property/">Minding your legal Affairs: What happens when you give a mortgage over your property</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/long-overdue-a-national-heroes-day/"><div class="thumbnail-container size-500 "><img width="129" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance, Thanksgiving &#038; National Heroes" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/10/T-A-Marryshow-cropped.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/long-overdue-a-national-heroes-day/">Long overdue: A National Heroes Day</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://matadornetwork.com/change/to-hell-with-good-intentions/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/grenada-crafts-centre-st.-georges.-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://matadornetwork.com/change/to-hell-with-good-intentions/#new_tab">To hell with good intentions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/06/17/taking-a-look-within/#new_tab"><div class="thumbnail-container size-500 "><img width="232" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Chester Humphrey continues to be in charge" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/Chester-Humphrey-450x350-275x213.gif.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/06/17/taking-a-look-within/#new_tab">Taking a look within</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/grenadians-being-covetous-a-symptom-of-a-grave-issue/"><div class="thumbnail-container size-500 "><img width="360" height="153" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Your opinion is important" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/01/grenada-flag-01.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/grenadians-being-covetous-a-symptom-of-a-grave-issue/">Grenadians being covetous: A symptom of a grave issue</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/theyve-started-a-fight-and-cant-afford-it/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/theyve-started-a-fight-and-cant-afford-it/">They’ve started a fight and can’t afford it</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-56527" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/">Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/">Grenadian participates in US Government-Sponsored International Visitor Leadership Programme</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/"><div class="thumbnail-container size-500 "><img width="193" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Acting Chief Education Officer" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/">Public Notice: Parliamentary Elections Office</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Waterwheels, windmills and aqueducts of Grenada and Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/">Waterwheels, windmills and aqueducts of Grenada and Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Quebec’s only official celebration of Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab">Quebec’s only official celebration of Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Ridge to Reef and MNIB launch Pest Management Project" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/">Work towards developing governance structure for Grenada’s soursop industry</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Focus on soursop, nutmeg and cocoa for plant distribution season" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/PLANT-PHOTO-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/">Focus on soursop, nutmeg and cocoa for plant distribution season</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/ecse-vacancy-it-technician/"><div class="thumbnail-container size-500 "><img width="360" height="95" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="ECSE Vacancy – IT Technician" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/ECSE-360x95.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/ecse-vacancy-it-technician/">ECSE Vacancy – IT Technician</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-12022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li id="menu-item-10298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li id="menu-item-24260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56 bgnav" data-item-row="default" ><a href="http://nowgrenada.com">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Father Mallaghan’s Home for Boys receives financial support to start poultry rearing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/">Father Mallaghan’s Home for Boys receives financial support to start poultry rearing</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab"><div class="thumbnail-container size-500 "><img width="299" height="168" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Jamaica stands firm against push by other Caricom states" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/jamaica-flag.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.jamaicaobserver.com/news/jamaica-stands-firm-against-push-by-other-caricom-states_169283#new_tab">Jamaica stands firm against push by other Caricom states</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="22% Decline in Cruise Passengers Recorded for 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/02/Cruise-ships-berth-at-the-Esplanade-cruise-Terminal.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.eturbonews.com/257439/a-call-for-caribbean-governments-to-tax-cruise-sector-more-and-tax-air-passengers-less/#new_tab">Call for Caribbean governments to tax cruise sector more and tax air passengers less</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Ridge to Reef and MNIB launch Pest Management Project" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/">Work towards developing governance structure for Grenada’s soursop industry</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Focus on soursop, nutmeg and cocoa for plant distribution season" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/PLANT-PHOTO-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/">Focus on soursop, nutmeg and cocoa for plant distribution season</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GTA and partners complete major cleanup of the St George’s Market" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/GTA-and-Partners-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/">GTA and partners complete major cleanup of the St George’s Market</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FCCA Foundation Competitions Call for Entries" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/FCCA_3_.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/">FCCA Foundation for the Caribbean 2019 Children’s Essay Contest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/imf-executive-board-concludes-2019-article-iv-consultation-with-grenada/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="IMF Assisting PFM Revision" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/04/IMF-logo-e1463149259947.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/imf-executive-board-concludes-2019-article-iv-consultation-with-grenada/">IMF Executive Board Concludes 2019 Article IV Consultation with Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenada-takes-4-medals-at-the-2019-cccan-swim-championship/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada takes 4 Medals at the 2019 CCCAN Swim Championship" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/f014654f-079a-4eac-9e5f-45036e364481-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenada-takes-4-medals-at-the-2019-cccan-swim-championship/">Grenada takes 4 Medals at the 2019 CCCAN Swim Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/spice-girlz-to-defend-their-wifa-title/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GFA delegation attends FIFA and CONCACAF Congress in France" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Grenada-Football-Association-at-90-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/spice-girlz-to-defend-their-wifa-title/">Spice Girlz to defend their WIFA title</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/">14-member swim team competes at CCCAN in Barbados</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/the-energy-of-gouyave-history-of-sports-in-the-parish-of-st-john/"><div class="thumbnail-container size-500 "><img width="354" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="The energy of Gouyave: History of sports in the parish of St John" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/IMG-20190620-WA0013-1-354x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/the-energy-of-gouyave-history-of-sports-in-the-parish-of-st-john/">The energy of Gouyave: History of sports in the parish of St John</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/gnba-holds-general-election/"><div class="thumbnail-container size-500 "><img width="318" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GNBA holds general election" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/GNBA-318x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/gnba-holds-general-election/">GNBA holds general election</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/grenadas-future-champions-at-inter-primary-school-swim-meet-2019/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada’s Future Champions at Inter-primary School Swim Meet, 2019" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/CIBCSwimMeet-Champ-Girls-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/grenadas-future-champions-at-inter-primary-school-swim-meet-2019/">Grenada’s Future Champions at Inter-primary School Swim Meet, 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/mt-cinnamon-sponsors-school-learn-to-swim-week-again/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Mt Cinnamon sponsors school Learn to Swim Week again!" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Mark-Scott-Director-Mt.-Cinnamon-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/mt-cinnamon-sponsors-school-learn-to-swim-week-again/">Mt Cinnamon sponsors school Learn to Swim Week again!</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/spice-girls-announced-for-oecs-netball-series/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Girls announced for OECS Netball Series" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/SPICE_GIRLS_OECS_SENIOR_TEAM_GRN-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/spice-girls-announced-for-oecs-netball-series/">Spice Girls announced for OECS Netball Series</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://girlsinsports758.wixsite.com/girlsinsports/home/grenadian-basketballer-sasha-mcvean#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian basketballer Sashanna Mcvean" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/Sashanna-Mcvean-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://girlsinsports758.wixsite.com/girlsinsports/home/grenadian-basketballer-sasha-mcvean#new_tab">Grenadian basketballer Sashanna Mcvean</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Father Mallaghan’s Home for Boys receives financial support to start poultry rearing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2831-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/father-mallaghans-home-for-boys-receives-financial-support-to-start-poultry-rearing/">Father Mallaghan’s Home for Boys receives financial support to start poultry rearing</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GTA and partners complete major cleanup of the St George’s Market" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/GTA-and-Partners-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/gta-and-partners-complete-major-cleanup-of-the-st-georges-market/">GTA and partners complete major cleanup of the St George’s Market</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FCCA Foundation Competitions Call for Entries" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/FCCA_3_.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fcca-foundation-for-the-caribbean-2019-childrens-essay-contest/">FCCA Foundation for the Caribbean 2019 Children’s Essay Contest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Visitor to Prison Caught With Marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/prison.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/">New rehabilitation programme launches at Her Majesty’s Prisons</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/radisson-grenada-renovates-some-of-pams-infrastructure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Radisson Grenada renovates some of PAM’s infrastructure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2815-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/radisson-grenada-renovates-some-of-pams-infrastructure/">Radisson Grenada renovates some of PAM’s infrastructure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.newsshopper.co.uk/news/17741373.plaque-unveiled-at-lewisham-police-station-for-kick-it-out-co-founder/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian Asquith Gibbes commemorative plaque at Lewisham Police Station" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Asquith-Gibbes--360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.newsshopper.co.uk/news/17741373.plaque-unveiled-at-lewisham-police-station-for-kick-it-out-co-founder/#new_tab">Grenadian Asquith Gibbes commemorative plaque at Lewisham Police Station</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/pure-grenada-culinary-team-returns-with-caribbean-national-team-bronze/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Pure Grenada culinary team returns with Caribbean National Team bronze" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/IMG_2708-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/pure-grenada-culinary-team-returns-with-caribbean-national-team-bronze/">Pure Grenada culinary team returns with Caribbean National Team bronze</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/14-member-swim-team-competes-at-cccan-in-barbados/">14-member swim team competes at CCCAN in Barbados</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Dimension dedicates Pan Xpression win to fallen comrade" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IMG_2894-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-dimension-dedicates-pan-xpression-win-to-fallen-comrade/">New Dimension dedicates Pan Xpression win to fallen comrade</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Waterwheels, windmills and aqueducts of Grenada and Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/">Waterwheels, windmills and aqueducts of Grenada and Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Quebec’s only official celebration of Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab">Quebec’s only official celebration of Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Visitor to Prison Caught With Marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/prison.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/new-rehabilitation-programme-launches-at-her-majestys-prisons/">New rehabilitation programme launches at Her Majesty’s Prisons</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.caribbeanlifenews.com/stories/2019/7/2019-07-05-nk-kings-county-caribbean-heritage-month-cl.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Kings County Brooklyn courts celebrate 3rd Annual Caribbean Heritage Month" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/2019-07-05-nk-kings-county-caribbean-heritage-month-cl01_z-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.caribbeanlifenews.com/stories/2019/7/2019-07-05-nk-kings-county-caribbean-heritage-month-cl.html#new_tab">Kings County Brooklyn courts celebrate 3rd Annual Caribbean Heritage Month</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenada-participates-in-international-festival-of-geography/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada participates in International Festival of Geography" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/44050100_2740669099292512_5535558811219132416_o-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenada-participates-in-international-festival-of-geography/">Grenada participates in International Festival of Geography</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/rgpf-carnival-operations-include-execution-of-commitment-warrants-and-fine-collection/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="RGPF carnival operations include execution of commitment warrants and fine collection" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/ACP-Prince-surrounded-by-other-high-ranking-officers-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/rgpf-carnival-operations-include-execution-of-commitment-warrants-and-fine-collection/">RGPF carnival operations include execution of commitment warrants and fine collection</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/island-life-with-ginger-rankin/"><div class="thumbnail-container size-500 "><img width="333" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Island Life with Ginger Rankin" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/spice-island-1-333x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/island-life-with-ginger-rankin/">Island Life with Ginger Rankin</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.essence.com/feature/vanessa-james-history-carnival-fete/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Vanessa James goes behind the fete to discover the history of carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Grenada-Spicemas.-The-famous-Jab-Jab-experinece-on-Jouvert-Morning-Photog-Arthur-Daniel20-copy-1-1200x800-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.essence.com/feature/vanessa-james-history-carnival-fete/#new_tab">Vanessa James goes behind the fete to discover the history of carnival</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab"><div class="thumbnail-container size-500 "><img width="225" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="CARICOM examines the free movement of Haitians" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/07/Flag-Pins-Haiti-Grenada.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.stabroeknews.com/2019/opinion/letters/07/08/credible-accounts-of-gross-human-rights-violations-in-haiti-must-be-addressed-by-caricom/#new_tab">Credible accounts of gross human rights violations in Haiti must be addressed by CARICOM</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/ndc-heartbeat-our-crumbling-infrastructure/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/ndc-heartbeat-our-crumbling-infrastructure/">NDC Heartbeat: Our crumbling infrastructure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/ndc-heartbeat-theyve-started-a-fight-cant-afford-it/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/ndc-heartbeat-theyve-started-a-fight-cant-afford-it/">NDC Heartbeat: They’ve started a fight &#038; can’t afford it</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/minding-your-legal-affairs-what-happens-when-you-give-a-mortgage-over-your-property/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/minding-your-legal-affairs-what-happens-when-you-give-a-mortgage-over-your-property/">Minding your legal Affairs: What happens when you give a mortgage over your property</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/long-overdue-a-national-heroes-day/"><div class="thumbnail-container size-500 "><img width="129" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance, Thanksgiving &#038; National Heroes" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/10/T-A-Marryshow-cropped.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/long-overdue-a-national-heroes-day/">Long overdue: A National Heroes Day</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://matadornetwork.com/change/to-hell-with-good-intentions/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/grenada-crafts-centre-st.-georges.-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://matadornetwork.com/change/to-hell-with-good-intentions/#new_tab">To hell with good intentions</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/06/17/taking-a-look-within/#new_tab"><div class="thumbnail-container size-500 "><img width="232" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Chester Humphrey continues to be in charge" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/Chester-Humphrey-450x350-275x213.gif.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/06/17/taking-a-look-within/#new_tab">Taking a look within</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/grenadians-being-covetous-a-symptom-of-a-grave-issue/"><div class="thumbnail-container size-500 "><img width="360" height="153" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Your opinion is important" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/01/grenada-flag-01.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/grenadians-being-covetous-a-symptom-of-a-grave-issue/">Grenadians being covetous: A symptom of a grave issue</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/06/theyve-started-a-fight-and-cant-afford-it/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/06/theyve-started-a-fight-and-cant-afford-it/">They’ve started a fight and can’t afford it</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/">Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/">Grenadian participates in US Government-Sponsored International Visitor Leadership Programme</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/"><div class="thumbnail-container size-500 "><img width="193" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="New Acting Chief Education Officer" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/">Public Notice: Parliamentary Elections Office</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Waterwheels, windmills and aqueducts of Grenada and Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/waterwheel-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/waterwheels-windmills-and-aqueducts-of-grenada-and-carriacou/">Waterwheels, windmills and aqueducts of Grenada and Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Quebec’s only official celebration of Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Photo-Montreal-Community-Contact-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.thesuburban.com/life/lifestyles/spice-isle-cultural-day-july-in-little-burgundy-quebec-s/article_2f0c1f42-9eb6-11e9-ae13-87a761973dd9.html#new_tab">Quebec’s only official celebration of Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Ridge to Reef and MNIB launch Pest Management Project" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/DSCN5641.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/work-towards-developing-governance-structure-for-grenadas-soursop-industry/">Work towards developing governance structure for Grenada’s soursop industry</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Focus on soursop, nutmeg and cocoa for plant distribution season" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/PLANT-PHOTO-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/focus-on-soursop-nutmeg-and-cocoa-for-plant-distribution-season/">Focus on soursop, nutmeg and cocoa for plant distribution season</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/ecse-vacancy-it-technician/"><div class="thumbnail-container size-500 "><img width="360" height="95" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="ECSE Vacancy – IT Technician" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/ECSE-360x95.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/ecse-vacancy-it-technician/">ECSE Vacancy – IT Technician</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/">
		        <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile@2x.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/03/NOWGrenada_text_mobile@2x.png 2x" data-dark-src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap post-autoload "  data-url="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/" data-title="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme" data-id="59341"  data-prev="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
<div id="vpp">
 
					<div class="bsaPopupWrapperBg bsaPopupWrapperBg-20 bsaHidden" style="display:none"></div>

					<div class="bsaPopupWrapper bsaPopupWrapper-20 bsaHidden" style="display:none">

						<div class="bsaPopupWrapperInner">
				<div id="bsa-html" class="bsaProContainer bsaProContainer-20 bsa-html bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=70&bsa_pro_url=https://www.thecommunalcu.com/" target="_blank"><video controls muted autoplay style="width:100%;" id="rvid">
<source src="https://www.nowgrenada.com/wp-content/uploads/2019/06/CCCU-Mortage-AD.mp4" width="1280px" height="720px" type="video/mp4">
</video></a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-20');
								var number_show_ads = "0";
								var number_hide_ads = "40";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div><span class="bsaPopupClose bsaPopupClose-20"></span></div>					<script>
						(function ($) {
							var ads = "1";
							if ( ads > 0 ) {
								var bsaPopupWrapperBg = $(".bsaPopupWrapperBg-20");
								var bsaPopupWrapper = $(".bsaPopupWrapper-20");
								var bsaBody = $("body");
								if (bsaPopupWrapper.hasClass('bsaClosed') === false) {
									setTimeout(function () {
//										bsaBody.css({
//											"overflow": "hidden",
//											"height": ( bsaBody.hasClass("logged-in") ) ? $(window).height() - 32 : $(window).height()
//										});
										bsaPopupWrapper.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
										bsaPopupWrapperBg.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
									}, 0);
								}
								$(document).ready(function () {
									var bsaPopupClose = $(".bsaPopupClose-20");
									bsaPopupClose.click(function () {
										bsaBody.css({"overflow": "visible", "height": "auto"});
										bsaPopupClose.addClass("animated zoomOut");
										bsaPopupWrapper.removeClass("fadeIn").addClass("animated fadeOut bsaClosed").fadeOut();
										bsaPopupWrapperBg.removeClass("fadeIn").addClass("animated fadeOut").fadeOut();
									});
									var number_close = "40";
									var number_show = "3";
									if ( number_close > 0 ) {
										bsaPopupWrapperBg.removeClass('animated');
										bsaPopupWrapper.removeClass('animated');
										setTimeout(function () {
											bsaPopupWrapperBg.fadeOut();
											bsaPopupWrapper.fadeOut();
										}, number_close * 1000);
									}
									if ( number_show > 0 ) {
										if ( number_show === 1000 ) {
											bsaPopupClose.remove();
										} else {
											bsaPopupClose.hide();
											setTimeout(function () {
												bsaPopupClose.fadeIn();
											}, number_show * 1000);
										}
									}
								});
							}
						})(jQuery);
					</script>
					<style>
																		.bsaPopupWrapperBg-20 {
							background-color: rgba(255,255,255,0.7);
						}
											</style>
				 </div> 
    <div class="container">
 
        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>
 
        <div class="row">
            <div class="jeg_main_content col-md-8">

               <div class="jeg_inner_content">

<div id="newad">
 <div id="bsa-block-720--300" class="bsaProContainer bsaProContainer-1 bsa-block-720--300 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Header</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=1" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=2&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1513607924-antillean-comp-plus-720x300_web-1.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "1";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "720";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-1 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-1');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					 </div>
                     
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                                                    </div>
                         
                        <div class="entry-header">

                            
                            <h1 class="jeg_post_title">Grenadian participates in US Government-Sponsored International Visitor Leadership Programme</h1>
 
                             
                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

    <div class="meta_left">
        
                    <div class="jeg_meta_date">
                <a href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/">8 July 2019</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="https://www.nowgrenada.com/category/law/" rel="category tag">Law</a>, <a href="https://www.nowgrenada.com/category/press-release/" rel="category tag">Press Release</a>                </span>
            </div>
        
	    <div class="jeg_meta_reading_time">
			            <span>
			            	1 min read
			            </span>
			        </div>    </div>

    <div class="meta_right">
                    </div>
</div>
</div>
                        </div>
 
                        <div class="jeg_featured featured_image"><a href="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg"><img src="https://www.nowgrenada.com/wp-content/uploads/2019/07/IVLP-Brendon-La-Touche-10.jpg" alt=""></a></div>                        <div class="now_featured_caption">
                        US Ambassador Linda Taglialatela (left) meets with Brendon La Touche prior to his departure to Washington, DC.                        </div>
                         
                        <div class="jeg_share_top_container"></div> 
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div> 
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Grenadian+participates+in+US+Government-Sponsored+International+Visitor+Leadership+Programme&url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="whatsapp://send?text=Grenadian+participates+in+US+Government-Sponsored+International+Visitor+Leadership+Programme%0Ahttps%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" rel='nofollow'  data-action="share/whatsapp/share"  class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
                <div class="share-secondary">
                    <a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" rel='nofollow'  class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="mailto:?subject=Grenadian+participates+in+US+Government-Sponsored+International+Visitor+Leadership+Programme&amp;body=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" rel='nofollow'  class="jeg_btn-email "><i class="fa fa-envelope"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
            </div></div>                            </div>
 
                            <div class="content-inner ">
                                <p><strong>Brendon La Touche is currently in the United States participating on the US Department of State’s International Visitor Leadership Programme (IVLP).</strong></p>
<p>He is taking part in a 3-week project on “Combating Trafficking in Persons” from 6-27 July.  La Touche is a Crown Counsel in the Office of the Director of Public Prosecutions (DPP) in Grenada. The Office of the DPP is responsible for the effective prosecution of all criminal related matters in Grenada.</p>
<p>During the programme, he and other participants will review US government strategies to combat international trafficking in persons, including crimes against women and children, by examining the formulation, administration, and enforcement of US policy on the national, state, and local levels. The participants will also explore initiatives to recognise, protect, and assist victims of abuse and trafficking, including victim recovery and reintegration programs; and investigate international law enforcement cooperation in trafficking in persons cases.</p>
<p>The International Visitor Leadership Programme (IVLP) is the Department of State’s premier professional exchange programme. The programme brings together emerging leaders in their respective professions to learn from how US experts in this profession operate, and to share best practices with the other programme fellows who hail from the same region and across the globe.</p>
<p><em>US Embassy Grenada</em></p>
                                 
                                 
                                                                <div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.nowgrenada.com/tag/brendon-la-touche/" rel="tag">brendon la touche</a><a href="https://www.nowgrenada.com/tag/director-of-public-prosecutions/" rel="tag">director of public prosecutions</a><a href="https://www.nowgrenada.com/tag/international-visitor-leadership-programme/" rel="tag">international visitor leadership programme</a></div>
                                                            </div>

<!--Footer Banner by Andel March 28 2019 -->
<div id="bsa-block-750--150" class="bsaProContainer bsaProContainer-15 bsa-block-750--150 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Footer Banner</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=15" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=76&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1558961045-Footer Banner.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "15";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "750";
					var parentHeight = "150";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-15');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					
 
                            <div class="jeg_share_bottom_container"></div> 
                                                    </div>
 
                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div  class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_59341_0_5d2401b374579   " data-unique="jnews_module_59341_0_5d2401b374579">
                <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
                    <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
                    
                </div>
                <div class="jeg_block_container">
                
                <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag"> 
                    <article class="jeg_post jeg_pl_md_5 post-59344 post type-post status-publish format-standard has-post-thumbnail hentry category-politics category-press-release tag-caricom tag-erna-solberg tag-norway">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-350x250.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-350x250.jpg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Prime-Minister-meets-his-Norwegian-counterpart-at-CARICOM-meeting-in-St.-Lucia-July-2019-120x86.jpg 120w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/">Bilateral talks between Grenada and Norway at recent Caricom Heads of Government summit</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/07/bilateral-talks-between-grenada-and-norway-at-recent-caricom-heads-of-government-summit/" ><i class="fa fa-clock-o"></i> 8 July 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-59265 post type-post status-publish format-standard has-post-thumbnail hentry category-notice-news category-politics tag-consolidated-list-of-electors tag-elections tag-elvis-morain tag-parliamentary-elections-office tag-peo">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/"><div class="thumbnail-container animate-lazy  size-715 "><img width="268" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="New Acting Chief Education Officer" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826.jpg 596w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826-150x140.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Elvis-Morain-2-e1425499739826-300x280.jpg 300w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/politics/" class="category-politics">Politics</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/">Public Notice: Parliamentary Elections Office</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/" ><i class="fa fa-clock-o"></i> 8 July 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-59328 post type-post status-publish format-standard has-post-thumbnail hentry category-business category-education category-press-release category-tourism category-youth tag-beacon-junior-school tag-ellisha-cooper tag-georges-seventh-day-adventist-primary-school tag-grenada-junior-academy tag-jaeda-newton tag-job-shadowing tag-junior-achievement tag-kunal-nundwai tag-rainbow-junior-academy tag-sandals-foundation tag-xayne-dominique">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Sandals Foundation Junior Achievers get on-the-job exposure" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-350x250.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-350x250.jpg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/07/Spa-Manager-120x86.jpg 120w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/education/" class="category-education">Education</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/">Sandals Foundation Junior Achievers get on-the-job exposure</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/07/sandals-foundation-junior-achievers-get-on-the-job-exposure/" ><i class="fa fa-clock-o"></i> 8 July 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                <div class="jeg_block_loadmore ">
                    <a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a>
                </div>
                
            </div>
                
                <script>var jnews_module_59341_0_5d2401b374579 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":59341,"include_category":"1034,4923,12758,5180,8671","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":"3","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_22"};</script>
            </div></div><div class='jnews-autoload-splitter'  data-url="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/" data-title="Grenadian participates in US Government-Sponsored International Visitor Leadership Programme" data-id="59341"  data-prev="https://www.nowgrenada.com/2019/07/public-notice-parliamentary-elections-office/" ></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.nowgrenada.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='59341' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9e42f8fe99" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="90"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
                    
<!--FB Comments by Andel March 12 2019 -->
<div style="" id="the_champ_fb_commenting"><div class="fb-comments" data-href="https://www.nowgrenada.com/2019/07/grenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme/" data-numposts="" data-width="100%" ></div></div><script type="text/javascript" src="//connect.facebook.net/en_GB/sdk.js
    "></script><script>FB.init({xfbml:1,version: "v3.2"});</script>
                </div>
            </div>
            
<div class="jeg_sidebar   col-md-4">
    <div class="widget widget_text" id="text-2">			<div class="textwidget"><p><div id="bsa-block-300--250" class="bsaProContainer bsaProContainer-8 bsa-block-300--250 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Sidebar 300x250</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=8" target="_blank" style="color:" rel="noopener noreferrer"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=12&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1514819661-Grenlec_WebBNR_EV_300x250_motion.gif&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "8";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "250";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-8 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-8');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					<br />
<!-- Article Sidebar 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x90--><br />
<br />
<!-- Article Sidebar 300x300 --><br />
<div id="bsa-block-300--300" class="bsaProContainer bsaProContainer-16 bsa-block-300--300 bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=83&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1562330837-ECSE-Vacancy---square-box.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "16";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-16');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</p>
<p><!-- Article Sidebar 300x750 --><br />
</p>
</div>
		</div><div class="widget_text widget widget_custom_html" id="custom_html-7"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget_text widget widget_custom_html" id="custom_html-6"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget widget_awesomeweatherwidget" id="awesomeweatherwidget-4"><div id="awesome-weather-grenada-gd" class="awesome-weather-wrap awecf awe_tall temp6 awe_with_stats awe-code-802 awe-desc-scattered-clouds awe-preset-cloudy darken" style=" color: #ffffff; "><div class="awesome-weather-cover" style='background-image: url(https://www.nowgrenada.com/wp-content/plugins/awesome-weather/img/awe-backgrounds/cloudy.jpg);'><div class="awesome-weather-header">Grenada</div><div class="awesome-weather-current-temp"><strong>27<sup>&deg;</sup></strong></div><!-- /.awesome-weather-current-temp --><div class="awesome-weather-todays-stats"><div class="awe_desc">scattered clouds</div><div class="awe_humidty">humidity: 83%</div><div class="awe_wind">wind: 4m/s E</div><div class="awe_highlow">H 28 &bull; L 27</div></div><!-- /.awesome-weather-todays-stats --><div class="awesome-weather-forecast awe_days_4 awecf">
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Tue</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Wed</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Thu</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Fri</div>
				</div></div><!-- /.awesome-weather-forecast --><div class="awesome-weather-attribution">Weather from OpenWeatherMap</div></div><!-- /.awesome-weather-cover --></div> <!-- /.awesome-weather-wrap --></div></div>        </div>
 
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>
 
    </div>
</div>                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-59341 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.3 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_custom">
    <div class="jeg_container">
        <div class="jeg_content">
            <div class="jeg_vc_content">
                <div data-vc-full-width="true" data-vc-full-width-init="false" class="row vc_row vc_custom_1512030979094 vc_row-has-fill jnews_5d2401b37b65b footer_dark"><div class="jeg-vc-wrapper"><div class="footer_left wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper">
	<div class="wpb_text_column wpb_content_element  vc_custom_1551598731654 copyright" >
		<div class="wpb_wrapper">
			<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>

		</div>
	</div>
</div></div><div class="footer_right wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper"><div  class='jeg_social_icon_block socials_widget jnews_module_59341_1_5d2401b37bee8 nobg '><a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div>
            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56"><a href="http://nowgrenada.com">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.nowgrenada.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527"><a href="https://www.nowgrenada.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://www.nowgrenada.com/category/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273"><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56527"><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297"><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022"><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298"><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260"><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = []</script><div id="selectShareContainer">
                    <div class="selectShare-inner">
                        <div class="select_share jeg_share_button">              
                            <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" data-image-url="" data-title="Grenadian+participates+in+US+Government-Sponsored+International+Visitor+Leadership+Programme" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F07%2Fgrenadian-participates-in-us-government-sponsored-international-visitor-leadership-programme%2F" data-image-url="" data-title="Grenadian+participates+in+US+Government-Sponsored+International+Visitor+Leadership+Programme" ><i class="fa fa-twitter"></i></a>
                        </div>
                        <div class="selectShare-arrowClip">
                            <div class="selectShare-arrow"></div>      
                        </div> 
                    </div>      
                  </div><div class="jnews-cookie-law-policy">This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a>. <button data-expire="84" class="btn btn-cookie">I Agree</button></div><div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"d MM yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-auto-load-post/assets/js/jquery.autoload.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/comment-reply.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","lang":"en_GB","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"59341","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"bottom_right","rtl":"0","gif":"1","site_slug":"\/","site_domain":"www.nowgrenada.com","autoload_limit":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=1.0.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=1.0.0'></script>
<![endif]-->
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.1.1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.12.30'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-embed.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script async="async" type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.0.3'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div></body>
</html>

<!-- Dynamic page generated in 0.942 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-07-08 22:53:39 -->

<!-- super cache -->