<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.nowgrenada.com/xmlrpc.php" />
    <title>Man linked to robbery in Grenada caught in Trinidad | NOW Grenada</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* allerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }


	/* Custom CSS */
	.bsaProContainer .bsaProHeader {
    display: none;
}

.owl-controls {
    display: none !important;
} 

#bsa-block-720—300 {
max-width: 300px;
}

@media only screen and (min-width: 900px) {
.bsaPopupClose {
    position: absolute;
    cursor: pointer;
    top: 150px;
    right: 320px;
    width: 25px;
    height: 25px;
    background: url(../../img/close-black.png) white center center no-repeat;
}
}

</style>	<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
		<script type="text/javascript">var theChampDefaultLang = 'en_GB', theChampCloseIconPath = 'https://www.nowgrenada.com/wp-content/plugins/super-socializer/images/close.png';</script>
		<script> var theChampSiteUrl = 'https://www.nowgrenada.com', theChampVerified = 0, theChampEmailPopup = 0; </script>
		<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.heateor_ss_mobile_footer{display:none;}@media screen and (max-width:783px){i.theChampTCBackground{background-color:white!important}div.the_champ_bottom_sharing{width:100%!important;left:0!important;}div.the_champ_bottom_sharing li{width:11.111111111111% !important;}div.the_champ_bottom_sharing .theChampSharing{width: 100% !important;}div.the_champ_bottom_sharing div.theChampTotalShareCount{font-size:1em!important;line-height:28px!important}div.the_champ_bottom_sharing div.theChampTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_ss_mobile_footer{display:block;height:40px;}.the_champ_bottom_sharing{padding:0!important;display:block!important;width: auto!important;bottom:-2px!important;top: auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height: inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right: 1.1em !important}}</style>
	            <script type="text/javascript"> var jnews_ajax_url = 'https://www.nowgrenada.com/?ajax-request=jnews'; </script>
            
<!-- All in One SEO Pack 3.2.4 by Michael Torbert of Semper Fi Web Design[989,1067] -->
<meta name="description"  content="The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch." />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.nowgrenada.com/#organization","url":"https://www.nowgrenada.com/","name":"NOW Grenada","sameAs":[]},{"@type":"WebSite","@id":"https://www.nowgrenada.com/#website","url":"https://www.nowgrenada.com/","name":"NOW Grenada","publisher":{"@id":"https://www.nowgrenada.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.nowgrenada.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.nowgrenada.com#webpage","url":"https://www.nowgrenada.com","inLanguage":"en-GB","name":"Man linked to robbery in Grenada caught in Trinidad","isPartOf":{"@id":"https://www.nowgrenada.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com#primaryimage","url":"https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg","width":900,"height":675,"caption":"Save N Gain department store in Grenville "},"primaryImageOfPage":{"@id":"https://www.nowgrenada.com#primaryimage"},"datePublished":"2019-08-23T20:27:20+00:00","dateModified":"2019-08-23T20:56:34+00:00","description":"The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch."},{"@type":"Article","@id":"https://www.nowgrenada.com#article","isPartOf":{"@id":"https://www.nowgrenada.com#webpage"},"author":{"@id":"https://www.nowgrenada.com/author/suelin/#author"},"headline":"Man linked to robbery in Grenada caught in Trinidad","datePublished":"2019-08-23T20:27:20+00:00","dateModified":"2019-08-23T20:56:34+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.nowgrenada.com#webpage"},"publisher":{"@id":"https://www.nowgrenada.com/#organization"},"articleSection":"General News, crime watch, curlan campbell, jeremiah mark, robbery, save n gain, trinidad","image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com#primaryimage","url":"https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg","width":900,"height":675,"caption":"Save N Gain department store in Grenville "}},{"@type":"Person","@id":"https://www.nowgrenada.com/author/suelin/#author","name":"NOW Grenada","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com/#personlogo","url":"https://secure.gravatar.com/avatar/55c565a497d409c71da09976211e9106?s=96&d=mm&r=g","width":96,"height":96,"caption":"NOW Grenada"}}]}</script>
<link rel="canonical" href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Feed" href="https://www.nowgrenada.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Comments Feed" href="https://www.nowgrenada.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Man linked to robbery in Grenada caught in Trinidad Comments Feed" href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.7.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.7.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-89948788-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-89948788-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.nowgrenada.com/wp-includes/css/dist/block-library/style.min.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='https://www.nowgrenada.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/style.css?v=4.1&#038;ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/user-panel.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/all.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/animate.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/chart.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_owl_carousel_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/bsa.carousel.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/material-design.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-css'  href='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=1.7.9' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=1.7.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://www.nowgrenada.com/wp-content/plugins/wp-polls/images/default_gradient/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='jnews-parent-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/style.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/super-socializer/css/front.css?ver=7.12.32' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='otw-shortcode-css'  href='https://www.nowgrenada.com/wp-content/plugins/lists-shortcode-and-widget//include/otw_components/otw_shortcode/css/otw_shortcode.css?ver=e5aec9abeb0a99927ec8bd9bba642c61' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.nowgrenada.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.7.1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/shortcode.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-admin/js/media-upload.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/script.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/chart.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/bsa.carousel.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/custom.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[]};
var log_object = {"ajax_url":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=1.7.9'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.nowgrenada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nowgrenada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nowgrenada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='How to survive college – free online seminar' href='https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/' />
<link rel='next' title='Advisory: An area of low pressure has developed' href='https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/' />

<link rel='shortlink' href='https://www.nowgrenada.com/?p=60627' />
<link rel="alternate" type="application/json+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F&#038;format=xml" />
<style>.spvc_views{display:inline;} .spvc_icon{display:inline;} .spvc_area{display:block; text-align:right; text-align:right; background:#dadada; float:right; clear:both;  margin:-20px 0 0 0; padding:2px 5px; font-size:14px; border-radius:5px;} </style>			<script>
			function mInlineJsLoadFunc(){	window.setTimeout(function(){ jQuery.post({ url:"/",  data:{ call__SPVC:'ok', pid:60627 }, complete : function(e,d){ if(window.spvc_log){console.log(e.responseText);} }   });  if(window.spvc_log){console.log("sent");} }, 5000); 	}

			var exec_for_user = true;
			if (exec_for_user) { window.addEventListener ? window.addEventListener("load", mInlineJsLoadFunc,false) : window.attachEvent && window.attachEvent("onload",mInlineJsLoadFunc); }
			</script>
					<script type="text/javascript">
			var cli_flush_cache=1;
		</script>
		      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.nowgrenada.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e0fbff27-0ea3-4e3f-a8d9-a4c7eac9ccc8';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "NOW Grenada";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing to nowgrenada.com!";
oneSignal_options['welcomeNotification']['url'] = "https://www.nowgrenada.com";
oneSignal_options['path'] = "https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4463433a-b41c-4a34-809b-879a9d93883b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'wants to show Notifications';
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Example Notification Title';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Notifications will appear on your desktop';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Example Notification';
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = 'Notifications will appear on your mobile';
oneSignal_options['promptOptions']['exampleNotificationCaption'] = '(you can unsubscribe anytime)';
oneSignal_options['promptOptions']['acceptButtonText'] = 'CONTINUE';
oneSignal_options['promptOptions']['cancelButtonText'] = 'NO THANKS';
oneSignal_options['promptOptions']['siteName'] = 'http://www.nowgrenada.com';
oneSignal_options['promptOptions']['autoAcceptTitle'] = 'Click Allow';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-270x270.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display: none;}</style>		<style type="text/css" id="wp-custom-css">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</style>
		<style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1512030979094{padding-top: 20px !important;padding-bottom: 20px !important;background-color: #212121 !important;}.vc_custom_1551598731654{margin-bottom: 0px !important;}</style><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<!-- START - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="NOW Grenada"/>
  <meta property="og:title" content="Man linked to robbery in Grenada caught in Trinidad"/>
  <meta property="og:url" content="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch."/>
  <meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"/>
  <meta property="og:image:url" content="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"/>
  <meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"/>
  <meta property="article:published_time" content="2019-08-23T16:27:20-04:00"/>
  <meta property="article:modified_time" content="2019-08-23T16:56:34-04:00" />
  <meta property="og:updated_time" content="2019-08-23T16:56:34-04:00" />
  <meta property="article:section" content="General News"/>
  <meta property="article:publisher" content="https://www.facebook.com/NowGrenada/"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Man linked to robbery in Grenada caught in Trinidad"/>
  <meta itemprop="headline" content="Man linked to robbery in Grenada caught in Trinidad"/>
  <meta itemprop="description" content="The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch."/>
  <meta itemprop="image" content="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"/>
  <meta itemprop="datePublished" content="2019-08-23"/>
  <meta itemprop="dateModified" content="2019-08-23T16:56:34-04:00" />
  <meta itemprop="author" content="NOW Grenada"/>
  <!--<meta itemprop="publisher" content="NOW Grenada"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Man linked to robbery in Grenada caught in Trinidad"/>
  <meta name="twitter:url" content="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/"/>
  <meta name="twitter:description" content="The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch."/>
  <meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@nowgrenada"/>
 <!-- SEO -->
  <meta name="description" content="The recent arrest of Jeremiah Mark over a string of robberies in Grenada made headlines in Trinidad and was brought live on Crime Watch."/>
  <meta name="publisher" content="NOW Grenada"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph for Facebook, Google+ and Twitter Card Tags 2.2.6.1 -->
	
</head>
<body class="post-template-default single single-post postid-60627 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive">

    
        <div id="jeg_sidecontent">
        <div class="jeg_side_heading">
            <ul class="jeg_side_tabs">
				<li data-tab-content="tab1" data-sort='latest' class="active">Latest</li>            </ul>
            <div class="jeg_side_feed_cat_wrapper">
				            </div>
			<script> var side_feed = {"paged":1,"post_type":"post","exclude_post":60627,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":12,"number_post":12,"pagination_mode":"loadmore"}; </script>        </div>

        <div class="sidecontent_postwrapper">
            <div class="jeg_sidefeed">
				<div class="jeg_post jeg_pl_md_box active " data-id="60627" data-sequence="0">
                        <div class="overlay_container">
                            <div class="jeg_thumb">
                                
                                <a class="ajax" href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/"><div class="thumbnail-container animate-lazy  size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Man linked to robbery in Grenada caught in Trinidad" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09-360x180.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09-360x180.jpeg 360w, https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09-750x375.jpeg 750w" data-expand="700" /></div></a>
                            </div>
                            <div class="jeg_postblock_content">
                                <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/">Man linked to robbery in Grenada caught in Trinidad</a></h2>
                                <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 hour ago</div></div>
                            </div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60632" data-sequence="1">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 hour ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60613" data-sequence="2">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 hours ago</div></div>
                        </div>
                    </div><div class="jeg_ad jnews_sidefeed_ads"><div class='ads-wrapper jeg_ad_sidecontent '></div></div><div class="jeg_post jeg_pl_xs_3  " data-id="60602" data-sequence="3">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-75x75.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-75x75.jpeg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-100x100.jpeg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 3 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60600" data-sequence="4">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/">Trinidad was Grenada’s best market for 2019 Carnival celebrations</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 4 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60393" data-sequence="5">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="45" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Police discover powerful cripa marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg 400w, https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana-150x89.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana-300x179.jpg 300w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/">Should Grenada decriminalise cannabis?</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 4 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60594" data-sequence="6">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Garvey and racial consciousness in the 1920s and 1930s" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/470px-Marcus_Garvey_1924-08-05-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/470px-Marcus_Garvey_1924-08-05-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/470px-Marcus_Garvey_1924-08-05-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab">Garvey and racial consciousness in the 1920s and 1930s</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 4 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60592" data-sequence="7">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/ndc-stages-second-corruption-picketing/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="NDC stages second corruption picketing" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-22-at-12.51.10-75x75.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-22-at-12.51.10-75x75.jpeg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-22-at-12.51.10-100x100.jpeg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/ndc-stages-second-corruption-picketing/">NDC stages second corruption picketing</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 5 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60589" data-sequence="8">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 7 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60585" data-sequence="9">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Word of mouth: Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab">Word of mouth: Carriacou</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 7 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60571" data-sequence="10">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="73" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="5 Grenadian Artistes at International Soca Monarch Semis" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg.jpg 873w, https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg-146x150.jpg 146w, https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg-291x300.jpg 291w, https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg-768x792.jpg 768w, https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg-770x794.jpg 770w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/">Carnival postmortem to discuss critical areas of risk</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60566" data-sequence="11">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/">NCAA rules restrict gifts for Anderson Peters’ gold medal</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="60344" data-sequence="12">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab">Remembrance of the Slave Trade and its Abolition 23 August</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 10 hours ago</div></div>
                        </div>
                    </div>            </div>
            <div class="sidefeed_loadmore">
	                            <button class="btn "
                        data-end="End of Content"
                        data-loading="Loading..."
                        data-loadmore="Load More">
					End of Content                </button>
            </div>
        </div>
        <div class="jeg_sidefeed_overlay">
            <div class='preloader_type preloader_dot'>
                <div class="sidefeed-preloader jeg_preloader dot">
                    <span></span><span></span><span></span>
                </div>
                <div class="sidefeed-preloader jeg_preloader circle">
                    <div class="jnews_preloader_circle_outer">
                        <div class="jnews_preloader_circle_inner"></div>
                    </div>
                </div>
                <div class="sidefeed-preloader jeg_preloader square">
                    <div class="jeg_square">
                        <div class="jeg_square_inner"></div>
                    </div>
                </div>
            </div>
        </div>
    </div>
	

    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/" style="padding: 0 0 0 0;">
	    	    <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" data-dark-src="" data-dark-srcset=" 1x,  2x">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '><div class='ads_shortcode'><div id="bsa-html" class="bsaProContainer bsaProContainer-10 bsa-html bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Footer 468x60</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=10" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=15&bsa_pro_url=http://netherlands.co.gd" target="_blank"><img class="netherlands-ad" src="https://www.nowgrenada.com/wp-content/uploads/2017/12/banner468x60Netherlands1.gif" title="Netherlands" styles="margin-bottom: 25px !important;"/>
<div class="spacer"></div>
</a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-60599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man linked to robbery in Grenada caught in Trinidad" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/">Man linked to robbery in Grenada caught in Trinidad</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/">Trinidad was Grenada’s best market for 2019 Carnival celebrations</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/"><div class="thumbnail-container size-500 "><img width="303" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Police discover powerful cripa marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/">Should Grenada decriminalise cannabis?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Word of mouth: Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab">Word of mouth: Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/">Banner to mark International Day for the Remembrance of the Slave Trade and its Abolition</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-55527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/">NCAA rules restrict gifts for Anderson Peters’ gold medal</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Swimmers compete at FINA World Junior Swimming Championships in Budapest" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Nataly-Sihera-Zackary-Gresham-Anaika-Charles-Jenebi-Benoit-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/">National Swimmers compete at FINA World Junior Swimming Championships in Budapest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/sports-minister-congratulates-anderson-peters-on-pan-am-gold/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/sports-minister-congratulates-anderson-peters-on-pan-am-gold/">Sports minister congratulates Anderson Peters on Pan-Am Gold</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.kbtx.com/content/sports/Texas-AM-at-The-Pan-American-Games-Vidales-with-offensive-onslaught-in-softball-track--swimming-begin-524477681.html#new_tab"><div class="thumbnail-container size-500 "><img width="288" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/Lindon-Victor-Texas-Relays-2017-MAR29-APR01.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.kbtx.com/content/sports/Texas-AM-at-The-Pan-American-Games-Vidales-with-offensive-onslaught-in-softball-track--swimming-begin-524477681.html#new_tab">Lindon Victor for Texas A&#038;M at The Pan American Games</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fina-world-championships-yields-excellent-performances-from-grenada-swimmers/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FINA World Championships yields excellent performances from Grenada Swimmers" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Delron-Felix-Kimberly-Ince-Kerry-Ollivierre-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fina-world-championships-yields-excellent-performances-from-grenada-swimmers/">FINA World Championships yields excellent performances from Grenada Swimmers</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.scubadivermag.com/10-awesome-grenada-wrecks-that-will-make-you-lust-for-rust/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="10 awesome Grenada wrecks that will make you lust for rust!" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/The-Bianca-C-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.scubadivermag.com/10-awesome-grenada-wrecks-that-will-make-you-lust-for-rust/#new_tab">10 awesome Grenada wrecks that will make you lust for rust!</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/team-grenada-nacac-age-group-championship/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GAA CARIFTA Team in Martinique" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/04/grenada-athletic-assoc.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/team-grenada-nacac-age-group-championship/">Team Grenada NACAC Age Group Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.guardian.co.tt/sports/new-concacaf-wcup-format-2-years-old-6.2.888699.b329472192#new_tab"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/01/GFA-President-Cheney-Joseph.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.guardian.co.tt/sports/new-concacaf-wcup-format-2-years-old-6.2.888699.b329472192#new_tab">New CONCACAF WorldCup format 2 years old</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/team-grenada-announced-for-2019-pan-american-games/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada inaugurates its renovated Olympic Committee with support from Panam Sports" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/06/Grenada-Olympic-Committee.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/team-grenada-announced-for-2019-pan-american-games/">Team Grenada announced for 2019 Pan-American Games</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/"><div class="thumbnail-container size-500 "><img width="303" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Police discover powerful cripa marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/">Should Grenada decriminalise cannabis?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/">NCAA rules restrict gifts for Anderson Peters’ gold medal</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fun and games at Youth Village" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/4992911-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab">Fun and games at Youth Village</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Swimmers compete at FINA World Junior Swimming Championships in Budapest" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Nataly-Sihera-Zackary-Gresham-Anaika-Charles-Jenebi-Benoit-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/">National Swimmers compete at FINA World Junior Swimming Championships in Budapest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.baltimoresun.com/obituaries/bs-md-ob-st-george-crosse-20190818-ac4sy6ptgjdvvgeweuwo6wcoum-story.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian-born religious and civil rights leader dies" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/LQVIDDEVFJCIHOXZOA534ZK3VA-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.baltimoresun.com/obituaries/bs-md-ob-st-george-crosse-20190818-ac4sy6ptgjdvvgeweuwo6wcoum-story.html#new_tab">Grenadian-born religious and civil rights leader dies</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/gut-credit-union-awards-143-cpea-grants/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GUT Credit Union awards 143 CPEA grants" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/DSC_0296-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/gut-credit-union-awards-143-cpea-grants/">GUT Credit Union awards 143 CPEA grants</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/reigning-groovy-king-dash-shares-title-with-vghn/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Crown City captures first 3 places in Power Soca Monarch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/DASH-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/reigning-groovy-king-dash-shares-title-with-vghn/">Reigning Groovy King Dash shares title with V’ghn</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/crown-city-captures-first-3-places-in-power-soca-monarch/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Crown City captures first 3 places in Power Soca Monarch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/BOYZIE-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/crown-city-captures-first-3-places-in-power-soca-monarch/">Crown City captures first 3 places in Power Soca Monarch</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/">Trinidad was Grenada’s best market for 2019 Carnival celebrations</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/"><div class="thumbnail-container size-500 "><img width="175" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5 Grenadian Artistes at International Soca Monarch Semis" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/">Carnival postmortem to discuss critical areas of risk</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.worcestermag.com/entertainmentlife/20190821/last-call-with-jennifer-gaskin-worcester-caribbean-american-carnival-organizer#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Last Call with Jennifer Gaskin, Worcester Caribbean American Carnival organiser" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Screenshot-2019-08-23-at-7.21.34-am-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.worcestermag.com/entertainmentlife/20190821/last-call-with-jennifer-gaskin-worcester-caribbean-american-carnival-organizer#new_tab">Last Call with Jennifer Gaskin, Worcester Caribbean American Carnival organiser</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.damajority.com/spicy-captures-from-2019-mas-in-beautiful-grenada/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicy captures from 2019 mas in beautiful Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicy-captures-from-2019-mas-in-beautiful-Grenada-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.damajority.com/spicy-captures-from-2019-mas-in-beautiful-grenada/#new_tab">Spicy captures from 2019 mas in beautiful Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/chokos-bar.00_02_19_00.Still003-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/">Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fun and games at Youth Village" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/4992911-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab">Fun and games at Youth Village</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/xnova-masqueraders-await-refund-and-explanation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="X’Nova masqueraders await refund and explanation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/xnova-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/xnova-masqueraders-await-refund-and-explanation/">X’Nova masqueraders await refund and explanation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/grenada-attends-animation-accelerator-training/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada attends animation accelerator training" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/IMG_2372-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/grenada-attends-animation-accelerator-training/">Grenada attends animation accelerator training</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Garvey and racial consciousness in the 1920s and 1930s" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/470px-Marcus_Garvey_1924-08-05-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab">Garvey and racial consciousness in the 1920s and 1930s</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Word of mouth: Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab">Word of mouth: Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-the-price-of-corruption-part-2/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-the-price-of-corruption-part-2/">NDC Heartbeat: The price of corruption – Part 2</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxvi-joint-ownership-of-land/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxvi-joint-ownership-of-land/">Minding Your Legal Affairs XXVI: Joint ownership of land</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.mirror.co.uk/news/politics/nelsons-column-words-matter-boris-18951922#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why Boris Johnson isn’t mentioning a general election" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/brexit-3870554_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.mirror.co.uk/news/politics/nelsons-column-words-matter-boris-18951922#new_tab">Why Boris Johnson isn’t mentioning a general election</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/why-are-students-in-grenada-failing-math/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why are students in Grenada failing Math?" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/geometry-1044090_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/why-are-students-in-grenada-failing-math/">Why are students in Grenada failing Math?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-now-that-carnival-is-over/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-now-that-carnival-is-over/">NDC Heartbeat: Now that carnival is over</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxv-maintenance-for-who-by-whom-and-what-is-covered/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxv-maintenance-for-who-by-whom-and-what-is-covered/">Minding Your Legal Affairs XXV: Maintenance &#8211; for Who, by Whom, and What is covered</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/citizens-standing-up-speaking-out-and-taking-action/"><div class="thumbnail-container size-500 "><img width="323" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Part I: The Integrity Commission" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/Sandra-Ferguson.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/citizens-standing-up-speaking-out-and-taking-action/">Citizens Standing Up, Speaking Out and Taking Action</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-56527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab">Remembrance of the Slave Trade and its Abolition 23 August</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/traffic-regulations-for-two-funerals-on-friday-23-august-2019/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Edzel Thomas Passes Away" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/12/funeral-flowers.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/traffic-regulations-for-two-funerals-on-friday-23-august-2019/">Traffic regulations for two funerals on Friday, 23 August 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/">Banner to mark International Day for the Remembrance of the Slave Trade and its Abolition</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/chokos-bar.00_02_19_00.Still003-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/">Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nwmissourinews.com/article_933a91ba-c472-11e9-8e56-972c923e4313.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian assistant professor added to Northwest faculty" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Giselle-Greenidge-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nwmissourinews.com/article_933a91ba-c472-11e9-8e56-972c923e4313.html#new_tab">Grenadian assistant professor added to Northwest faculty</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-12022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li id="menu-item-10298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li id="menu-item-24260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man linked to robbery in Grenada caught in Trinidad" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/">Man linked to robbery in Grenada caught in Trinidad</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/">Trinidad was Grenada’s best market for 2019 Carnival celebrations</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/"><div class="thumbnail-container size-500 "><img width="303" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Police discover powerful cripa marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/">Should Grenada decriminalise cannabis?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Word of mouth: Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab">Word of mouth: Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/">Banner to mark International Day for the Remembrance of the Slave Trade and its Abolition</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/">NCAA rules restrict gifts for Anderson Peters’ gold medal</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Swimmers compete at FINA World Junior Swimming Championships in Budapest" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Nataly-Sihera-Zackary-Gresham-Anaika-Charles-Jenebi-Benoit-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/">National Swimmers compete at FINA World Junior Swimming Championships in Budapest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/sports-minister-congratulates-anderson-peters-on-pan-am-gold/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/sports-minister-congratulates-anderson-peters-on-pan-am-gold/">Sports minister congratulates Anderson Peters on Pan-Am Gold</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.kbtx.com/content/sports/Texas-AM-at-The-Pan-American-Games-Vidales-with-offensive-onslaught-in-softball-track--swimming-begin-524477681.html#new_tab"><div class="thumbnail-container size-500 "><img width="288" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/04/Lindon-Victor-Texas-Relays-2017-MAR29-APR01.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.kbtx.com/content/sports/Texas-AM-at-The-Pan-American-Games-Vidales-with-offensive-onslaught-in-softball-track--swimming-begin-524477681.html#new_tab">Lindon Victor for Texas A&#038;M at The Pan American Games</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/fina-world-championships-yields-excellent-performances-from-grenada-swimmers/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="FINA World Championships yields excellent performances from Grenada Swimmers" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/Delron-Felix-Kimberly-Ince-Kerry-Ollivierre-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/fina-world-championships-yields-excellent-performances-from-grenada-swimmers/">FINA World Championships yields excellent performances from Grenada Swimmers</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.scubadivermag.com/10-awesome-grenada-wrecks-that-will-make-you-lust-for-rust/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="10 awesome Grenada wrecks that will make you lust for rust!" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/The-Bianca-C-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.scubadivermag.com/10-awesome-grenada-wrecks-that-will-make-you-lust-for-rust/#new_tab">10 awesome Grenada wrecks that will make you lust for rust!</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/team-grenada-nacac-age-group-championship/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GAA CARIFTA Team in Martinique" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/04/grenada-athletic-assoc.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/team-grenada-nacac-age-group-championship/">Team Grenada NACAC Age Group Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.guardian.co.tt/sports/new-concacaf-wcup-format-2-years-old-6.2.888699.b329472192#new_tab"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2017/01/GFA-President-Cheney-Joseph.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.guardian.co.tt/sports/new-concacaf-wcup-format-2-years-old-6.2.888699.b329472192#new_tab">New CONCACAF WorldCup format 2 years old</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/07/team-grenada-announced-for-2019-pan-american-games/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada inaugurates its renovated Olympic Committee with support from Panam Sports" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/06/Grenada-Olympic-Committee.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/07/team-grenada-announced-for-2019-pan-american-games/">Team Grenada announced for 2019 Pan-American Games</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/"><div class="thumbnail-container size-500 "><img width="303" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Police discover powerful cripa marijuana" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/10/Creepy-marijuana.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/should-grenada-decriminalise-cannabis/">Should Grenada decriminalise cannabis?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sports minister congratulates Anderson Peters on Pan-Am Gold" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/PETERS-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/no-reward-for-anderson-peters-gold-medal/">NCAA rules restrict gifts for Anderson Peters’ gold medal</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fun and games at Youth Village" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/4992911-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab">Fun and games at Youth Village</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Swimmers compete at FINA World Junior Swimming Championships in Budapest" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Nataly-Sihera-Zackary-Gresham-Anaika-Charles-Jenebi-Benoit-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/national-swimmers-compete-at-fina-world-junior-swimming-championships-in-budapest/">National Swimmers compete at FINA World Junior Swimming Championships in Budapest</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.baltimoresun.com/obituaries/bs-md-ob-st-george-crosse-20190818-ac4sy6ptgjdvvgeweuwo6wcoum-story.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian-born religious and civil rights leader dies" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/LQVIDDEVFJCIHOXZOA534ZK3VA-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.baltimoresun.com/obituaries/bs-md-ob-st-george-crosse-20190818-ac4sy6ptgjdvvgeweuwo6wcoum-story.html#new_tab">Grenadian-born religious and civil rights leader dies</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/gut-credit-union-awards-143-cpea-grants/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GUT Credit Union awards 143 CPEA grants" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/DSC_0296-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/gut-credit-union-awards-143-cpea-grants/">GUT Credit Union awards 143 CPEA grants</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/reigning-groovy-king-dash-shares-title-with-vghn/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Crown City captures first 3 places in Power Soca Monarch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/DASH-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/reigning-groovy-king-dash-shares-title-with-vghn/">Reigning Groovy King Dash shares title with V’ghn</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/crown-city-captures-first-3-places-in-power-soca-monarch/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Crown City captures first 3 places in Power Soca Monarch" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/BOYZIE-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/crown-city-captures-first-3-places-in-power-soca-monarch/">Crown City captures first 3 places in Power Soca Monarch</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/trinidad-was-grenadas-best-market-for-2019-carnival-celebrations/">Trinidad was Grenada’s best market for 2019 Carnival celebrations</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/"><div class="thumbnail-container size-500 "><img width="175" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5 Grenadian Artistes at International Soca Monarch Semis" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/norland-cox-lg.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/carnival-postmortem-to-discuss-critical-areas-of-risk-for-grenadas-product/">Carnival postmortem to discuss critical areas of risk</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.worcestermag.com/entertainmentlife/20190821/last-call-with-jennifer-gaskin-worcester-caribbean-american-carnival-organizer#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Last Call with Jennifer Gaskin, Worcester Caribbean American Carnival organiser" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Screenshot-2019-08-23-at-7.21.34-am-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.worcestermag.com/entertainmentlife/20190821/last-call-with-jennifer-gaskin-worcester-caribbean-american-carnival-organizer#new_tab">Last Call with Jennifer Gaskin, Worcester Caribbean American Carnival organiser</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.damajority.com/spicy-captures-from-2019-mas-in-beautiful-grenada/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicy captures from 2019 mas in beautiful Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicy-captures-from-2019-mas-in-beautiful-Grenada-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.damajority.com/spicy-captures-from-2019-mas-in-beautiful-grenada/#new_tab">Spicy captures from 2019 mas in beautiful Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/chokos-bar.00_02_19_00.Still003-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/">Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Fun and games at Youth Village" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/4992911-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://newsday.co.tt/2019/08/22/fun-and-games-at-youth-village/#new_tab">Fun and games at Youth Village</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/xnova-masqueraders-await-refund-and-explanation/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="X’Nova masqueraders await refund and explanation" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/xnova-1-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/xnova-masqueraders-await-refund-and-explanation/">X’Nova masqueraders await refund and explanation</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/grenada-attends-animation-accelerator-training/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada attends animation accelerator training" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/IMG_2372-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/grenada-attends-animation-accelerator-training/">Grenada attends animation accelerator training</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Garvey and racial consciousness in the 1920s and 1930s" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/470px-Marcus_Garvey_1924-08-05-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://searchlight.vc/searchlight/dr-fraser/2019/08/23/garvey-and-racial-consciousness-in-the-1920s-and-1930s/#new_tab">Garvey and racial consciousness in the 1920s and 1930s</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Word of mouth: Carriacou" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Clifton-Harbor-1030x581-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://coolhunting.com/travel/word-of-mouth-carriacou/#new_tab">Word of mouth: Carriacou</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-the-price-of-corruption-part-2/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-the-price-of-corruption-part-2/">NDC Heartbeat: The price of corruption – Part 2</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxvi-joint-ownership-of-land/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxvi-joint-ownership-of-land/">Minding Your Legal Affairs XXVI: Joint ownership of land</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.mirror.co.uk/news/politics/nelsons-column-words-matter-boris-18951922#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why Boris Johnson isn’t mentioning a general election" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/brexit-3870554_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.mirror.co.uk/news/politics/nelsons-column-words-matter-boris-18951922#new_tab">Why Boris Johnson isn’t mentioning a general election</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/why-are-students-in-grenada-failing-math/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why are students in Grenada failing Math?" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/geometry-1044090_640-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/why-are-students-in-grenada-failing-math/">Why are students in Grenada failing Math?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-now-that-carnival-is-over/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/ndc-heartbeat-now-that-carnival-is-over/">NDC Heartbeat: Now that carnival is over</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxv-maintenance-for-who-by-whom-and-what-is-covered/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/minding-your-legal-affairs-xxv-maintenance-for-who-by-whom-and-what-is-covered/">Minding Your Legal Affairs XXV: Maintenance &#8211; for Who, by Whom, and What is covered</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/citizens-standing-up-speaking-out-and-taking-action/"><div class="thumbnail-container size-500 "><img width="323" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Part I: The Integrity Commission" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/Sandra-Ferguson.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/citizens-standing-up-speaking-out-and-taking-action/">Citizens Standing Up, Speaking Out and Taking Action</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicemas continues strong positive growth in arrivals" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Spicemas-2019-Monday-Night-Mas-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/spicemas-continues-strong-positive-growth-in-arrivals/">Spicemas continues strong positive growth in arrivals</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://en.unesco.org/commemorations/slavetraderemembranceday#new_tab">Remembrance of the Slave Trade and its Abolition 23 August</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/traffic-regulations-for-two-funerals-on-friday-23-august-2019/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Edzel Thomas Passes Away" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/12/funeral-flowers.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/traffic-regulations-for-two-funerals-on-friday-23-august-2019/">Traffic regulations for two funerals on Friday, 23 August 2019</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Remembrance of the Slave Trade and its Abolition 23 August" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/banner_intday_remembrance-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/unesco-international-day-for-the-remembrance-of-the-slave-trade-and-its-abolition/">Banner to mark International Day for the Remembrance of the Slave Trade and its Abolition</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/chokos-bar.00_02_19_00.Still003-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/08/chokos-sports-bar-grill-reopens-with-a-blast-from-the-past/">Choko’s Sports Bar &#038; Grill reopens with “A Blast from The Past”</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nwmissourinews.com/article_933a91ba-c472-11e9-8e56-972c923e4313.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian assistant professor added to Northwest faculty" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Giselle-Greenidge-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nwmissourinews.com/article_933a91ba-c472-11e9-8e56-972c923e4313.html#new_tab">Grenadian assistant professor added to Northwest faculty</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/">
		        <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" data-dark-src="" data-dark-srcset=" 1x,  2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap post-autoload "  data-url="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/" data-title="Man linked to robbery in Grenada caught in Trinidad" data-id="60627"  data-prev="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
<!--<div id="vpp">
 
					<div class="bsaPopupWrapperBg bsaPopupWrapperBg-20 bsaHidden" style="display:none"></div>

					<div class="bsaPopupWrapper bsaPopupWrapper-20 bsaHidden" style="display:none">

						<div class="bsaPopupWrapperInner">
				<div id="bsa-html" class="bsaProContainer bsaProContainer-20 bsa-html bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=70&bsa_pro_url=https://www.thecommunalcu.com/" target="_blank"><video controls muted autoplay style="width:100%;" id="rvid">
<source src="https://www.nowgrenada.com/wp-content/uploads/2019/06/CCCU-Mortage-AD.mp4" width="1280px" height="720px" type="video/mp4">
</video></a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-20');
								var number_show_ads = "0";
								var number_hide_ads = "40";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div><span class="bsaPopupClose bsaPopupClose-20"></span></div>					<script>
						(function ($) {
							var ads = "1";
							if ( ads > 0 ) {
								var bsaPopupWrapperBg = $(".bsaPopupWrapperBg-20");
								var bsaPopupWrapper = $(".bsaPopupWrapper-20");
								var bsaBody = $("body");
								if (bsaPopupWrapper.hasClass('bsaClosed') === false) {
									setTimeout(function () {
//										bsaBody.css({
//											"overflow": "hidden",
//											"height": ( bsaBody.hasClass("logged-in") ) ? $(window).height() - 32 : $(window).height()
//										});
										bsaPopupWrapper.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
										bsaPopupWrapperBg.appendTo(document.body).removeClass("bsaHidden").addClass("animated fadeIn").fadeIn();
									}, 0);
								}
								$(document).ready(function () {
									var bsaPopupClose = $(".bsaPopupClose-20");
									bsaPopupClose.click(function () {
										bsaBody.css({"overflow": "visible", "height": "auto"});
										bsaPopupClose.addClass("animated zoomOut");
										bsaPopupWrapper.removeClass("fadeIn").addClass("animated fadeOut bsaClosed").fadeOut();
										bsaPopupWrapperBg.removeClass("fadeIn").addClass("animated fadeOut").fadeOut();
									});
									var number_close = "40";
									var number_show = "3";
									if ( number_close > 0 ) {
										bsaPopupWrapperBg.removeClass('animated');
										bsaPopupWrapper.removeClass('animated');
										setTimeout(function () {
											bsaPopupWrapperBg.fadeOut();
											bsaPopupWrapper.fadeOut();
										}, number_close * 1000);
									}
									if ( number_show > 0 ) {
										if ( number_show === 1000 ) {
											bsaPopupClose.remove();
										} else {
											bsaPopupClose.hide();
											setTimeout(function () {
												bsaPopupClose.fadeIn();
											}, number_show * 1000);
										}
									}
								});
							}
						})(jQuery);
					</script>
					<style>
																		.bsaPopupWrapperBg-20 {
							background-color: rgba(255,255,255,0.7);
						}
											</style>
				 </div>-->
    <div class="container">
 
        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>
 
        <div class="row">
            <div class="jeg_main_content col-md-8">

               <div class="jeg_inner_content">

<div id="newad">
 <div id="bsa-block-720--300" class="bsaProContainer bsaProContainer-1 bsa-block-720--300 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Header</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=1" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=2&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1513607924-antillean-comp-plus-720x300_web-1.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "1";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "720";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-1 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-1');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					 </div>
                     
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                                                    </div>
                         
                        <div class="entry-header">

                            
                            <h1 class="jeg_post_title">Man linked to robbery in Grenada caught in Trinidad</h1>
 
                            
                            <!--NOW Grenada Custom Ago Date -->
                            <div id="agodate">
                                                        </div>
 
                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

    <div class="meta_left">
        
                    <div class="jeg_meta_date">
                <a href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/">23 August 2019</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="https://www.nowgrenada.com/category/news/" rel="category tag">General News</a>                </span>
            </div>
        
	    <div class="jeg_meta_reading_time">
			            <span>
			            	2 min read
			            </span>
			        </div>    </div>

    <div class="meta_right">
                    </div>
</div>
</div>
                        </div>
 
                        <div class="jeg_featured featured_image"><a href="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg"><img src="https://www.nowgrenada.com/wp-content/uploads/2019/08/WhatsApp-Image-2019-08-23-at-16.13.09.jpeg" alt=""></a></div>                        <div class="now_featured_caption">
                        Save N Gain department store in Grenville 

                        </div>
                         
                        <div class="jeg_share_top_container"></div> 
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div> 
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Man+linked+to+robbery+in+Grenada+caught+in+Trinidad&url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="whatsapp://send?text=Man+linked+to+robbery+in+Grenada+caught+in+Trinidad%0Ahttps%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" rel='nofollow'  data-action="share/whatsapp/share"  class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
                <div class="share-secondary">
                    <a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" rel='nofollow'  class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="mailto:?subject=Man+linked+to+robbery+in+Grenada+caught+in+Trinidad&amp;body=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" rel='nofollow'  class="jeg_btn-email "><i class="fa fa-envelope"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
            </div></div>                            </div>
 
                            <div class="content-inner ">
                                <p><em>by Curlan Campbell, NOW Grenada</em></p>
<ul>
<li><strong>Jeremiah Mark’s arrest made headlines in Trinidad and was brought live on Crime Watch</strong></li>
<li><strong>EC$50,000 worth of appliances and other goods stolen from a shared warehouse</strong></li>
</ul>
<p>The proprietor of Save ’N’ Gain department store in Grenville is saddened over the recent arrest of Jeremiah Mark over a string of robberies in Grenada. Mark was caught by police in Trinidad &amp; Tobago on Thursday. The arrest made headlines in Trinidad and was brought live on Crime Watch.</p>
<p>The store owner, who wished not to be mentioned by name, said the suspect made away with over $50,000 worth of appliances and other goods from a warehouse shared by both Best Buy and Save ’N’ Gain department store. The incident happened in March 2019.</p>
<p>NOW Grenada was informed by the store owner that the young man arrested was once an employee of his store for over 6 years, and is someone whom he knew for quite some time. Apparently, the accused was able to use his brother to steal his keys for the warehouse located at Deco Industries, and he and 4 other suspects were said to have taken the goods. The proprietor was only able to recoup $20,000 worth of goods.</p>
<p>Although Mark had been charged for the offence, he didn’t attend his court hearing and fled the country before being caught by Trinidadian police.</p>
<p>Mark is said to have resided at Simon (Seamoon), St Andrew. NOW Grenada is awaiting information from the Community Relations Department of the Royal Grenada Police Force (RGPF) regarding whether Mark is indeed a Grenadian, or just resides on the island.</p>
                                 
                                 
                                                                <div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.nowgrenada.com/tag/crime-watch/" rel="tag">crime watch</a><a href="https://www.nowgrenada.com/tag/curlan-campbell/" rel="tag">curlan campbell</a><a href="https://www.nowgrenada.com/tag/jeremiah-mark/" rel="tag">jeremiah mark</a><a href="https://www.nowgrenada.com/tag/robbery/" rel="tag">robbery</a><a href="https://www.nowgrenada.com/tag/save-n-gain/" rel="tag">save n gain</a><a href="https://www.nowgrenada.com/tag/trinidad/" rel="tag">trinidad</a></div>
                                                            </div>

<!--Footer Banner by Andel March 28 2019 -->

 
                            <div class="jeg_share_bottom_container"></div> 
                                                    </div>
 
                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div  class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_60627_0_5d605df6e808c   " data-unique="jnews_module_60627_0_5d605df6e808c">
                <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
                    <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
                    
                </div>
                <div class="jeg_block_container">
                
                <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag"> 
                    <article class="jeg_post jeg_pl_md_5 post-60632 post type-post status-publish format-standard has-post-thumbnail hentry category-notice-news category-weather-news tag-disaster tag-meteorological-office tag-nadma tag-tropical-wave">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/"><div class="thumbnail-container animate-lazy  size-715 "><img width="250" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/weather-news/" class="category-weather-news">Weather</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/">Advisory: An area of low pressure has developed</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/08/advisory-an-area-of-low-pressure-has-developed/" ><i class="fa fa-clock-o"></i> 23 August 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-60613 post type-post status-publish format-standard has-post-thumbnail hentry category-advertisement category-education category-press-release category-youth tag-college tag-education tag-how-to-survive-college tag-icon-leadership tag-online tag-roslyn-douglas tag-school tag-seminar">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="How to survive college – free online seminar" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-350x250.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-350x250.jpg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/08/free-sponsored-fier-How-to-Survive-College-120x86.jpg 120w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/education/" class="category-education">Education</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/">How to survive college – free online seminar</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/" ><i class="fa fa-clock-o"></i> 23 August 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-60602 post type-post status-publish format-standard has-post-thumbnail hentry category-advertisement category-business category-press-release tag-aaron-moses tag-business-2 tag-conferennce tag-disruptive-leadership tag-goblue tag-judy-mccutcheonn tag-leaderhip-series tag-leadership tag-management">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Disruptive Leadership: The Way of The Future" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-350x250.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-350x250.jpeg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/08/Disruptive-Leadership-120x86.jpeg 120w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/business/" class="category-business">Business</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/">Disruptive Leadership: The Way of The Future</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/08/disruptive-leadership-the-way-of-the-future/" ><i class="fa fa-clock-o"></i> 23 August 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                <div class="jeg_block_loadmore ">
                    <a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a>
                </div>
                
            </div>
                
                <script>var jnews_module_60627_0_5d605df6e808c = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":60627,"include_category":"9,8008,4,887,6615,6613,19492,6612,6614,4789","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":"3","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_22"};</script>
            </div></div><div class='jnews-autoload-splitter'  data-url="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/" data-title="Man linked to robbery in Grenada caught in Trinidad" data-id="60627"  data-prev="https://www.nowgrenada.com/2019/08/how-to-survive-college-free-online-seminar/" ></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=man-linked-to-robbery-in-grenada-caught-in-trinidad#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.nowgrenada.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='60627' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5477744222" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="227"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
                    
<!--FB Comments by Andel March 12 2019 -->
<div style="" id="the_champ_fb_commenting"><div class="fb-comments" data-href="https://www.nowgrenada.com/2019/08/man-linked-to-robbery-in-grenada-caught-in-trinidad/" data-numposts="" data-width="100%" ></div></div><script type="text/javascript" src="//connect.facebook.net/en_GB/sdk.js
    "></script><script>FB.init({xfbml:1,version: "v3.2"});</script>
                </div>
            </div>
            
<div class="jeg_sidebar   col-md-4">
    <div class="widget widget_text" id="text-2">			<div class="textwidget"><p><br />
<!-- Article Sidebar 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x90--><br />
<br />
<!-- Article Sidebar 300x300 --><br />
</p>
<p><!-- Article Sidebar 300x750 --><br />
</p>
</div>
		</div><div class="widget_text widget widget_custom_html" id="custom_html-7"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget_text widget widget_custom_html" id="custom_html-6"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget widget_awesomeweatherwidget" id="awesomeweatherwidget-4"><div id="awesome-weather-grenada-gd" class="awesome-weather-wrap awecf awe_tall temp6 awe_with_stats awe-code-801 awe-desc-few-clouds awe-preset-cloudy darken" style=" color: #ffffff; "><div class="awesome-weather-cover" style='background-image: url(https://www.nowgrenada.com/wp-content/plugins/awesome-weather/img/awe-backgrounds/cloudy.jpg);'><div class="awesome-weather-header">Grenada</div><div class="awesome-weather-current-temp"><strong>30<sup>&deg;</sup></strong></div><!-- /.awesome-weather-current-temp --><div class="awesome-weather-todays-stats"><div class="awe_desc">few clouds</div><div class="awe_humidty">humidity: 74%</div><div class="awe_wind">wind: 5m/s ESE</div><div class="awe_highlow">H 30 &bull; L 28</div></div><!-- /.awesome-weather-todays-stats --><div class="awesome-weather-forecast awe_days_4 awecf">
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">30<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Sat</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">29<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Sun</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">29<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Mon</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Tue</div>
				</div></div><!-- /.awesome-weather-forecast --><div class="awesome-weather-attribution">Weather from OpenWeatherMap</div></div><!-- /.awesome-weather-cover --></div> <!-- /.awesome-weather-wrap --></div></div>        </div>
 
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>
 
    </div>
</div>                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-60627 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_custom">
    <div class="jeg_container">
        <div class="jeg_content">
            <div class="jeg_vc_content">
                <div data-vc-full-width="true" data-vc-full-width-init="false" class="row vc_row vc_custom_1512030979094 vc_row-has-fill jnews_5d605df6ee59e footer_dark"><div class="jeg-vc-wrapper"><div class="footer_left wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper">
	<div class="wpb_text_column wpb_content_element  vc_custom_1551598731654 copyright" >
		<div class="wpb_wrapper">
			<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>

		</div>
	</div>
</div></div><div class="footer_right wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper"><div  class='jeg_social_icon_block socials_widget jnews_module_60627_1_5d605df6eef58 nobg '><a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div>
            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599"><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-54"><a href="https://www.nowgrenada.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527"><a href="https://www.nowgrenada.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://www.nowgrenada.com/category/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273"><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527"><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297"><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022"><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298"><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260"><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = []</script><div id="cookie-law-info-bar"><span>This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a>. <a  data-cli_action="accept" id="cookie_action_close_header"  class="small cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">ACCEPT</a></span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
    <div class="cli-modal-content cli-bar-popup">
      <button type="button" class="cli-modal-close" id="cliModalClose">
        <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
      </button>
      <div class="cli-modal-body">
        <div class="cli-container-fluid cli-tab-container">
    <div class="cli-row">
        <div class="cli-col-12 cli-align-items-stretch cli-px-0">
            <div class="cli-privacy-overview">
                <h4>Privacy Overview</h4>                                   
                <div class="cli-privacy-content">
                    <p class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</p>
                </div>
                <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a>            </div>
        </div>  
        <div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
            <div class="cli-tab-section cli-privacy-tab">
                <div class="cli-tab-header">
                    <a class="cli-nav-link cli-settings-mobile" >
                        Privacy Overview                    </a>
                </div>
                <div class="cli-tab-content">
                    <div class="cli-tab-pane cli-fade">
                        <p>This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</p>
                    </div>
                </div>

            </div>
              
           
                            <div class="cli-tab-section">
                    <div class="cli-tab-header">
                        <a class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" >
                            Necessary 
                        </a>
                    
                    <span class="cli-necessary-caption">Always Enabled</span>                     </div>
                    <div class="cli-tab-content">
                        <div class="cli-tab-pane cli-fade" data-id="necessary">
                            <p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p>
                        </div>
                    </div>
                </div>
              
           
                       
        </div>
    </div> 
</div> 
      </div>
    </div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<script type="text/javascript">
  /* <![CDATA[ */
  cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#ad0f0f","button_1_button_hover":"#8a0c0c","button_1_link_colour":"#fff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"button_2_hidebar":false,"button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#62a329","button_4_as_button":false,"font_family":"inherit","header_fix":false,"notify_animate_hide":false,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';
  /* ]]> */
</script><div id="selectShareContainer">
                    <div class="selectShare-inner">
                        <div class="select_share jeg_share_button">              
                            <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" data-image-url="" data-title="Man+linked+to+robbery+in+Grenada+caught+in+Trinidad" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F08%2Fman-linked-to-robbery-in-grenada-caught-in-trinidad%2F" data-image-url="" data-title="Man+linked+to+robbery+in+Grenada+caught+in+Trinidad" ><i class="fa fa-twitter"></i></a>
                        </div>
                        <div class="selectShare-arrowClip">
                            <div class="selectShare-arrow"></div>      
                        </div> 
                    </div>      
                  </div><div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"d MM yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-auto-load-post/assets/js/jquery.autoload.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/comment-reply.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","lang":"en_GB","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"60627","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"bottom_right","rtl":"0","gif":"1","site_slug":"\/","site_domain":"www.nowgrenada.com","autoload_limit":"20"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=1.0.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=1.0.0'></script>
<![endif]-->
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.1.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.12.32'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-embed.min.js?ver=e5aec9abeb0a99927ec8bd9bba642c61'></script>
<script async="async" type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.0.5'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div>    
    <script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
$('a').each(function() {
var a = new RegExp('/' + window.location.host + '/');
if(!a.test(this.href)) {
$(this).click(function(event) {
event.preventDefault();
event.stopPropagation();
window.open(this.href, '_blank');
});
}
});
});
//]]>
</script>
    
</body>
</html>

<!-- Dynamic page generated in 0.638 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-08-23 17:43:18 -->
