<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.nowgrenada.com/xmlrpc.php" />
    <title>Date set for NDC convention | NOW Grenada</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* allerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }


	/* Custom CSS */
	.bsaProContainer .bsaProHeader {
    display: none;
}
.bsaProItems, bsaProItemInner__thumb {
margin-bottom:10px !important;
}

.bsaProHeader__title {
    display: none !important;
}


.bsaProCarousel-22 {
    max-width: 300px !important;
}

.bsaProCarousel-9 {
    max-width: 300px !important;
}

.owl-controls {
    display: none !important;
} 

#bsa-block-720—300 {
max-width: 300px;
}


@media only screen and (min-width: 900px) {
.bsaPopupClose {
    position: absolute;
    cursor: pointer;
    top: 150px;
    right: 320px;
    width: 25px;
    height: 25px;
    background: url(../../img/close-black.png) white center center no-repeat;
}
}

.bsaProContainer-23 .bsaProItem {
margin-bottom: 15px !important;
}

.bsaProContainer-9 .bsaProItem {
margin-bottom: 15px !important;
}

.bsaProContainer-16 .bsaProItem {
margin-bottom: 12px !important
}

.bsaProItemInner__thumb {
width: 100% !important;
}
</style>	<script type="text/javascript">function theChampLoadEvent(e){var t=window.onload;if(typeof window.onload!="function"){window.onload=e}else{window.onload=function(){t();e()}}}</script>
		<script type="text/javascript">var theChampDefaultLang = 'en_GB', theChampCloseIconPath = 'https://www.nowgrenada.com/wp-content/plugins/super-socializer/images/close.png';</script>
		<script> var theChampSiteUrl = 'https://www.nowgrenada.com', theChampVerified = 0, theChampEmailPopup = 0; </script>
		<style type="text/css">.the_champ_horizontal_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_horizontal_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_horizontal_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	.the_champ_vertical_sharing .theChampSharing{
					color: #fff;
				border-width: 0px;
		border-style: solid;
		border-color: transparent;
	}
		.the_champ_vertical_sharing .theChampTCBackground{
		color:#666;
	}
		.the_champ_vertical_sharing .theChampSharing:hover{
				border-color: transparent;
	}
	@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.heateor_ss_mobile_footer{display:none;}@media screen and (max-width:783px){i.theChampTCBackground{background-color:white!important}div.the_champ_bottom_sharing{width:100%!important;left:0!important;}div.the_champ_bottom_sharing li{width:11.111111111111% !important;}div.the_champ_bottom_sharing .theChampSharing{width: 100% !important;}div.the_champ_bottom_sharing div.theChampTotalShareCount{font-size:1em!important;line-height:28px!important}div.the_champ_bottom_sharing div.theChampTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_ss_mobile_footer{display:block;height:40px;}.the_champ_bottom_sharing{padding:0!important;display:block!important;width: auto!important;bottom:-2px!important;top: auto!important;}.the_champ_bottom_sharing .the_champ_square_count{line-height: inherit;}.the_champ_bottom_sharing .theChampSharingArrow{display:none;}.the_champ_bottom_sharing .theChampTCBackground{margin-right: 1.1em !important}}</style>
	            <script type="text/javascript"> var jnews_ajax_url = 'https://www.nowgrenada.com/?ajax-request=jnews'; </script>
            
<!-- All in One SEO Pack 3.2.8 by Michael Torbert of Semper Fi Web Design[989,1043] -->
<meta name="description"  content="A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre." />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.nowgrenada.com/#organization","url":"https://www.nowgrenada.com/","name":"NOW Grenada","sameAs":[]},{"@type":"WebSite","@id":"https://www.nowgrenada.com/#website","url":"https://www.nowgrenada.com/","name":"NOW Grenada","publisher":{"@id":"https://www.nowgrenada.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.nowgrenada.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.nowgrenada.com#webpage","url":"https://www.nowgrenada.com","inLanguage":"en-GB","name":"Date set for NDC convention","isPartOf":{"@id":"https://www.nowgrenada.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com#primaryimage","url":"https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg","width":357,"height":323},"primaryImageOfPage":{"@id":"https://www.nowgrenada.com#primaryimage"},"datePublished":"2019-09-24T16:36:41+00:00","dateModified":"2019-09-24T16:36:41+00:00","description":"A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre."},{"@type":"Article","@id":"https://www.nowgrenada.com#article","isPartOf":{"@id":"https://www.nowgrenada.com#webpage"},"author":{"@id":"https://www.nowgrenada.com/author/suelin/#author"},"headline":"Date set for NDC convention","datePublished":"2019-09-24T16:36:41+00:00","dateModified":"2019-09-24T16:36:41+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.nowgrenada.com#webpage"},"publisher":{"@id":"https://www.nowgrenada.com/#organization"},"articleSection":"Politics, convention, joseph andall, linda straker, national democratic congress, randal robinson, raymond roberts, vincent Roberts","image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com#primaryimage","url":"https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg","width":357,"height":323}},{"@type":"Person","@id":"https://www.nowgrenada.com/author/suelin/#author","name":"NOW Grenada","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.nowgrenada.com/#personlogo","url":"https://secure.gravatar.com/avatar/55c565a497d409c71da09976211e9106?s=96&d=mm&r=g","width":96,"height":96,"caption":"NOW Grenada"}}]}</script>
<link rel="canonical" href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/" />
<!-- All in One SEO Pack -->
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Feed" href="https://www.nowgrenada.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Comments Feed" href="https://www.nowgrenada.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Date set for NDC convention Comments Feed" href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=c23615977040a396e5a599d7ecf8580c"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.nowgrenada.com/wp-includes/css/dist/block-library/style.min.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='_ning_font_awesome_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/angwp/assets/fonts/font-awesome/css/font-awesome.min.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='_ning_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/angwp/assets/dist/angwp.bundle.js.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='spr_col_animate_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/css/animate.min.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='spr_col_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/css/spr_columns.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='https://www.nowgrenada.com/wp-content/plugins/awesome-weather/awesome-weather.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/style.css?v=4.1&#038;ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/user-panel.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/all.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/animate.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/chart.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_owl_carousel_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/bsa.carousel.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/material-design.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-css'  href='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-parent-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/style.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='the_champ_frontend_css-css'  href='https://www.nowgrenada.com/wp-content/plugins/super-socializer/css/front.css?ver=7.12.34' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.5' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='js_composer_front-css'  href='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.0.5' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=c23615977040a396e5a599d7ecf8580c' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews-child/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var gadwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|rar*","event_bouncerate":0,"aff_tracking":1,"event_affiliates":"\/out\/","hash_tracking":"1","root_domain":"nowgrenada.com","event_timeout":100,"event_precision":0,"event_formsubmit":1,"ga_pagescrolldepth_tracking":1,"ga_with_gtag":0}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/google-analytics-dashboard-for-wp/front/js/tracking-analytics-events.js?ver=5.3.9'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/google-analytics-dashboard-for-wp/front/js/tracking-scrolldepth.js?ver=5.3.9'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/angwp/assets/dev/js/advertising.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/shortcode.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-admin/js/media-upload.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/script.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/chart.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/bsa.carousel.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-pro-scripteo/frontend/js/custom.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[]};
var log_object = {"ajax_url":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js?ver=1.8.0'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.nowgrenada.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nowgrenada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nowgrenada.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='School spirit: US colleges pave the road to track success' href='https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab' />
<link rel='next' title='General Hospital PAHO-certified as baby friendly' href='https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/' />

<link rel='shortlink' href='https://www.nowgrenada.com/?p=61722' />
<link rel="alternate" type="application/json+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F&#038;format=xml" />
		<script type="text/javascript">
			var cli_flush_cache=1;
		</script>
		      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.nowgrenada.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e0fbff27-0ea3-4e3f-a8d9-a4c7eac9ccc8';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "NOW Grenada";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing to nowgrenada.com!";
oneSignal_options['welcomeNotification']['url'] = "https://www.nowgrenada.com";
oneSignal_options['path'] = "https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4463433a-b41c-4a34-809b-879a9d93883b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = 'wants to show Notifications';
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = 'Example Notification Title';
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = 'Notifications will appear on your desktop';
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = 'Example Notification';
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = 'Notifications will appear on your mobile';
oneSignal_options['promptOptions']['exampleNotificationCaption'] = '(you can unsubscribe anytime)';
oneSignal_options['promptOptions']['acceptButtonText'] = 'CONTINUE';
oneSignal_options['promptOptions']['cancelButtonText'] = 'NO THANKS';
oneSignal_options['promptOptions']['siteName'] = 'http://www.nowgrenada.com';
oneSignal_options['promptOptions']['autoAcceptTitle'] = 'Click Allow';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = false;
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

<!-- Ads on this site are served by Adning v1.4.0 - adning.com -->
<style></style><!-- / Adning. -->

<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-270x270.png" />

<!-- BEGIN ExactMetrics v5.3.9 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-89948788-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display: none;}</style>		<style type="text/css" id="wp-custom-css">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</style>
		<style type="text/css" data-type="vc_shortcodes-custom-css">.vc_custom_1512030979094{padding-top: 20px !important;padding-bottom: 20px !important;background-color: #212121 !important;}.vc_custom_1551598731654{margin-bottom: 0px !important;}</style><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
<!-- START - Open Graph and Twitter Card Tags 2.2.7.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="NOW Grenada"/>
  <meta property="og:title" content="Date set for NDC convention"/>
  <meta property="og:url" content="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre."/>
  <meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"/>
  <meta property="og:image:url" content="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"/>
  <meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"/>
  <meta property="article:published_time" content="2019-09-24T12:36:41-04:00"/>
  <meta property="article:modified_time" content="2019-09-24T12:36:41-04:00" />
  <meta property="og:updated_time" content="2019-09-24T12:36:41-04:00" />
  <meta property="article:section" content="Politics"/>
  <meta property="article:publisher" content="https://www.facebook.com/NOWGrenada/"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Date set for NDC convention"/>
  <meta itemprop="headline" content="Date set for NDC convention"/>
  <meta itemprop="description" content="A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre."/>
  <meta itemprop="image" content="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"/>
  <meta itemprop="datePublished" content="2019-09-24"/>
  <meta itemprop="dateModified" content="2019-09-24T12:36:41-04:00" />
  <meta itemprop="author" content="NOW Grenada"/>
  <!--<meta itemprop="publisher" content="NOW Grenada"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Date set for NDC convention"/>
  <meta name="twitter:url" content="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/"/>
  <meta name="twitter:description" content="A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre."/>
  <meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@nowgrenada"/>
 <!-- SEO -->
  <meta name="description" content="A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre."/>
  <meta name="publisher" content="NOW Grenada"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 2.2.7.1 -->
	
</head>
<body class="post-template-default single single-post postid-61722 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive">

    
        <div id="jeg_sidecontent">
        <div class="jeg_side_heading">
            <ul class="jeg_side_tabs">
				<li data-tab-content="tab1" data-sort='latest' class="active">Latest</li>            </ul>
            <div class="jeg_side_feed_cat_wrapper">
				            </div>
			<script> var side_feed = {"paged":1,"post_type":"post","exclude_post":61722,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":12,"number_post":12,"pagination_mode":"loadmore"}; </script>        </div>

        <div class="sidecontent_postwrapper">
            <div class="jeg_sidefeed">
				<div class="jeg_post jeg_pl_md_box active " data-id="61722" data-sequence="0">
                        <div class="overlay_container">
                            <div class="jeg_thumb">
                                
                                <a class="ajax" href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/"><div class="thumbnail-container animate-lazy  size-500 "><img width="199" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Press Statement – Budget 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg 357w, https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n-150x136.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n-300x271.jpg 300w" data-expand="700" /></div></a>
                            </div>
                            <div class="jeg_postblock_content">
                                <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/">Date set for NDC convention</a></h2>
                                <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 10 hours ago</div></div>
                            </div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61741" data-sequence="1">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Diving wreck Tyrell Bay celebrates 1st anniversary" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/04-MV-Tyrell-2019-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/">Diving wreck Tyrell Bay celebrates 1st anniversary</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 6 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61690" data-sequence="2">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Captain Jex leads team on Bahamas humanitarian mission" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/">Captain Jex leads team on Bahamas humanitarian mission</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 7 hours ago</div></div>
                        </div>
                    </div><div class="jeg_ad jnews_sidefeed_ads"><div class='ads-wrapper jeg_ad_sidecontent '></div></div><div class="jeg_post jeg_pl_xs_3  " data-id="61727" data-sequence="3">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Sandals Foundation and MBIA volunteers clean up Devil’s Bay" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/MBIA-volunteer-celebrates-a-cleaner-beach-toward-the-end-of-the-cleanup-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/">Sandals Foundation and MBIA volunteers clean up Devil’s Bay</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61707" data-sequence="4">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="70" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg 364w, https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235-140x150.jpeg 140w, https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235-281x300.jpeg 281w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61724" data-sequence="5">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="General Hospital PAHO-certified as baby friendly" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PAHO-certification-to-the-hospital-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/">General Hospital PAHO-certified as baby friendly</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61710" data-sequence="6">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="School spirit: US colleges pave the road to track success" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-2014-e1569344448574-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab">School spirit: US colleges pave the road to track success</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 10 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61703" data-sequence="7">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-75x75.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-75x75.png 75w, https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-100x100.png 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 12 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61700" data-sequence="8">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Spice Isle Imaging celebrates 15 years of service to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_0130-e1569332289433-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/">Spice Isle Imaging celebrates 15 years of service to Grenada</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 13 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61694" data-sequence="9">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="From pelting mangoes to global titles – Anderson Peters sets sights on Doha" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-100x100.jpg 100w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab">From pelting mangoes to global titles – Anderson Peters sets sights on Doha</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 14 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61697" data-sequence="10">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="73" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png 300w, https://www.nowgrenada.com/wp-content/uploads/2013/02/crest-150x146.png 150w, https://www.nowgrenada.com/wp-content/uploads/2013/02/crest-38x38.png 38w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/">Prime Minister at United Nations this week</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 14 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61686" data-sequence="11">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/embracing-the-change/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Embracing the Change" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-150x150.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler.jpg 240w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/embracing-the-change/">Embracing the Change</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 day ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="61674" data-sequence="12">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Man caught with drugs at MBIA while out on bail" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-75x75.jpg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-75x75.jpg 75w, https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-150x150.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-300x300.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178.jpg 434w" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/">Man caught with drugs at MBIA while out on bail</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 day ago</div></div>
                        </div>
                    </div>            </div>
            <div class="sidefeed_loadmore">
	                            <button class="btn "
                        data-end="End of Content"
                        data-loading="Loading..."
                        data-loadmore="Load More">
					End of Content                </button>
            </div>
        </div>
        <div class="jeg_sidefeed_overlay">
            <div class='preloader_type preloader_dot'>
                <div class="sidefeed-preloader jeg_preloader dot">
                    <span></span><span></span><span></span>
                </div>
                <div class="sidefeed-preloader jeg_preloader circle">
                    <div class="jnews_preloader_circle_outer">
                        <div class="jnews_preloader_circle_inner"></div>
                    </div>
                </div>
                <div class="sidefeed-preloader jeg_preloader square">
                    <div class="jeg_square">
                        <div class="jeg_square_inner"></div>
                    </div>
                </div>
            </div>
        </div>
    </div>
	

    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/" style="padding: 0 0 0 0;">
	    	    <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" data-dark-src="" data-dark-srcset=" 1x,  2x">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '><div class='ads_shortcode'><div id="bsa-html" class="bsaProContainer bsaProContainer-10 bsa-html bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Footer 468x60</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=10" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=15&bsa_pro_url=http://netherlands.co.gd" target="_blank"><img class="netherlands-ad" src="https://www.nowgrenada.com/wp-content/uploads/2017/12/banner468x60Netherlands1.gif" title="Netherlands" styles="margin-bottom: 25px !important;"/>
<div class="spacer"></div>
</a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					</div></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-60599" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Captain Jex leads team on Bahamas humanitarian mission" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/">Captain Jex leads team on Bahamas humanitarian mission</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation and MBIA volunteers clean up Devil’s Bay" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/MBIA-volunteer-celebrates-a-cleaner-beach-toward-the-end-of-the-cleanup-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/">Sandals Foundation and MBIA volunteers clean up Devil’s Bay</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container size-500 "><img width="168" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man caught with drugs at MBIA while out on bail" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/">Man caught with drugs at MBIA while out on bail</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/stepson-charged-with-murder-of-carriacou-resident/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Stepson charged with murder of Carriacou resident" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3520-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/stepson-charged-with-murder-of-carriacou-resident/">Stepson charged with murder of Carriacou resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.looptt.com/content/why-you-need-make-grenada-your-next-adventure-destination#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why you need to make Grenada your next adventure destination" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Mount-Qua-Qua-sits-overlooking-the-Grand-Etang-National-Park-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.looptt.com/content/why-you-need-make-grenada-your-next-adventure-destination#new_tab">Why you need to make Grenada your next adventure destination</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/">Tropical Storm Karen: All clear given</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/">Tropical Storm Karen moves 85 Miles away from Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-55527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Diving wreck Tyrell Bay celebrates 1st anniversary" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/04-MV-Tyrell-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/">Diving wreck Tyrell Bay celebrates 1st anniversary</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="School spirit: US colleges pave the road to track success" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-2014-e1569344448574-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab">School spirit: US colleges pave the road to track success</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="From pelting mangoes to global titles – Anderson Peters sets sights on Doha" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab">From pelting mangoes to global titles – Anderson Peters sets sights on Doha</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_9310-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/">GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/marine-craft-operators-advisory-grand-anse-beach/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/marine-craft-operators-advisory-grand-anse-beach/">Marine craft operators advisory: Grand Anse beach</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grand-anse-beach-is-home-to-inaugural-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grand Anse beach is home to Inaugural Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PHOTO-2019-09-18-08-26-32-4-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grand-anse-beach-is-home-to-inaugural-ariza-pure-grenada-open-water-swim-invitational/">Grand Anse beach is home to Inaugural Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/cricket-and-climate-change/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Regional Security System T20 Cricket Tournament" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/03/cricket_ball.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/cricket-and-climate-change/">Cricket and climate change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenada-at-world-boxing-championships-russia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada at World Boxing Championships, Russia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/20190906_203026-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenada-at-world-boxing-championships-russia/">Grenada at World Boxing Championships, Russia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spicy-tuna-fishing-tournament-to-donate-50-of-tuna-caught-to-charity/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicy Tuna Fishing Tournament to donate 50% of tuna caught to charity" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_1407-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spicy-tuna-fishing-tournament-to-donate-50-of-tuna-caught-to-charity/">Spicy Tuna Fishing Tournament to donate 50% of tuna caught to charity</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Captain Jex leads team on Bahamas humanitarian mission" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/">Captain Jex leads team on Bahamas humanitarian mission</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenadas-international-brain-bee-participant-thankful-for-experience/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada’s International Brain Bee participant thankful for experience" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/WhatsApp-Image-2019-09-22b-at-9.00.47-AM-e1569339376360-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenadas-international-brain-bee-participant-thankful-for-experience/">Grenada’s International Brain Bee participant thankful for experience</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/move-to-update-policy-on-ageing-due-to-expected-rise-in-elderly-population/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Overdue &#8211; Top Hill Senior Citizen Home" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/pensioner-elderly-hands-old.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/move-to-update-policy-on-ageing-due-to-expected-rise-in-elderly-population/">Move to update policy on ageing due to expected rise in elderly population</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/creating-a-culture-of-kindness-and-inclusiveness-in-schools/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Creating a culture of kindness and inclusiveness in schools" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PHOTO-2019-09-17-21-10-13-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/creating-a-culture-of-kindness-and-inclusiveness-in-schools/">Creating a culture of kindness and inclusiveness in schools</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenada-heads-to-south-korea-for-international-brain-bee-championship/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada heads to South Korea for International Brain Bee Championship" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Jevonie-Thomas-e1569332899183-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenada-heads-to-south-korea-for-international-brain-bee-championship/">Grenada heads to South Korea for International Brain Bee Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/qualishore-partners-with-homes-for-children-to-provide-back-to-school-needs/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Qualishore partners with homes for children to provide back-to-school needs" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Bel-Air-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/qualishore-partners-with-homes-for-children-to-provide-back-to-school-needs/">Qualishore partners with homes for children to provide back-to-school needs</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gutcu-awards-12000-in-scholarship-to-tamcc-students/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GUTCU awards $12,000 in scholarships to TAMCC students" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/GUTCU-TAMCC-recipients-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gutcu-awards-12000-in-scholarship-to-tamcc-students/">GUTCU awards $12,000 in scholarships to TAMCC students</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxviii-child-labour/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxviii-child-labour/">Minding Your Legal Affairs XXVIII: Child Labour</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="General Hospital PAHO-certified as baby friendly" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PAHO-certification-to-the-hospital-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/">General Hospital PAHO-certified as baby friendly</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Isle Imaging celebrates 15 years of service to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_0130-e1569332289433-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/">Spice Isle Imaging celebrates 15 years of service to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/embracing-the-change/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Embracing the Change" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/embracing-the-change/">Embracing the Change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5th Grenada Contemporary set to open at Art House 473" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/photo-Art-House-473-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/">5th Grenada Contemporary set to open at Art House 473</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://vinepair.com/articles/craft-soda-coca-cola#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Can craft mixers and heritage ingredients ever dethrone big soda?" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/kola-nuts-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://vinepair.com/articles/craft-soda-coca-cola#new_tab">Can craft mixers and heritage ingredients ever dethrone big soda?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/oxygen-system-at-general-hospital-restored-after-2-years-of-inactivity/"><div class="thumbnail-container size-500 "><img width="306" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Cardiovascular Surgeries at General Hospital" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/10/general-hospital-st-george.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/oxygen-system-at-general-hospital-restored-after-2-years-of-inactivity/">Oxygen system at General Hospital restored after 2 years of inactivity</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/thousands-of-grenadians-served-by-usns-comfort-medical-services/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="USNS Comfort on humanitarian mission to countries overwhelmed by Venezuelans" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/US-Naval-Ship-Comfort-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/thousands-of-grenadians-served-by-usns-comfort-medical-services/">Thousands of Grenadians served by USNS Comfort medical services</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/12n61w-grenadian-film-festival-launches-1261-international-film-series-showcase/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/9330db60-73a3-41c8-888f-02a28f602f5e-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/12n61w-grenadian-film-festival-launches-1261-international-film-series-showcase/">12°N61°W Grenadian Film Festival launches 1261 international film series showcase</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://brixtonblog.com/2019/09/brixton-blue-new-art-for-our-underground/?cn-reloaded=1#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian artist&#8217;s new art for Brixton Underground" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Denzil-Forrester-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://brixtonblog.com/2019/09/brixton-blue-new-art-for-our-underground/?cn-reloaded=1#new_tab">Grenadian artist&#8217;s new art for Brixton Underground</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container size-500 "><img width="168" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/embracing-the-change/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Embracing the Change" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/embracing-the-change/">Embracing the Change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/ndc-heartbeat-mitchells-attack-on-the-free-press/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/ndc-heartbeat-mitchells-attack-on-the-free-press/">NDC Heartbeat: Mitchell’s attack on the Free Press</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/ndc-statement-on-the-accident-of-20-september-on-the-carenage/"><div class="thumbnail-container size-500 "><img width="199" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Press Statement – Budget 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/ndc-statement-on-the-accident-of-20-september-on-the-carenage/">NDC statement on the accident of 20 September on the Carenage</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.forbes.com/sites/daphneewingchow/2019/09/20/caribbean-islands-are-the-biggest-plastic-polluters-per-capita-in-the-world/#653849f3774b#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada among biggest plastic polluters per capita in the world" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/garbage-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.forbes.com/sites/daphneewingchow/2019/09/20/caribbean-islands-are-the-biggest-plastic-polluters-per-capita-in-the-world/#653849f3774b#new_tab">Grenada among biggest plastic polluters per capita in the world</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/open-letter-to-hon-clarice-modeste-curwen/"><div class="thumbnail-container size-500 "><img width="323" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Part I: The Integrity Commission" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/Sandra-Ferguson.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/open-letter-to-hon-clarice-modeste-curwen/">Open letter to Hon. Clarice Modeste-Curwen</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxix-the-shared-responsibility-of-road-maintenance/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxix-the-shared-responsibility-of-road-maintenance/">Minding Your Legal Affairs XXIX: The shared responsibility of road maintenance</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.theguardian.com/uk-news/2019/sep/14/scale-misery-devastating-inside-story-reporting-windrush-scandal#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Chased into ‘self-deportation’: the most disturbing Windrush case so far" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Joycelyn-John.-Photo-Yves-SalmonThe-Guardian-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.theguardian.com/uk-news/2019/sep/14/scale-misery-devastating-inside-story-reporting-windrush-scandal#new_tab">Chased into ‘self-deportation’: the most disturbing Windrush case so far</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/61276/"><div class="thumbnail-container size-500 "><img width="319" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/02/image02.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/61276/">State of Affairs (Governance)</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-56527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Diving wreck Tyrell Bay celebrates 1st anniversary" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/04-MV-Tyrell-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/">Diving wreck Tyrell Bay celebrates 1st anniversary</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation and MBIA volunteers clean up Devil’s Bay" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/MBIA-volunteer-celebrates-a-cleaner-beach-toward-the-end-of-the-cleanup-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/">Sandals Foundation and MBIA volunteers clean up Devil’s Bay</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Isle Imaging celebrates 15 years of service to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_0130-e1569332289433-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/">Spice Isle Imaging celebrates 15 years of service to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/"><div class="thumbnail-container size-500 "><img width="185" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/">Prime Minister at United Nations this week</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_9310-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/">GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5th Grenada Contemporary set to open at Art House 473" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/photo-Art-House-473-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/">5th Grenada Contemporary set to open at Art House 473</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/">Tropical Storm Karen: All clear given</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/">Tropical Storm Karen moves 85 Miles away from Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li id="menu-item-10297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-12022" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li id="menu-item-10298" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li id="menu-item-24260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">News</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="9" class="active"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
                        <li data-cat-id="8008" class=""><a href="https://www.nowgrenada.com/category/news/agriculture/">Agriculture</a></li><li data-cat-id="4" class=""><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li><li data-cat-id="887" class=""><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li><li data-cat-id="6615" class=""><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li><li data-cat-id="6613" class=""><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li><li data-cat-id="19492" class=""><a href="https://www.nowgrenada.com/category/news/history/">History</a></li><li data-cat-id="6612" class=""><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li><li data-cat-id="6614" class=""><a href="https://www.nowgrenada.com/category/news/tourism/">Tourism</a></li><li data-cat-id="4789" class=""><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="9" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Captain Jex leads team on Bahamas humanitarian mission" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/">Captain Jex leads team on Bahamas humanitarian mission</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation and MBIA volunteers clean up Devil’s Bay" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/MBIA-volunteer-celebrates-a-cleaner-beach-toward-the-end-of-the-cleanup-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/">Sandals Foundation and MBIA volunteers clean up Devil’s Bay</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container size-500 "><img width="168" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Man caught with drugs at MBIA while out on bail" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3521-e1569332537178-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/man-caught-with-drugs-at-mbia-while-out-on-bail/">Man caught with drugs at MBIA while out on bail</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/stepson-charged-with-murder-of-carriacou-resident/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Stepson charged with murder of Carriacou resident" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3520-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/stepson-charged-with-murder-of-carriacou-resident/">Stepson charged with murder of Carriacou resident</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="http://www.looptt.com/content/why-you-need-make-grenada-your-next-adventure-destination#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Why you need to make Grenada your next adventure destination" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Mount-Qua-Qua-sits-overlooking-the-Grand-Etang-National-Park-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="http://www.looptt.com/content/why-you-need-make-grenada-your-next-adventure-destination#new_tab">Why you need to make Grenada your next adventure destination</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/">Tropical Storm Karen: All clear given</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/">Tropical Storm Karen moves 85 Miles away from Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="6" class="active"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
                        <li data-cat-id="14" class=""><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li><li data-cat-id="42" class=""><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li><li data-cat-id="43" class=""><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li><li data-cat-id="19395" class=""><a href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="6" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Diving wreck Tyrell Bay celebrates 1st anniversary" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/04-MV-Tyrell-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/">Diving wreck Tyrell Bay celebrates 1st anniversary</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="School spirit: US colleges pave the road to track success" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-2014-e1569344448574-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab">School spirit: US colleges pave the road to track success</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="From pelting mangoes to global titles – Anderson Peters sets sights on Doha" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Anderson-Peters-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.sportsmax.tv/index.php/athletics/athletics-international/item/47754-from-pelting-mangoes-to-global-titles-anderson-peters-sets-sights-on-doha#new_tab">From pelting mangoes to global titles – Anderson Peters sets sights on Doha</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_9310-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/">GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/marine-craft-operators-advisory-grand-anse-beach/"><div class="thumbnail-container size-500 "><img width="176" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/02/gsm-image-6a1914ba-ab20-4d87-84c0-87bf10392db0.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/marine-craft-operators-advisory-grand-anse-beach/">Marine craft operators advisory: Grand Anse beach</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grand-anse-beach-is-home-to-inaugural-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grand Anse beach is home to Inaugural Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PHOTO-2019-09-18-08-26-32-4-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grand-anse-beach-is-home-to-inaugural-ariza-pure-grenada-open-water-swim-invitational/">Grand Anse beach is home to Inaugural Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/cricket-and-climate-change/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Regional Security System T20 Cricket Tournament" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/03/cricket_ball.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/cricket-and-climate-change/">Cricket and climate change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenada-at-world-boxing-championships-russia/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada at World Boxing Championships, Russia" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/20190906_203026-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenada-at-world-boxing-championships-russia/">Grenada at World Boxing Championships, Russia</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spicy-tuna-fishing-tournament-to-donate-50-of-tuna-caught-to-charity/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spicy Tuna Fishing Tournament to donate 50% of tuna caught to charity" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_1407-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spicy-tuna-fishing-tournament-to-donate-50-of-tuna-caught-to-charity/">Spicy Tuna Fishing Tournament to donate 50% of tuna caught to charity</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="8" class="active"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
                        <li data-cat-id="46" class=""><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li><li data-cat-id="44" class=""><a href="https://www.nowgrenada.com/category/community/youth/">Youth</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="8" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Captain Jex leads team on Bahamas humanitarian mission" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_3475-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/captain-jex-leads-team-on-bahamas-humanitarian-mission/">Captain Jex leads team on Bahamas humanitarian mission</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenadas-international-brain-bee-participant-thankful-for-experience/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada’s International Brain Bee participant thankful for experience" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/WhatsApp-Image-2019-09-22b-at-9.00.47-AM-e1569339376360-360x180.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenadas-international-brain-bee-participant-thankful-for-experience/">Grenada’s International Brain Bee participant thankful for experience</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/move-to-update-policy-on-ageing-due-to-expected-rise-in-elderly-population/"><div class="thumbnail-container size-500 "><img width="270" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Overdue &#8211; Top Hill Senior Citizen Home" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/06/pensioner-elderly-hands-old.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/move-to-update-policy-on-ageing-due-to-expected-rise-in-elderly-population/">Move to update policy on ageing due to expected rise in elderly population</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/creating-a-culture-of-kindness-and-inclusiveness-in-schools/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Creating a culture of kindness and inclusiveness in schools" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PHOTO-2019-09-17-21-10-13-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/creating-a-culture-of-kindness-and-inclusiveness-in-schools/">Creating a culture of kindness and inclusiveness in schools</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/grenada-heads-to-south-korea-for-international-brain-bee-championship/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada heads to South Korea for International Brain Bee Championship" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Jevonie-Thomas-e1569332899183-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/grenada-heads-to-south-korea-for-international-brain-bee-championship/">Grenada heads to South Korea for International Brain Bee Championship</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/qualishore-partners-with-homes-for-children-to-provide-back-to-school-needs/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Qualishore partners with homes for children to provide back-to-school needs" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Bel-Air-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/qualishore-partners-with-homes-for-children-to-provide-back-to-school-needs/">Qualishore partners with homes for children to provide back-to-school needs</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gutcu-awards-12000-in-scholarship-to-tamcc-students/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GUTCU awards $12,000 in scholarships to TAMCC students" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/GUTCU-TAMCC-recipients-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gutcu-awards-12000-in-scholarship-to-tamcc-students/">GUTCU awards $12,000 in scholarships to TAMCC students</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxviii-child-labour/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxviii-child-labour/">Minding Your Legal Affairs XXVIII: Child Labour</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="7" class="active"><a href="https://www.nowgrenada.com/category/lifestyle/">All</a></li>
                        <li data-cat-id="5" class=""><a href="https://www.nowgrenada.com/category/lifestyle/arts_culture/">Arts &amp; Culture</a></li><li data-cat-id="45" class=""><a href="https://www.nowgrenada.com/category/lifestyle/health/">Health</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="7" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="General Hospital PAHO-certified as baby friendly" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PAHO-certification-to-the-hospital-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/">General Hospital PAHO-certified as baby friendly</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Isle Imaging celebrates 15 years of service to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_0130-e1569332289433-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/">Spice Isle Imaging celebrates 15 years of service to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/embracing-the-change/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Embracing the Change" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/embracing-the-change/">Embracing the Change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5th Grenada Contemporary set to open at Art House 473" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/photo-Art-House-473-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/">5th Grenada Contemporary set to open at Art House 473</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://vinepair.com/articles/craft-soda-coca-cola#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Can craft mixers and heritage ingredients ever dethrone big soda?" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/kola-nuts-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://vinepair.com/articles/craft-soda-coca-cola#new_tab">Can craft mixers and heritage ingredients ever dethrone big soda?</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/oxygen-system-at-general-hospital-restored-after-2-years-of-inactivity/"><div class="thumbnail-container size-500 "><img width="306" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Cardiovascular Surgeries at General Hospital" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/10/general-hospital-st-george.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/oxygen-system-at-general-hospital-restored-after-2-years-of-inactivity/">Oxygen system at General Hospital restored after 2 years of inactivity</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/thousands-of-grenadians-served-by-usns-comfort-medical-services/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="USNS Comfort on humanitarian mission to countries overwhelmed by Venezuelans" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/06/US-Naval-Ship-Comfort-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/thousands-of-grenadians-served-by-usns-comfort-medical-services/">Thousands of Grenadians served by USNS Comfort medical services</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/12n61w-grenadian-film-festival-launches-1261-international-film-series-showcase/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/04/9330db60-73a3-41c8-888f-02a28f602f5e-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/12n61w-grenadian-film-festival-launches-1261-international-film-series-showcase/">12°N61°W Grenadian Film Festival launches 1261 international film series showcase</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://brixtonblog.com/2019/09/brixton-blue-new-art-for-our-underground/?cn-reloaded=1#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenadian artist&#8217;s new art for Brixton Underground" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Denzil-Forrester-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://brixtonblog.com/2019/09/brixton-blue-new-art-for-our-underground/?cn-reloaded=1#new_tab">Grenadian artist&#8217;s new art for Brixton Underground</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="485" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel no_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container size-500 "><img width="168" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/embracing-the-change/"><div class="thumbnail-container size-500 "><img width="240" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Embracing the Change" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/sadler-240x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/embracing-the-change/">Embracing the Change</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/ndc-heartbeat-mitchells-attack-on-the-free-press/"><div class="thumbnail-container size-500 "><img width="256" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Opposition Party launches Policy Agenda" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/NDC-LOGO-1-.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/ndc-heartbeat-mitchells-attack-on-the-free-press/">NDC Heartbeat: Mitchell’s attack on the Free Press</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/ndc-statement-on-the-accident-of-20-september-on-the-carenage/"><div class="thumbnail-container size-500 "><img width="199" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Press Statement – Budget 2013" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/ndc-statement-on-the-accident-of-20-september-on-the-carenage/">NDC statement on the accident of 20 September on the Carenage</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.forbes.com/sites/daphneewingchow/2019/09/20/caribbean-islands-are-the-biggest-plastic-polluters-per-capita-in-the-world/#653849f3774b#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada among biggest plastic polluters per capita in the world" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/garbage-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.forbes.com/sites/daphneewingchow/2019/09/20/caribbean-islands-are-the-biggest-plastic-polluters-per-capita-in-the-world/#653849f3774b#new_tab">Grenada among biggest plastic polluters per capita in the world</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/open-letter-to-hon-clarice-modeste-curwen/"><div class="thumbnail-container size-500 "><img width="323" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Part I: The Integrity Commission" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/03/Sandra-Ferguson.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/open-letter-to-hon-clarice-modeste-curwen/">Open letter to Hon. Clarice Modeste-Curwen</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxix-the-shared-responsibility-of-road-maintenance/"><div class="thumbnail-container size-500 "><img width="172" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Grenada Bar Association honours 2 retired High Court judges" data-src="https://www.nowgrenada.com/wp-content/uploads/2018/02/1234645_411705442355460_8672971500475936205_n.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/minding-your-legal-affairs-xxix-the-shared-responsibility-of-road-maintenance/">Minding Your Legal Affairs XXIX: The shared responsibility of road maintenance</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.theguardian.com/uk-news/2019/sep/14/scale-misery-devastating-inside-story-reporting-windrush-scandal#new_tab"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Chased into ‘self-deportation’: the most disturbing Windrush case so far" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Joycelyn-John.-Photo-Yves-SalmonThe-Guardian-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.theguardian.com/uk-news/2019/sep/14/scale-misery-devastating-inside-story-reporting-windrush-scandal#new_tab">Chased into ‘self-deportation’: the most disturbing Windrush case so far</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/61276/"><div class="thumbnail-container size-500 "><img width="319" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/02/image02.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/61276/">State of Affairs (Governance)</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527 bgnav jeg_megamenu category_1" data-number="9"  data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a><div class="sub-menu">
                <div class="jeg_newsfeed clearfix">
                    <div class="jeg_newsfeed_subcat">
                    <ul class="jeg_subcat_item">
                        <li data-cat-id="4923" class="active"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
                        <li data-cat-id="12758" class=""><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisement</a></li><li data-cat-id="5180" class=""><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notice</a></li><li data-cat-id="8671" class=""><a href="https://www.nowgrenada.com/category/press-release/vacancy/">Vacancy</a></li>
                    </ul>
                </div>
                    <div class="jeg_newsfeed_list">
                        <div data-cat-id="4923" data-load-status="loaded" class="jeg_newsfeed_container">
                            <div class="newsfeed_carousel owl-carousel with_subcat">
                                <div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Diving wreck Tyrell Bay celebrates 1st anniversary" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/04-MV-Tyrell-2019-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/diving-wreck-tyrell-bay-celebrates-1st-anniversary/">Diving wreck Tyrell Bay celebrates 1st anniversary</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Sandals Foundation and MBIA volunteers clean up Devil’s Bay" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/MBIA-volunteer-celebrates-a-cleaner-beach-toward-the-end-of-the-cleanup-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/sandals-foundation-and-mbia-volunteers-clean-up-devils-bay/">Sandals Foundation and MBIA volunteers clean up Devil’s Bay</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Launch of the Caribbean Innovation Competition 8.0" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/CICSocialMedia-03-360x180.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/launch-of-the-caribbean-innovation-competition-8-0/">Launch of the Caribbean Innovation Competition 8.0</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="Spice Isle Imaging celebrates 15 years of service to Grenada" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_0130-e1569332289433-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/spice-isle-imaging-celebrates-15-years-of-service-to-grenada/">Spice Isle Imaging celebrates 15 years of service to Grenada</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/"><div class="thumbnail-container size-500 "><img width="185" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/">Prime Minister at United Nations this week</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/IMG_9310-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/gasa-hosts-successful-ariza-pure-grenada-open-water-swim-invitational/">GASA hosts successful Ariza Pure Grenada Open Water Swim Invitational</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/"><div class="thumbnail-container size-500 "><img width="360" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="5th Grenada Contemporary set to open at Art House 473" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/photo-Art-House-473-3-360x180.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/5th-grenada-contemporary-set-to-open-at-art-house-473/">5th Grenada Contemporary set to open at Art House 473</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-all-clear-given/">Tropical Storm Karen: All clear given</a></h3>
                </div><div class="jeg_newsfeed_item ">
                    <div class="jeg_thumb">
                        
                        <a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/"><div class="thumbnail-container size-500 "><img width="180" height="180" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 owl-lazy wp-post-image" alt="National Cleanup Begins Friday" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/05/NaDMALogo-e1463145257251.jpg" /></div></a>
                    </div>
                    <h3 class="jeg_post_title"><a href="https://www.nowgrenada.com/2019/09/tropical-storm-karen-moves-85-miles-away-from-grenada/">Tropical Storm Karen moves 85 Miles away from Grenada</a></h3>
                </div>
                            </div>
                        </div>
                        <div class="newsfeed_overlay">
                            <div class="preloader_type preloader_dot">
                                <div class="newsfeed_preloader jeg_preloader dot">
                                    <span></span><span></span><span></span>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader circle">
                                    <div class="jnews_preloader_circle_outer">
                                        <div class="jnews_preloader_circle_inner"></div>
                                    </div>
                                </div>
                                <div class="newsfeed_preloader jeg_preloader square">
                                    <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/">
		        <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" data-dark-src="" data-dark-srcset=" 1x,  2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
<!--<div id="vpp">
  </div>-->
    <div class="container">
 
        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>
 
        <div class="row">
            <div class="jeg_main_content col-md-8">

               <div class="jeg_inner_content">

<div id="newad">
 <div id="bsa-block-720--300" class="bsaProContainer bsaProContainer-1 bsa-block-720--300 bsa-pro-col-1"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Header</span></h3><a class="bsaProHeader__formUrl" href="http://www.nowgrenada.com/stats/?sid=1" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=19&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1519485822-Antillean-Life-banner-720x300_web.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "1";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "720";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script><style>
		.bsaProContainer-1 .bsaProItem {
			clear: both;
			width: 100% !important;
			margin-left: 0 !important;
			margin-right: 0 !important;
		}
		</style>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-1');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					 </div>
                     
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                                                    </div>
                         
                        <div class="entry-header">

                            
                            <h1 class="jeg_post_title">Date set for NDC convention</h1>
 
                            
                            <!--NOW Grenada Custom Ago Date -->
                            <div id="agodate">
                                                        </div>
 
                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

    <div class="meta_left">
        
                    <div class="jeg_meta_date">
                <a href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/">24 September 2019</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="https://www.nowgrenada.com/category/politics/" rel="category tag">Politics</a>                </span>
            </div>
        
	    <div class="jeg_meta_reading_time">
			            <span>
			            	2 min read
			            </span>
			        </div>    </div>

    <div class="meta_right">
                    </div>
</div>
</div>
                        </div>
 
                        <div class="jeg_featured featured_image"><a href="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg"><img src="https://www.nowgrenada.com/wp-content/uploads/2013/04/487844_209434459185433_1161613785_n.jpg" alt=""></a></div>                        <div class="now_featured_caption">
                        

                        </div>
                         
                        <div class="jeg_share_top_container"></div> 
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div> 
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" rel='nofollow'  class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a><a href="https://twitter.com/intent/tweet?text=Date+set+for+NDC+convention&url=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" rel='nofollow'  class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a><a href="whatsapp://send?text=Date+set+for+NDC+convention%0Ahttps%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" rel='nofollow'  data-action="share/whatsapp/share"  class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a>
                <div class="share-secondary">
                    <a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" rel='nofollow'  class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="mailto:?subject=Date+set+for+NDC+convention&amp;body=https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" rel='nofollow'  class="jeg_btn-email "><i class="fa fa-envelope"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
            </div></div>                            </div>
 
                            <div class="content-inner ">
                                <p><em>by Linda Straker</em></p>
<ul>
<li><strong>New political leader will be elected when NDC holds its convention on 3 November</strong></li>
<li><strong>Efforts now are on mobilising the constituencies</strong></li>
</ul>
<p>A new political leader will be elected by delegates of the main opposition National Democratic Congress (NDC) when the party holds its convention on 3 November 2019 at the Trade Centre.</p>
<p>Political leader Nazim Burke resigned in July 2018 after the party were unable to win a seat in the 13 March 2018 General Election. Joseph Andall has been the interim leader since Burke’s resignation.</p>
<p>Raymond Roberts, who was a candidate in 2018 General Election said that efforts are on mobilising the constituencies. “The focus of the work now is to energise the constituencies,” he said while a guest on the popular Grenada Broadcasting Network “To-the-Point” daily midmorning talk show.</p>
<p>“It’s going to be one of the significant conventions of the NDC, all are significant but this one has greater significance. You know our results in the last two general elections were not as desirable,” said Roberts who lost the St George’s South constituency to the New National Party’s Nickolas Steele in the 2018 General Election.</p>
<p>“At the moment we are working as a team behind the scene not in the public eyes, to ensure that we do what is right. Numbers at the Trade Centre is not all, we are going there with a purpose,” Roberts said, confirming that there will be visiting speakers.</p>
<p>The theme for the convention will be announced in the coming days by the interim leader. In the build-up to the convention, the party is having a series of public meetings. Roberts said that there will be about 400 delegates attending the convention and, in addition to the political leader position, all other posts on the executive will become vacant on the day and must be filled during the election segment by the delegates.</p>
<p>The party which governed the country from July 2008 to February 2013 was unable to win a seat in both the 2013 and 2018 General Elections. As a result, the country’s parliament does not have an elected opposition, but only opposition senators in the Upper House of Parliament who were appointed by Head of State, Governors-General Sir Carlyle Glean and Dame Cecile La Grenade respectively.</p>
<p>A number of other NDC executive members have resigned, including Chairman Vincent Roberts and Public Relations Officer, Randal Robinson.</p>
                                 
                                 
                                                                <div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.nowgrenada.com/tag/convention/" rel="tag">convention</a><a href="https://www.nowgrenada.com/tag/joseph-andall/" rel="tag">joseph andall</a><a href="https://www.nowgrenada.com/tag/linda-straker/" rel="tag">linda straker</a><a href="https://www.nowgrenada.com/tag/national-democratic-congress/" rel="tag">national democratic congress</a><a href="https://www.nowgrenada.com/tag/randal-robinson/" rel="tag">randal robinson</a><a href="https://www.nowgrenada.com/tag/raymond-roberts/" rel="tag">raymond roberts</a><a href="https://www.nowgrenada.com/tag/vincent-roberts/" rel="tag">vincent Roberts</a></div>
                                                            </div>

<!--Footer Banner by Andel March 28 2019 -->

 
                            <div class="jeg_share_bottom_container"></div> 
                                                    </div>
 
                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
            <a href="https://www.valdostadailytimes.com/sports/national_sports/school-spirit-us-colleges-pave-the-road-to-track-success/article_2732df7e-018d-58fb-8951-ccd30584ef01.html#new_tab" class="post prev-post">
            <span class="caption">Previous Post</span>
            <h3 class="post-title">School spirit: US colleges pave the road to track success</h3>
        </a>
    
            <a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/" class="post next-post">
            <span class="caption">Next Post</span>
            <h3 class="post-title">General Hospital PAHO-certified as baby friendly</h3>
        </a>
    </div></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"><div  class="jeg_postblock_22 jeg_postblock jeg_module_hook jeg_pagination_loadmore jeg_col_2o3 jnews_module_61722_0_5d8ad12ede868   " data-unique="jnews_module_61722_0_5d8ad12ede868">
                <div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
                    <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
                    
                </div>
                <div class="jeg_block_container">
                
                <div class="jeg_posts_wrap">
                <div class="jeg_posts jeg_load_more_flag"> 
                    <article class="jeg_post jeg_pl_md_5 post-61707 post type-post status-publish format-standard has-post-thumbnail hentry category-commentary category-environment category-politics tag-climate-change tag-climate-migrants tag-displacement tag-hurricane tag-internal-displacement-monitoring-centre tag-kellon-bubb tag-migration">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/"><div class="thumbnail-container animate-lazy  size-715 "><img width="234" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Yellow Journalism and the Alleged Closure of the Grenada Consulate in New York" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235.jpeg 364w, https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235-140x150.jpeg 140w, https://www.nowgrenada.com/wp-content/uploads/2015/07/Scan-e1436715755235-281x300.jpeg 281w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/news/environment/" class="category-environment">Environment</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/">Forced displacement, international law and climate refugees</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/09/forced-displacement-international-law-and-climate-refugees/" ><i class="fa fa-clock-o"></i> 24 September 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-61697 post type-post status-publish format-standard has-post-thumbnail hentry category-politics category-press-release tag-caricom-india-summit tag-climate-change tag-global-commission-on-adaptation tag-small-island-sustainable-energy-and-climate-resilience-organisation tag-united-nations">
                <div class="jeg_thumb">
                    
                    <a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/"><div class="thumbnail-container animate-lazy  size-715 "><img width="257" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="No Holiday for Carriacou Carnival" data-src="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2013/02/crest.png 300w, https://www.nowgrenada.com/wp-content/uploads/2013/02/crest-150x146.png 150w, https://www.nowgrenada.com/wp-content/uploads/2013/02/crest-38x38.png 38w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/press-release/" class="category-press-release">Press Release</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/">Prime Minister at United Nations this week</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.nowgrenada.com/2019/09/prime-minister-at-united-nations-this-week/" ><i class="fa fa-clock-o"></i> 24 September 2019</a></div></div>
                </div>
            </article><article class="jeg_post jeg_pl_md_5 post-61656 post type-post status-publish format-standard has-post-thumbnail hentry category-politics tag-canada tag-election tag-gananoque-reporter tag-jim-moodie tag-michael-coteau tag-ontario-liberal-party tag-sudbury">
                <div class="jeg_thumb">
                    
                    <a href="https://www.gananoquereporter.com/news/local-news/i-think-i-know-how-to-win/wcm/a2a6a4b3-9a17-47c9-92cc-72a8b2a9e67d#new_tab"><div class="thumbnail-container animate-lazy  size-715 "><img width="350" height="250" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-350x250 size-jnews-350x250 lazyload wp-post-image" alt="Michael Coteau looking to build support" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/Michael-Coteau--350x250.jpeg" data-sizes="auto" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/09/Michael-Coteau--350x250.jpeg 350w, https://www.nowgrenada.com/wp-content/uploads/2019/09/Michael-Coteau--120x86.jpeg 120w, https://www.nowgrenada.com/wp-content/uploads/2019/09/Michael-Coteau--750x536.jpeg 750w" data-expand="700" /></div></a>
                    <div class="jeg_post_category">
                        <span><a href="https://www.nowgrenada.com/category/politics/" class="category-politics">Politics</a></span>
                    </div>
                </div>
                <div class="jeg_postblock_content">
                    <h3 class="jeg_post_title">
                        <a href="https://www.gananoquereporter.com/news/local-news/i-think-i-know-how-to-win/wcm/a2a6a4b3-9a17-47c9-92cc-72a8b2a9e67d#new_tab">Michael Coteau looking to build support</a>
                    </h3>
                    <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://www.gananoquereporter.com/news/local-news/i-think-i-know-how-to-win/wcm/a2a6a4b3-9a17-47c9-92cc-72a8b2a9e67d#new_tab" ><i class="fa fa-clock-o"></i> 23 September 2019</a></div></div>
                </div>
            </article>
                </div>
            </div>
                <div class='module-overlay'>
                <div class='preloader_type preloader_dot'>
                    <div class="module-preloader jeg_preloader dot">
                        <span></span><span></span><span></span>
                    </div>
                    <div class="module-preloader jeg_preloader circle">
                        <div class="jnews_preloader_circle_outer">
                            <div class="jnews_preloader_circle_inner"></div>
                        </div>
                    </div>
                    <div class="module-preloader jeg_preloader square">
                        <div class="jeg_square"><div class="jeg_square_inner"></div></div>
                    </div>
                </div>
            </div>
            </div>
            <div class="jeg_block_navigation">
                <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                <div class="jeg_block_loadmore ">
                    <a href="#" class='' data-load='Load More' data-loading='Loading...'> Load More</a>
                </div>
                
            </div>
                
                <script>var jnews_module_61722_0_5d8ad12ede868 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"disable","include_post":"","exclude_post":61722,"include_category":"3","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"loadmore","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":"3","boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","excerpt_length":20,"paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_22"};</script>
            </div></div><div class="jnews_popup_post_container">
    <section class="jeg_popup_post">
        <span class="caption">Next Post</span>

                    <div class="jeg_popup_content">
                <div class="jeg_thumb">
                                        <a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/">
                        <div class="thumbnail-container animate-lazy  size-1000 "><img width="75" height="75" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="General Hospital PAHO-certified as baby friendly" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/09/PAHO-certification-to-the-hospital-75x75.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div>                    </a>
                </div>
                <h3 class="post-title">
                    <a href="https://www.nowgrenada.com/2019/09/general-hospital-paho-certified-as-baby-friendly/">
                        General Hospital PAHO-certified as baby friendly                    </a>
                </h3>
            </div>
                
        <a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
    </section>

</div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/09/date-set-for-ndc-convention/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.nowgrenada.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='61722' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8944355f62" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="34"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div> 
                    
<!--FB Comments by Andel March 12 2019 -->
<div style="" id="the_champ_fb_commenting"><div class="fb-comments" data-href="https://www.nowgrenada.com/2019/09/date-set-for-ndc-convention/" data-numposts="" data-width="100%" ></div></div><script type="text/javascript" src="//connect.facebook.net/en_GB/sdk.js
    "></script><script>FB.init({xfbml:1,version: "v3.2"});</script>
                </div>
            </div>
            
<div class="jeg_sidebar   col-md-4">
    <div class="widget sidebardads widget_text" id="text-2">			<div class="textwidget"><p><br />
<!-- Article Sidebar 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x250 --><br />
<br />
<!-- Article Sidebar Top 300x90--><br />
<br />
<!-- Article Sidebar 300x300 --><br />
<div id="bsa-block-300--300" class="bsaProContainer bsaProContainer-16 bsa-block-300--300 bsa-pro-col-1"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=102&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1568666612-Grenada-Bottling-ad.jpg&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=93&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1567775531-National-Sustainable-Development-Plan-ad.jpg&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com?bsa_pro_id=100&bsa_pro_url=1" target="_blank" rel="noopener noreferrer"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1568399453-Fl-GND_Vacancy-SeniorAdministrator_Web_130919_300x300.png&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				function bsaProResize() {
					var sid = "16";
					var object = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
					var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
					var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
					var parentWidth = "300";
					var parentHeight = "300";
					var objectWidth = object.width();
					if ( objectWidth < parentWidth ) {
						var scale = objectWidth / parentWidth;
						if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
							animateThumb.height(parentHeight * scale);
							innerThumb.height(parentHeight * scale);
							object.height(parentHeight * scale);
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							object.height(parentHeight);
						}
					} else {
						animateThumb.height(parentHeight);
						innerThumb.height(parentHeight);
						object.height(parentHeight);
					}
				}
				$(document).ready(function(){
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-16');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
					<br />
<!-- Article Sidebar 300x750 --><br />
</p>
</div>
		</div><div class="widget_text widget widget_custom_html" id="custom_html-7"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget_text widget widget_custom_html" id="custom_html-6"><div class="textwidget custom-html-widget">&nbsp;</div></div><div class="widget widget_awesomeweatherwidget" id="awesomeweatherwidget-4"><div id="awesome-weather-grenada-gd" class="awesome-weather-wrap awecf awe_tall temp6 awe_with_stats awe-code-801 awe-desc-few-clouds awe-preset-cloudy darken" style=" color: #ffffff; "><div class="awesome-weather-cover" style='background-image: url(https://www.nowgrenada.com/wp-content/plugins/awesome-weather/img/awe-backgrounds/cloudy.jpg);'><div class="awesome-weather-header">Grenada</div><div class="awesome-weather-current-temp"><strong>29<sup>&deg;</sup></strong></div><!-- /.awesome-weather-current-temp --><div class="awesome-weather-todays-stats"><div class="awe_desc">few clouds</div><div class="awe_humidty">humidity: 83%</div><div class="awe_wind">wind: 5m/s E</div><div class="awe_highlow">H 29 &bull; L 28</div></div><!-- /.awesome-weather-todays-stats --><div class="awesome-weather-forecast awe_days_4 awecf">
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">29<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Wed</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Thu</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Fri</div>
				</div>
				<div class="awesome-weather-forecast-day">
					<div class="awesome-weather-forecast-day-temp">28<sup>&deg;</sup></div>
					<div class="awesome-weather-forecast-day-abbr">Sat</div>
				</div></div><!-- /.awesome-weather-forecast --><div class="awesome-weather-attribution">Weather from OpenWeatherMap</div></div><!-- /.awesome-weather-cover --></div> <!-- /.awesome-weather-wrap --></div></div>        </div>
 
        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>
 
    </div>
</div>                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-61722 single-format-standard jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal wpb-js-composer js-comp-ver-6.0.5 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_custom">
    <div class="jeg_container">
        <div class="jeg_content">
            <div class="jeg_vc_content">
                <div data-vc-full-width="true" data-vc-full-width-init="false" class="row vc_row vc_custom_1512030979094 vc_row-has-fill jnews_5d8ad12ee694c footer_dark"><div class="jeg-vc-wrapper"><div class="footer_left wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper">
	<div class="wpb_text_column wpb_content_element  vc_custom_1551598731654 copyright" >
		<div class="wpb_wrapper">
			<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>

		</div>
	</div>
</div></div><div class="footer_right wpb_column jeg_column vc_column_container vc_col-sm-6"><div class="jeg_wrapper wpb_wrapper"><div  class='jeg_social_icon_block socials_widget jnews_module_61722_1_5d8ad12ee7196 nobg '><a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div></div></div></div></div><div class="vc_row-full-width vc_clearfix"></div>
            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-60599"><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.nowgrenada.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55527"><a href="https://www.nowgrenada.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://www.nowgrenada.com/category/community/">Community</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.nowgrenada.com/category/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10273"><a href="https://www.nowgrenada.com/category/commentary/">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56527"><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10297"><a href="https://www.nowgrenada.com/contactus/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12022"><a href="https://www.nowgrenada.com/contactus/">Contact Form</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10298"><a href="https://www.nowgrenada.com/submit-article/">Submit Article</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24260"><a href="https://www.nowgrenada.com/submit-pic-day/">Submit Pic of the Day</a></li>
</ul>
</li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Nowgrenada" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© NOW Grenada. All Rights Reserved – Powered by aqua.gd | <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a></p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = []</script><div id="cookie-law-info-bar"><span>This website uses cookies. By continuing to use this website you are giving consent to cookies being used. Visit our <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a>. <a  data-cli_action="accept" id="cookie_action_close_header"  class="small cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" style="display:inline-block; ">ACCEPT</a></span></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
    <div class="cli-modal-content cli-bar-popup">
      <button type="button" class="cli-modal-close" id="cliModalClose">
        <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
      </button>
      <div class="cli-modal-body">
        <div class="cli-container-fluid cli-tab-container">
    <div class="cli-row">
        <div class="cli-col-12 cli-align-items-stretch cli-px-0">
            <div class="cli-privacy-overview">
                <h4>Privacy Overview</h4>                                   
                <div class="cli-privacy-content">
                    <p class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</p>
                </div>
                <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a>            </div>
        </div>  
        <div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
            <div class="cli-tab-section cli-privacy-tab">
                <div class="cli-tab-header">
                    <a class="cli-nav-link cli-settings-mobile" >
                        Privacy Overview                    </a>
                </div>
                <div class="cli-tab-content">
                    <div class="cli-tab-pane cli-fade">
                        <p>This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are as essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</p>
                    </div>
                </div>

            </div>
              
           
                            <div class="cli-tab-section">
                    <div class="cli-tab-header">
                        <a class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" >
                            Necessary 
                        </a>
                    
                    <span class="cli-necessary-caption">Always Enabled</span>                     </div>
                    <div class="cli-tab-content">
                        <div class="cli-tab-pane cli-fade" data-id="necessary">
                            <p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p>
                        </div>
                    </div>
                </div>
              
           
                       
        </div>
    </div> 
</div> 
      </div>
    </div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<script type="text/javascript">
  /* <![CDATA[ */
  cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"#FFF","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"#ad0f0f","button_1_button_hover":"#8a0c0c","button_1_link_colour":"#fff","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"button_2_hidebar":false,"button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#62a329","button_4_as_button":false,"font_family":"inherit","header_fix":false,"notify_animate_hide":false,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":true,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"}';
  /* ]]> */
</script><div id="selectShareContainer">
                    <div class="selectShare-inner">
                        <div class="select_share jeg_share_button">              
                            <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" data-image-url="" data-title="Date+set+for+NDC+convention" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2019%2F09%2Fdate-set-for-ndc-convention%2F" data-image-url="" data-title="Date+set+for+NDC+convention" ><i class="fa fa-twitter"></i></a>
                        </div>
                        <div class="selectShare-arrowClip">
                            <div class="selectShare-arrow"></div>      
                        </div> 
                    </div>      
                  </div><div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-sanitize.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-a11y.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _adn_ = {"ajaxurl":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","upload":{"dir":"\/home\/nowgrena\/public_html\/wp-content\/uploads\/angwp\/","src":"https:\/\/www.nowgrenada.com\/wp-content\/uploads\/angwp\/"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/angwp/assets/dist/angwp.bundle.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/js/spr_inViewport.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/angwp/include/extensions/spr_columns/assets/js/parallax.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"d MM yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/comment-reply.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"1","lang":"en_GB","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"61722","isblog":"1","admin_bar":"0","follow_video":"1","follow_position":"bottom_right","rtl":"0","gif":"1","site_slug":"\/","site_domain":"www.nowgrenada.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=1.0.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=1.0.0'></script>
<![endif]-->
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/page-links-to/js/new-tab.min.js?ver=3.1.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/super-socializer/js/front/social_login/general.js?ver=7.12.34'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sTrackStatsArgs = {"ajaxurl":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","is_admin":"","id":"701593","track_id":"397766","content_id":"61722"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/smartrack/public/assets/js/sTrackStats.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-embed.min.js?ver=c23615977040a396e5a599d7ecf8580c'></script>
<script async="async" type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=6.0.5'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script>
</script>
<!-- Ads on this site are served by Adning v1.4.0 - adning.com -->
<!-- / Adning. -->

<script type="text/javascript">var ang_tracker = "UA-89948788-1";var loaded_ang = [];var loaded_angzones = [];</script>    
    <script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
$('a').each(function() {
var a = new RegExp('/' + window.location.host + '/');
if(!a.test(this.href)) {
$(this).click(function(event) {
event.preventDefault();
event.stopPropagation();
window.open(this.href, '_blank');
});
}
});
});
//]]>
</script>
    
</body>
</html>

<!-- Dynamic page generated in 0.610 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-09-24 22:30:06 -->

<!-- Compression = gzip -->