<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-GB"
	prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#" > <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-GB"
	prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#" > <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-GB"
	prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#" > <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-GB"
	prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#" > <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-GB"
	prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#" > <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="https://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://www.nowgrenada.com/xmlrpc.php" />
    <title>Historic engagement between government ministers and Grenlec workers | NOW Grenada</title>
<style>
	/* Custom BSA_PRO Styles */

	/* fonts */

	/* form */
	.bsaProOrderingForm {   }
	.bsaProInput input,
	.bsaProInput input[type='file'],
	.bsaProSelectSpace select,
	.bsaProInputsRight .bsaInputInner,
	.bsaProInputsRight .bsaInputInner label {   }
	.bsaProPrice  {  }
	.bsaProDiscount  {   }
	.bsaProOrderingForm .bsaProSubmit,
	.bsaProOrderingForm .bsaProSubmit:hover,
	.bsaProOrderingForm .bsaProSubmit:active {   }

	/* alerts */
	.bsaProAlert,
	.bsaProAlert > a,
	.bsaProAlert > a:hover,
	.bsaProAlert > a:focus {  }
	.bsaProAlertSuccess {  }
	.bsaProAlertFailed {  }

	/* stats */
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-b .ct-slice.ct-donut { stroke: #673AB7 !important; }

	.bsaStatsWrapper  .ct-chart .ct-series.ct-series-a .ct-bar,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-line,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-point,
	.bsaStatsWrapper .ct-chart .ct-series.ct-series-a .ct-slice.ct-donut { stroke: #FBCD39 !important; }

	/* Custom CSS */
	@media only screen and (max-width: 500px) { 
.bsaProContainer-4 {
margin-bottom: -155px !important;
}
}

@media only screen and (max-width: 500px) { 
.bsaProContainer-52 {
margin-bottom: -155px !important;
}
}


.bsaProContainer .bsaProHeader {
    display: none;
}
.bsaProItems, bsaProItemInner__thumb {
margin-bottom:10px !important;
}

.bsaProContainerNew .bsaProHeader {
     padding: 1px 15px !important;
}

.bsaProHeader__title {
    display: none !important;
}


.bsaProCarousel-22 {
    max-width: 300px !important;
}

.bsaProCarousel-9 {
    max-width: 300px !important;
}

.owl-controls {
    display: none !important;
} 

#bsa-block-720—300 {
max-width: 300px;
} 


/*@media only screen and (min-width: 900px) {
.bsaPopupClose {
    position: absolute;
    cursor: pointer;
    top: 150px;
    right: 320px;
    width: 25px;
    height: 25px;
    background: url(../../img/close-black.png) white center center no-repeat;
}
}*/

.bsaProContainer-23 .bsaProItem {
margin-bottom: 15px !important;
}

.bsaProContainer-9 .bsaProItem {
margin-bottom: 15px !important;
}

.bsaProContainer-16 .bsaProItem {
margin-bottom: 12px !important
}

.bsaProItemInner__thumb {
width: 100% !important;
}

/*Fixing adspace 300x300 on Article Page Sidebar */
#bsa-block-300--300 .bsaProItemInner__img {
background-size: contain !important;
}
.bsaProContainerNew .bsaProItemInner__img {
background-position: inherit !important;
}

/*Fixing adspace 300x250 on Category page Sidebar */
#bsa-block-300--250 .bsaProItemInner__img {
background-size: contain !important;
}

.bsaProContainerNew .bsaProItemInner__img {
     background-position: inherit !important;
    background-size: contain !important;
}

#bsa-block-300--250, #bsa-block-300--720, #bsa-block-300--400, #bsa-block-300--300, #bsa-block-300--500{
 max-width: 300px;
 margin: auto;
}

#bsa-block-208--500 {
   max-width: 208px;
}

.bsaProCarousel-25 {
    max-width: 300px !important;
}

.adcenter {
  display: block;
  margin-left: auto !important;
  margin-right: auto !important;
}

@media only screen and (max-width: 1025px) {
#bsa-block-468--60 {
display: block;
}

@media only screen and (max-width: 1025px) { 
.bsaProContainer-52 {
margin-bottom: -90px !important;
}
}

@media only screen and (max-width: 1025px) { 
.bsaProContainer-4 {
margin-bottom: -90px !important;
}
}

@media only screen and (max-width: 500px) { 
.bsaProContainer-4 {
margin-bottom: -130px !important;
}
}

@media only screen and (max-width: 500px) { 
.bsaProContainer-52 {
margin-bottom: -130px !important;
}
}

@media only screen and (max-width: 500px) { 
.bsaProContainer-57 {
margin-bottom: -130px !important;
}
}</style>
		<!-- All in One SEO 4.1.1.1 -->
		<link rel="canonical" href="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/" />
		<meta property="og:site_name" content="NOW Grenada" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Historic engagement between government ministers and Grenlec workers | NOW Grenada" />
		<meta property="og:url" content="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/" />
		<meta property="fb:app_id" content="640135875998340" />
		<meta property="fb:admins" content="1526986643" />
		<meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg" />
		<meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg" />
		<meta property="og:image:width" content="900" />
		<meta property="og:image:height" content="506" />
		<meta property="article:published_time" content="2021-06-04T18:42:11Z" />
		<meta property="article:modified_time" content="2021-06-04T18:42:11Z" />
		<meta property="article:publisher" content="https://www.facebook.com/NOWGrenada/" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@nowgrenada" />
		<meta name="twitter:domain" content="www.nowgrenada.com" />
		<meta name="twitter:title" content="Historic engagement between government ministers and Grenlec workers | NOW Grenada" />
		<meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg" />
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->

			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Feed" href="https://www.nowgrenada.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Comments Feed" href="https://www.nowgrenada.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NOW Grenada &raquo; Historic engagement between government ministers and Grenlec workers Comments Feed" href="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-188638277-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-188638277-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-188638277-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.nowgrenada.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='awsm-ead-public-css'  href='https://www.nowgrenada.com/wp-content/plugins/embed-any-document/css/embed-public.min.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_main_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/style.css?v=4.3.9&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_user_panel-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/user-panel.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_template_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/all.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_animate_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/animate.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_chart_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/chart.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_carousel_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/jquery.bxslider.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='buy_sell_ads_pro_materialize_stylesheet-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/material-design.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-css'  href='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/css/asset/ui-datapicker.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-parent-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='jeg_customizer_font-css'  href='//fonts.googleapis.com/css?family=Roboto%3Areguler&#038;display=swap&#038;ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-icon-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/fonts/jegicon/jegicon.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jscrollpane-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/jquery.jscrollpane.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='oknav-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/okayNav.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/magnific-popup.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='chosen-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/chosen/chosen.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel2-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/owl-carousel2/assets/owl.carousel.min.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-main-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/main.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-responsive-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/responsive.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-pb-temp-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/pb-temp.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/elementor-frontend.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews-child/style.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://www.nowgrenada.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='moove_gdpr_frontend-css'  href='https://www.nowgrenada.com/wp-content/plugins/gdpr-cookie-compliance/dist/styles/gdpr-main.css?ver=4.5.5' type='text/css' media='all' />
<style id='moove_gdpr_frontend-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jnews-select-share-css'  href='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.nowgrenada.com","hash_tracking":"false","ua":"UA-188638277-1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-migrate/jquery-migrate-1.4.1-wp.js?ver=1.4.1-wp' id='jquery-migrate-js'></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.nowgrenada.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/shortcode.min.js?ver=5.7.2' id='shortcode-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-admin/js/media-upload.min.js?ver=5.7.2' id='media-upload-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/script.js?ver=5.7.2' id='buy_sell_ads_pro_js_script-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.viewportchecker.js?ver=5.7.2' id='buy_sell_ads_pro_viewport_checker_js_script-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/chart.js?ver=5.7.2' id='buy_sell_ads_pro_chart_js_script-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.bxslider.js?ver=5.7.2' id='buy_sell_ads_pro_carousel_js_script-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/bsa-plugin-pro-scripteo/frontend/js/jquery.simplyscroll.js?ver=5.7.2' id='buy_sell_ads_pro_simply_scroll_js_script-js'></script>
<link rel="https://api.w.org/" href="https://www.nowgrenada.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.nowgrenada.com/wp-json/wp/v2/posts/80833" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nowgrenada.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nowgrenada.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.nowgrenada.com/?p=80833' />
<link rel="alternate" type="application/json+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nowgrenada.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F&#038;format=xml" />
<script>

	window.fbAsyncInit = function() {
    FB.init({
      appId      : '640135875998340',
      cookie     : true,
      xfbml      : true,
      version    : 'v8.0'
    });
      
    FB.AppEvents.logPageView();   
      
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));

</script>
      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.nowgrenada.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e0fbff27-0ea3-4e3f-a8d9-a4c7eac9ccc8';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "NOW Grenada";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing to nowgrenada.com!";
oneSignal_options['welcomeNotification']['url'] = "https://www.nowgrenada.com";
oneSignal_options['path'] = "https://www.nowgrenada.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.4463433a-b41c-4a34-809b-879a9d93883b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "We'd like to show you notifications for the latest news and updates";
oneSignal_options['promptOptions']['exampleNotificationTitleDesktop'] = "Example Notification Title";
oneSignal_options['promptOptions']['exampleNotificationMessageDesktop'] = "Notifications will appear on your desktop";
oneSignal_options['promptOptions']['exampleNotificationTitleMobile'] = "Example Notification";
oneSignal_options['promptOptions']['exampleNotificationMessageMobile'] = "Notifications will appear on your mobile";
oneSignal_options['promptOptions']['exampleNotificationCaption'] = "(you can unsubscribe anytime)";
oneSignal_options['promptOptions']['acceptButtonText'] = "ALLOW";
oneSignal_options['promptOptions']['cancelButtonText'] = "NO THANKS";
oneSignal_options['promptOptions']['siteName'] = "https://www.nowgrenada.com";
oneSignal_options['promptOptions']['autoAcceptTitle'] = "Click Allow";
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = false;
          /* OneSignal: Using custom SDK initialization. */
                });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.nowgrenada.com/wp-content/uploads/2019/07/cropped-now-logo_social-2-270x270.png" />
<style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">
					.no_thumbnail .jeg_thumb,
					.thumbnail-container.no_thumbnail {
					    display: none !important;
					}
					.jeg_search_result .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_xs_3.no_thumbnail .jeg_postblock_content,
					.jeg_pl_sm.no_thumbnail .jeg_postblock_content {
					    margin-left: 0;
					}
					.jeg_postblock_11 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12 .no_thumbnail .jeg_postblock_content,
					.jeg_postblock_12.jeg_col_3o3 .no_thumbnail .jeg_postblock_content  {
					    margin-top: 0;
					}
					.jeg_postblock_15 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_19 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_postblock_24 .jeg_pl_md_box.no_thumbnail .jeg_postblock_content,
					.jeg_sidefeed .jeg_pl_md_box .jeg_postblock_content {
					    position: relative;
					}
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_title a:hover,
					.jeg_postblock_carousel_2 .no_thumbnail .jeg_post_meta .fa {
					    color: #212121 !important;
					} 
				</style>		<style type="text/css" id="wp-custom-css">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</style>
		
<!-- START - Open Graph and Twitter Card Tags 3.1.1 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_GB"/>
  <meta property="og:site_name" content="NOW Grenada"/>
  <meta property="og:title" content="Historic engagement between government ministers and Grenlec workers"/>
  <meta property="og:url" content="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="This is the first occasion that such a meeting has taken place and Dr Mitchell thanked the company’s management for arranging it."/>
  <meta property="og:image" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"/>
  <meta property="og:image:url" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"/>
  <meta property="og:image:secure_url" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"/>
  <meta property="og:image:width" content="900"/>
  <meta property="og:image:height" content="506"/>
  <meta property="article:published_time" content="2021-06-04T14:42:11-04:00"/>
  <meta property="article:modified_time" content="2021-06-04T14:42:11-04:00" />
  <meta property="og:updated_time" content="2021-06-04T14:42:11-04:00" />
  <meta property="article:section" content="Business"/>
  <meta property="article:section" content="PRESS RELEASE"/>
  <meta property="article:publisher" content="https://www.facebook.com/NOWGrenada/"/>
  <meta property="fb:app_id" content="640135875998340"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="Historic engagement between government ministers and Grenlec workers"/>
  <meta itemprop="headline" content="Historic engagement between government ministers and Grenlec workers"/>
  <meta itemprop="description" content="This is the first occasion that such a meeting has taken place and Dr Mitchell thanked the company’s management for arranging it."/>
  <meta itemprop="image" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"/>
  <meta itemprop="datePublished" content="2021-06-04"/>
  <meta itemprop="dateModified" content="2021-06-04T14:42:11-04:00" />
  <meta itemprop="author" content="NOW Grenada"/>
  <!--<meta itemprop="publisher" content="NOW Grenada"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="Historic engagement between government ministers and Grenlec workers"/>
  <meta name="twitter:url" content="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/"/>
  <meta name="twitter:description" content="This is the first occasion that such a meeting has taken place and Dr Mitchell thanked the company’s management for arranging it."/>
  <meta name="twitter:image" content="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@nowgrenada"/>
 <!-- SEO -->
  <meta name="description" content="This is the first occasion that such a meeting has taken place and Dr Mitchell thanked the company’s management for arranging it."/>
  <meta name="publisher" content="NOW Grenada"/>
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 3.1.1 -->
	
</head>
<body class="post-template-default single single-post postid-80833 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal elementor-default elementor-kit-80688">

    
    	<div id="jeg_sidecontent">
						<div class="jeg_side_heading">
					<ul class="jeg_side_tabs">
					<li data-tab-content="tab1" data-sort='latest' class="active">Latest</li>					</ul>
					<div class="jeg_side_feed_cat_wrapper">
					<div class="jeg_cat_dropdown"></div>					</div>
				<script> var side_feed = {"paged":1,"post_type":"post","exclude_post":80833,"include_category":"","sort_by":"latest","post_offset":0,"pagination_number_post":12,"number_post":12,"pagination_mode":"loadmore"}; </script>				</div>
				
		<div class="sidecontent_postwrapper">
			<div class="jeg_sidefeed ">
				<div class="jeg_post jeg_pl_md_box active " data-id="80833" data-sequence="0">
                        <div class="overlay_container">
                            <div class="jeg_thumb">
                                
                                <a class="ajax" href="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/"><div class="thumbnail-container animate-lazy  size-500 "><img width="900" height="506" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-360x180 size-jnews-360x180 lazyload wp-post-image" alt="Historic engagement between government ministers and Grenlec workers" loading="lazy" sizes="(max-width: 900px) 100vw, 900px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-300x169.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-150x84.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-768x432.jpg 768w" data-sizes="auto" data-expand="700" /></div></a>
                            </div>
                            <div class="jeg_postblock_content">
                                <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/">Historic engagement between government ministers and Grenlec workers</a></h2>
                                <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 4 hours ago</div></div>
                            </div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80827" data-sequence="1">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/new-police-officers-told-job-will-be-challenging/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="593" height="395" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="New police officers told job will be challenging" loading="lazy" sizes="(max-width: 593px) 100vw, 593px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/image.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/image.jpg 593w, https://www.nowgrenada.com/wp-content/uploads/2021/06/image-300x200.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/image-150x100.jpg 150w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/new-police-officers-told-job-will-be-challenging/">New police officers told job will be challenging</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 5 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80824" data-sequence="2">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/government-assures-timely-delivery-of-plough-service-in-carriacou/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="900" height="597" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Government assures timely delivery of plough service in Carriacou" loading="lazy" sizes="(max-width: 900px) 100vw, 900px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/96143233_3322993044391791_8911824562425954304_n.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/96143233_3322993044391791_8911824562425954304_n.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2021/06/96143233_3322993044391791_8911824562425954304_n-300x199.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/96143233_3322993044391791_8911824562425954304_n-150x100.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2021/06/96143233_3322993044391791_8911824562425954304_n-768x509.jpg 768w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/government-assures-timely-delivery-of-plough-service-in-carriacou/">Government assures timely delivery of plough service in Carriacou</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 5 hours ago</div></div>
                        </div>
                    </div><div class="jeg_ad jnews_sidefeed_ads"></div><div class="jeg_post jeg_pl_xs_3  " data-id="80809" data-sequence="3">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/job-opportunity-gidc/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="400" height="306" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Think Creative… Be Innovative… Youth Seminar" loading="lazy" sizes="(max-width: 400px) 100vw, 400px" data-src="https://www.nowgrenada.com/wp-content/uploads/2016/09/GIDC.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2016/09/GIDC.jpg 400w, https://www.nowgrenada.com/wp-content/uploads/2016/09/GIDC-150x115.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2016/09/GIDC-300x230.jpg 300w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/job-opportunity-gidc/">Job Opportunity: GIDC</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 9 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80806" data-sequence="4">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/hm-the-queen-recognises-grenadian-with-commonwealth-points-of-light-award/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="900" height="705" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="HM The Queen recognises Grenadian with Commonwealth Points of Light award" loading="lazy" sizes="(max-width: 900px) 100vw, 900px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/Tamika-Gilbert.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/Tamika-Gilbert.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Tamika-Gilbert-300x235.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Tamika-Gilbert-150x118.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Tamika-Gilbert-768x602.jpg 768w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/hm-the-queen-recognises-grenadian-with-commonwealth-points-of-light-award/">HM The Queen recognises Grenadian with Commonwealth Points of Light award</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 11 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80801" data-sequence="5">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/covid-19-update-grenada-dashboard-2-june/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="500" height="414" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Claims of coronavirus at SGU designed to create fear and panic" loading="lazy" sizes="(max-width: 500px) 100vw, 500px" data-src="https://www.nowgrenada.com/wp-content/uploads/2020/02/Ministry-of-Health-Grenada.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2020/02/Ministry-of-Health-Grenada.jpg 500w, https://www.nowgrenada.com/wp-content/uploads/2020/02/Ministry-of-Health-Grenada-300x248.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2020/02/Ministry-of-Health-Grenada-150x124.jpg 150w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/covid-19-update-grenada-dashboard-2-june/">Covid-19 update: Grenada Dashboard 2 June</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 23 hours ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80776" data-sequence="6">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/dr-yvette-noel-schure-at-mac-donald-college-career-day/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="900" height="675" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Dr Yvette Noel-Schure at Mac Donald College career day" loading="lazy" sizes="(max-width: 900px) 100vw, 900px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/IMG_5773.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/IMG_5773.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2021/06/IMG_5773-300x225.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/IMG_5773-150x113.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2021/06/IMG_5773-768x576.jpg 768w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/dr-yvette-noel-schure-at-mac-donald-college-career-day/">Dr Yvette Noel-Schure at Mac Donald College career day</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 day ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80794" data-sequence="7">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/vacancy-project-manager-2/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="327" height="211" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Vacancy: Plant Engineer" loading="lazy" sizes="(max-width: 327px) 100vw, 327px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/01/image001.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/01/image001.jpg 327w, https://www.nowgrenada.com/wp-content/uploads/2021/01/image001-300x194.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/01/image001-150x97.jpg 150w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/vacancy-project-manager-2/">Vacancy: Project Manager</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 1 day ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80791" data-sequence="8">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/final-day-for-quarantine-facilities-to-meet-vaccination-criteria/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="640" height="384" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Grenada stepping up measles surveillance at ports of entry" loading="lazy" sizes="(max-width: 640px) 100vw, 640px" data-src="https://www.nowgrenada.com/wp-content/uploads/2019/01/syringe-1884758_640.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/01/syringe-1884758_640.jpg 640w, https://www.nowgrenada.com/wp-content/uploads/2019/01/syringe-1884758_640-150x90.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2019/01/syringe-1884758_640-300x180.jpg 300w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/final-day-for-quarantine-facilities-to-meet-vaccination-criteria/">Final day for quarantine facilities to meet vaccination criteria</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80783" data-sequence="9">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/7th-chinese-bridge-competition-in-grenada-a-success/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="661" height="406" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="7th “Chinese Bridge” Competition in Grenada a success" loading="lazy" sizes="(max-width: 661px) 100vw, 661px" data-src="https://www.nowgrenada.com/wp-content/uploads/2021/06/image003-1.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/image003-1.jpg 661w, https://www.nowgrenada.com/wp-content/uploads/2021/06/image003-1-300x184.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/image003-1-150x92.jpg 150w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/7th-chinese-bridge-competition-in-grenada-a-success/">7th “Chinese Bridge” Competition in Grenada a success</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80781" data-sequence="10">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/temporary-closure-of-balthazar-road-2/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="832" height="731" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Grand Bacolet to Munich Road nearing Completion" loading="lazy" sizes="(max-width: 832px) 100vw, 832px" data-src="https://www.nowgrenada.com/wp-content/uploads/2015/03/Brunei_road_sign_-_Road_Work.svg-e1607537018973.png" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2015/03/Brunei_road_sign_-_Road_Work.svg-e1607537018973.png 832w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Brunei_road_sign_-_Road_Work.svg-e1607537018973-150x132.png 150w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Brunei_road_sign_-_Road_Work.svg-e1607537018973-300x264.png 300w, https://www.nowgrenada.com/wp-content/uploads/2015/03/Brunei_road_sign_-_Road_Work.svg-e1607537018973-768x675.png 768w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/temporary-closure-of-balthazar-road-2/">Temporary Closure of Balthazar Road</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80779" data-sequence="11">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/cibc-firstcaribbeans-walk-for-the-cure-celebrates-year-10/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="900" height="443" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="Grenada records highest incidence of cancer in Caribbean" loading="lazy" sizes="(max-width: 900px) 100vw, 900px" data-src="https://www.nowgrenada.com/wp-content/uploads/2020/03/IMGP2717.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2020/03/IMGP2717.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2020/03/IMGP2717-300x148.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2020/03/IMGP2717-150x74.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2020/03/IMGP2717-768x378.jpg 768w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/cibc-firstcaribbeans-walk-for-the-cure-celebrates-year-10/">CIBC FirstCaribbean’s Walk for the Cure celebrates Year 10!</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div><div class="jeg_post jeg_pl_xs_3  " data-id="80760" data-sequence="12">
                        <div class="jeg_thumb">
                            
                            <a class="ajax" href="https://www.nowgrenada.com/2021/06/update-grenadian-national-breaches-entry-protocol/"><div class="thumbnail-container animate-lazy  size-1000 "><img width="205" height="246" src="https://www.nowgrenada.com/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-75x75 size-jnews-75x75 lazyload wp-post-image" alt="RGPF Reports 77% detection for 2014" loading="lazy" sizes="(max-width: 205px) 100vw, 205px" data-src="https://www.nowgrenada.com/wp-content/uploads/2014/12/RGPF.jpg" data-srcset="https://www.nowgrenada.com/wp-content/uploads/2014/12/RGPF.jpg 205w, https://www.nowgrenada.com/wp-content/uploads/2014/12/RGPF-125x150.jpg 125w" data-sizes="auto" data-expand="700" /></div></a>
                        </div>
                        <div class="jeg_postblock_content">
                            <h2 class="jeg_post_title"><a class="ajax" href="https://www.nowgrenada.com/2021/06/update-grenadian-national-breaches-entry-protocol/">Update: Grenadian National breaches Entry Protocol</a></h2>
                            <div class="jeg_post_meta"><div class="jeg_meta_date"><i class="fa fa-clock-o"></i> 2 days ago</div></div>
                        </div>
                    </div>			</div>
								<div class="sidefeed_loadmore">
											<button class="btn "
								data-end="End of Content"
								data-loading="Loading..."
								data-loadmore="Load More">
						Load More						</button>
					</div>
							</div>
		<div class="jeg_sidefeed_overlay">
			<div class='preloader_type preloader_dot'>
				<div class="sidefeed-preloader jeg_preloader dot">
					<span></span><span></span><span></span>
				</div>
				<div class="sidefeed-preloader jeg_preloader circle">
					<div class="jnews_preloader_circle_outer">
						<div class="jnews_preloader_circle_inner"></div>
					</div>
				</div>
				<div class="sidefeed-preloader jeg_preloader square">
					<div class="jeg_square">
						<div class="jeg_square_inner"></div>
					</div>
				</div>
			</div>
		</div>
	</div>
	
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/" style="padding: 0 0 0 0;">
	    	    <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_retina.png 2x" data-dark-src="https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_dark_mode.png" data-dark-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_dark_mode.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_retina_dark_mode.png 2x">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '><div class='ads_shortcode'><div id="bsa-html" class="bsaProContainerNew bsaProContainer-10 bsa-html bsa-pro-col-1" style="display: block !important"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Main Header Ad 468x60</span></h3><a class="bsaProHeader__formUrl" href="https://www.nowgrenada.com/stats/?sid=10" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__copy"><div class="bsaProItemInner__copyInner"><div class="bsaProItemInner__html"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=10&bsa_pro_id=15&bsa_pro_url=netherlands.co.gd" target="_blank"><img class="netherlands-ad" src="https://www.nowgrenada.com/wp-content/uploads/2017/12/banner468x60Netherlands1.gif" title="Netherlands" styles="margin-bottom: 25px !important;"/>
<div class="spacer"></div>
</a></div></div></div></div></div></div></div>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-10');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						</div></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_nav_html">
    </div>                    </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="none"><li id="menu-item-78358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-78358 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li id="menu-item-62227" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-62227 bgnav" data-item-row="default" ><a href="http://#">Categories</a>
<ul class="sub-menu">
	<li id="menu-item-62233" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-62233 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">General News</a>
	<ul class="sub-menu">
		<li id="menu-item-62365" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-62365 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">All</a></li>
		<li id="menu-item-62234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62234 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/agriculture_fisheries/">Agriculture &#038; Fisheries</a></li>
		<li id="menu-item-62245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62245 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/arts_culture_entertainment/">Arts &#038; Culture</a></li>
		<li id="menu-item-62235" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62235 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li>
		<li id="menu-item-62237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62237 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li>
		<li id="menu-item-62238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62238 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li>
		<li id="menu-item-62246" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62246 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/health/">Health</a></li>
		<li id="menu-item-62239" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62239 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/history/">History</a></li>
		<li id="menu-item-62244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62244 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/lifestyle/">Lifestyle</a></li>
		<li id="menu-item-62243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62243 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/law/">Law</a></li>
		<li id="menu-item-62247" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62247 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/politics/">Politics</a></li>
		<li id="menu-item-62240" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62240 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li>
		<li id="menu-item-62241" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62241 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/travel_tourism/">Travel &#038; Tourism</a></li>
		<li id="menu-item-62242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62242 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
		<li id="menu-item-62230" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62230 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/youth/">Youth</a></li>
	</ul>
</li>
	<li id="menu-item-62251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62251 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a>
	<ul class="sub-menu">
		<li id="menu-item-62369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62369 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
		<li id="menu-item-62252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62252 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li>
		<li id="menu-item-62253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62253 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li>
		<li id="menu-item-62254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62254 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li>
		<li id="menu-item-62255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62255 bgnav" data-item-row="default" ><a target="_blank" href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
	</ul>
</li>
	<li id="menu-item-62228" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62228 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a>
	<ul class="sub-menu">
		<li id="menu-item-62363" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62363 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">All</a></li>
		<li id="menu-item-62229" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62229 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li>
	</ul>
</li>
	<li id="menu-item-62236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62236 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li>
	<li id="menu-item-62231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62231 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/">Features</a>
	<ul class="sub-menu">
		<li id="menu-item-62364" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62364 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/">All</a></li>
		<li id="menu-item-62232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62232 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/today-in-history/">Today in History</a></li>
	</ul>
</li>
	<li id="menu-item-62256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62256 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/opinion_commentary/">Opinion/Commentary</a></li>
	<li id="menu-item-62248" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-62248 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a>
	<ul class="sub-menu">
		<li id="menu-item-62368" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62368 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
		<li id="menu-item-62249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62249 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisements</a></li>
		<li id="menu-item-62250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62250 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notices</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-62258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62258 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/video/">Video</a></li>
<li id="menu-item-78192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78192 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/notices/">Notices &#038; Vacancies</a></li>
<li id="menu-item-78126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78126 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/advertise/">Advertise</a></li>
<li id="menu-item-78125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78125 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contact/">Contact Us</a></li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div>                    </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="none"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-78358 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-62227 bgnav" data-item-row="default" ><a href="http://#">Categories</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-62233 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">General News</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-62365 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62234 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/agriculture_fisheries/">Agriculture &#038; Fisheries</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62245 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/arts_culture_entertainment/">Arts &#038; Culture</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62235 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62237 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62238 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62246 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/health/">Health</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62239 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/history/">History</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62244 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/lifestyle/">Lifestyle</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62243 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/law/">Law</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62247 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/politics/">Politics</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62240 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62241 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/travel_tourism/">Travel &#038; Tourism</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62242 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62230 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/youth/">Youth</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62251 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">Sports</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62369 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62252 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62253 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62254 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62255 bgnav" data-item-row="default" ><a target="_blank" href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62228 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">Community</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62363 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62229 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62236 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62231 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/">Features</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62364 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62232 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/feature/today-in-history/">Today in History</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62256 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/opinion_commentary/">Opinion/Commentary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-62248 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62368 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62249 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisements</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62250 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notices</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62258 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/category/video/">Video</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78192 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/notices/">Notices &#038; Vacancies</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78126 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78125 bgnav" data-item-row="default" ><a href="https://www.nowgrenada.com/contact/">Contact Us</a></li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://www.nowgrenada.com/">
		        <img class='jeg_logo_img' src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" alt="NOW Grenada"data-light-src="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png" data-light-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/07/nowgrenada_logo_web_reg.png 2x" data-dark-src="https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_dark_mode.png" data-dark-srcset="https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_dark_mode.png 1x, https://www.nowgrenada.com/wp-content/uploads/2019/10/nowgrenada_logo_web_retina_dark_mode.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
<!--<div id="vpp">-->
  <!--</div>-->
    <div class="container">

        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>

        <div class="row">
            <div class="jeg_main_content col-md-8">
                <div class="jeg_inner_content">
<div id="newad">
 <div id="bsa-block-720--300" class="bsaProContainerNew bsaProContainer-1 bsa-block-720--300 bsa-pro-col-1" style="display: block !important"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Article Header</span></h3><a class="bsaProHeader__formUrl" href="https://www.nowgrenada.com/stats/?sid=1" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridNoGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=1&bsa_pro_id=19&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1606883624-life_icon_ad_720x300master.png&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "1";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "720";
						var parentHeight = "300";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-1');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						 	  	<div id="ad35">
		  	</div>
</div>
                    
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                                                    </div>
                        
                        <div class="entry-header">
    	                    
                            <h1 class="jeg_post_title">Historic engagement between government ministers and Grenlec workers</h1>

                            <!--NOW Grenada Custom Ago Date -->
                            <div id="agodate">
                                                        </div>

                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

	<div class="meta_left">
		
					<div class="jeg_meta_date">
				<a href="https://www.nowgrenada.com/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/">4 June 2021</a>
			</div>
		
					<div class="jeg_meta_category">
				<span><span class="meta_text">in</span>
					<a href="https://www.nowgrenada.com/category/news/business/" rel="category tag">Business</a>, <a href="https://www.nowgrenada.com/category/press-release/" rel="category tag">PRESS RELEASE</a>				</span>
			</div>
		
		<div class="jeg_meta_reading_time">
			            <span>
			            	 4 min. read
			            </span>
			        </div>	</div>

	<div class="meta_right">
					</div>
</div>
</div>
                        </div>
						
					<div class="now_ft_img">
						<img width="900" height="506" src="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg" class="attachment-full size-full wp-post-image" alt="" loading="lazy" srcset="https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg 900w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-300x169.jpg 300w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-150x84.jpg 150w, https://www.nowgrenada.com/wp-content/uploads/2021/06/Historic-Meeting-with-GRENLEC-Workers-June-2021-768x432.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><div class="featured_caption">Historic meeting with Grenlec Workers - June 2021</div>					</div>


                        <div class="jeg_share_top_container"></div>
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
                        <div class="entry-content with-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-normal">
                                <div class="jeg_share_float_container"><div class="jeg_sharelist">
                <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=Historic+engagement+between+government+ministers+and+Grenlec+workers&url=https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" rel='nofollow'  class="jeg_btn-twitter "><i class="fa fa-twitter"></i></a><a href="//api.whatsapp.com/send?text=Historic+engagement+between+government+ministers+and+Grenlec+workers%0Ahttps%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" rel='nofollow'  data-action="share/whatsapp/share"  class="jeg_btn-whatsapp "><i class="fa fa-whatsapp"></i></a><a href="https://chart.googleapis.com/chart?chs=400x400&cht=qr&choe=UTF-8&chl=https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" rel='nofollow'  class="jeg_btn-wechat "><i class="fa fa-wechat"></i></a><a href="/cdn-cgi/l/email-protection#300f4345525a5553440d785943445f4259531b555e575157555d555e441b5255444755555e1b575f4655425e5d555e441b5d595e5943445542431b515e541b7742555e5c55531b475f425b55424316515d400b525f54490d58444440431503711502761502764747471e5e5f475742555e5154511e535f5d150276020002011502760006150276585943445f4259531d555e575157555d555e441d5255444755555e1d575f4655425e5d555e441d5d595e5943445542431d515e541d5742555e5c55531d475f425b554243150276" rel='nofollow' class="jeg_btn-email "><i class="fa fa-envelope"></i></a>
                
            </div></div>                            </div>

                            <div class="content-inner ">
                                <div class="jeg_ad jeg_ad_article jnews_content_inline_3_ads  "><div class='ads-wrapper align-center '><div class='ads_shortcode'></div></div></div><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads  "><div class='ads-wrapper align-center '><div class='ads_shortcode'>
</div></div></div><div class="jeg_ad jeg_ad_article jnews_content_inline_ads  "><div class='ads-wrapper align-center '><div class='ads_shortcode'></div></div></div><p><strong>A historic engagement this week as Prime Minister Dr the Right Honourable Keith Mitchell, Energy Minister Honourable Gregory Bowen and Public Utilities Minister Senator the Honourable Norland Cox, met with workers of the Grenada Electricity Services Limited (Grenlec).</strong>
<p>Dr Mitchell acknowledged the historic nature of Wednesday’s meeting in his remarks noting that in his 36 years of involvement in politics, this is the first occasion that such a meeting has taken place and he thanked the company’s management for arranging it.
<p>The Prime Minister commended the workers for their stellar service over the years. He said, “Historically Grenlec employees have demonstrated that they are some of the most productive workers in the country. There is no doubt that the company has been successful and it is the workers who are responsible for the strength of the company today.vDr Mitchell noted too, “The Cuban workers, when they came after Hurricane Ivan, said some of the best electricity workers they have encountered are those from Grenada. Former Cuban President, the late Fidel Castro echoed that sentiment and you know the Cubans would not give that kind of credit lightly. The people of Montserrat too, will never forget the service you gave. In the aftermath of disaster, you are often called upon and that is based on the quality of personnel in the company.”<div id="bsa-block-720--150" class="bsaProContainerNew bsaProContainer-53 bsa-block-720--150 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=53&bsa_pro_id=318&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1620323739-Axcel-720x150.gif&#39;)"></div></a></div></div></div></div></div></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "53";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "720";
						var parentHeight = "150";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-53');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						
<p>The Prime Minister identified some of the former Grenlec stalwarts including Bruce Bain and the late Wilfred Hayes, who both gave 50-years of service to the company; the late Raymond “Barrel” Lewis, a long-serving linesman and supervisor; the late Kenneth Edwards and Randolph Greenidge.

<p>Dr Mitchell referenced the tremendous success of the rural electrification programme which was undertaken prior to the privatisation of the company and which resulted in a dramatic increase in the number of households which had access to electricity.
<p>Since the Government repurchased majority shares in the electricity company, there have been concerns about job security and it was one of the discussion points at the meeting. Dr Mitchell gave assurances that here are no plans to change the status of workers. He said, “If we are convinced that these are some of the best workers in the country, it would not be in anyone’s best interest to change that.”
<p>Energy Minister, Honourable Gregory Bowen, who previously held the portfolio of Public Utilities and was a former General Manager of Grenlec, was also high in praise for the workers at the electricity company. He made reference to the new energy environment, which places more emphasis on renewable energy. He said, “We have to be forward thinking in our approach and prepare ourselves for what’s to come. There will come a time when financing will be totally removed from fossil fuel and we will not be able to finance a diesel generated plant. The country could also be ostracised for not following international guidance as it relates to energy sector and the impact on the environment. We are operating in a new energy environment and we must work collectively towards the common goal of saving the planet.”
<p>With an increasing emphasis on renewable energy, coupled with Government’s commitment to lowering the cost of electricity, there is concern about the potential impact of that on Grenlec’s finances. Though he affirmed that alternative energy will be the order of the day, along with cheaper electricity rates, the Prime Minister said it’s a fallacy that the salaries of workers would be negatively impacted.
<p>The Prime Minister likened the situation to regional transportation, noting that if the cost of air travel went down, more people would travel, therefore the reduction in the cost per ticket would be offset by the increase in volume.
<p>Dr Mitchell stated, “Similarly with electricity, as cheaper service becomes available, there will be more investment and expansion in various sectors including manufacturing, hotel and general business. So the cost will go down for individual users but the company will maintain its earnings because there will be more users. One of the key considerations going forward, will be ensuring that the company remains viable, we will not do anything to affect that.”
<p>Senator Norland Cox who has current responsibility for Public Utilities, also addressed the workers, saying the company continues to play a critical role in the history and development of Grenada.
<p>Minister Cox said, “The work ethic, professionalism, skills and talent of the workers continue to be widely recognised. Great opportunities lie ahead as the world continues to evolve. There will always be challenges, but working together, we can ensure that the desired results are achieved. I expect that we will have a strong and productive working relationship going forward.”
<p><em>GIS</em>
<div id="bsa-block-720--300" class="bsaProContainerNew bsaProContainer-55 bsa-block-720--300 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=55&bsa_pro_id=307&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1618512514-MoH__720_300_Get_VaxadNow_Grenada.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "55";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "720";
						var parentHeight = "300";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-55');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						                                
	                            
<!--Report text by Andel October 24 2019 -->
<p id="rptxt"><strong>NOW Grenada</strong> is not responsible for the opinions, statements or media content presented by contributors. In case of abuse, <a href="https://www.nowgrenada.com/contact/">click here to report</a>.</p>


                                                                <div class="jeg_post_tags"><span>Tags:</span> <a href="https://www.nowgrenada.com/tag/gis/" rel="tag">gis</a><a href="https://www.nowgrenada.com/tag/gregory-bowen/" rel="tag">gregory bowen</a><a href="https://www.nowgrenada.com/tag/grenada-electricity-services-limited/" rel="tag">grenada electricity services limited</a><a href="https://www.nowgrenada.com/tag/grenlec/" rel="tag">grenlec</a><a href="https://www.nowgrenada.com/tag/keith-mitchell/" rel="tag">keith mitchell</a><a href="https://www.nowgrenada.com/tag/norland-cox/" rel="tag">norland cox</a></div>
                                                            </div>

<!--Footer Banner by Andel March 28 2019 -->

                            <div class="jeg_share_bottom_container"></div>
                                                    </div>

                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '><div class='ads_shortcode'>
</div></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container "></div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Comment on story <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/06/historic-engagement-between-government-ministers-and-grenlec-workers/?utm_source=rss&amp;utm_medium=rss&amp;utm_campaign=historic-engagement-between-government-ministers-and-grenlec-workers#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.nowgrenada.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><div id="cmtnote"><b>Please enter your valid email address.</b><br>Your email address will not be published. Required fields are marked * </div><br><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" required='required' /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name and email in this browser for the next time I comment.</label></p>
<div class="anr_captcha_field"><div id="anr_captcha_field_1" class="anr_captcha_field_div"></div></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='80833' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="136f578bef" /></p><input type="hidden" id="ak_js" name="ak_js" value="2"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p></div>
                    
<!--FB Comments by Andel March 12 2019 -->
<!--[TheChamp-FB-Comments]-->
<!--Add * to word Comment -->
					<script>
		//Adding asterisk to comment_
		let astr = document.createElement('span');
		astr.className = 'required';
		astr.id = 'required';
		astr.appendChild(document.createTextNode('*'));
		document.querySelector('label[for=comment]').appendChild(astr);
        </script>
		<!--<script>-->
		<!--let myElement = document.querySelector(".fb-video");-->
		<!--let noL = myElement.setAttribute("data-width", " ");	-->
		<!--</script>-->
		<style>
		#required{margin-left: 3px;} 
		</style>

                </div>
            </div>
            
<div class="jeg_sidebar   col-md-4">
    <div id="bsa-block-300--400" class="bsaProContainerNew bsaProContainer-33 bsa-block-300--400 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=33&bsa_pro_id=299&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1616423576-Caribbean_blue-resize.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "33";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "300";
						var parentHeight = "400";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-33');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						<div id="bsa-block-300--300" class="bsaProContainerNew bsaProContainer-16 bsa-block-300--300 bsa-pro-col-1" style="display: block !important"><div class="bsaProItems bsaGridGutter " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=16&bsa_pro_id=341&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1622820240-Job Opportunity Vice President Investment Promotion Agency.png&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=16&bsa_pro_id=334&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1622488143-rubis-want-more-miles-for-less-ad.jpg&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=16&bsa_pro_id=329&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1621542167-GIZ_vacancy_sr_field_collector.gif&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=16&bsa_pro_id=153&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1591190854-Grenlec-Hurricane-Preparedness-web-300x300.png&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "16";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "300";
						var parentHeight = "300";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-16');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						<div id="bsa-block-300--250" class="bsaProContainerNew bsaProContainer-9 bsa-block-300--250 bsa-pro-col-1" style="display: block !important"><div class="bsaProHeader" style="background-color:"><h3 class="bsaProHeader__title" style="color:"><span>Home Sidebar NP 300x250</span></h3><a class="bsaProHeader__formUrl" href="https://www.nowgrenada.com/stats/?sid=9" target="_blank" style="color:"><span></span></a></div><div class="bsaProItems bsaGridGutHor " style="background-color:"><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=9&bsa_pro_id=17&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/bsa-pro-upload/1583354903-1514827691-gcs-sidebar-box.jpg&#39;)"></div></a></div></div></div></div><div class="bsaProItem bsaReset" data-animation="none" style="opacity:1"><div class="bsaProItemInner" style="background-color:"><div class="bsaProItemInner__thumb"><div class="bsaProAnimateThumb"><a class="bsaProItem__url" href="https://www.nowgrenada.com/stats/?sid=9&bsa_pro_id=195&bsa_pro_url=1" target="_blank"><div class="bsaProItemInner__img" style="background-image: url(&#39;https://www.nowgrenada.com/wp-content/uploads/2014/03/Aqua-Banner-300x250.jpg&#39;)"></div></a></div></div></div></div></div></div><script>
			(function($){
				$(document).ready(function(){
					function bsaProResize() {
						var sid = "9";
						var object = $(".bsaProContainer-" + sid);
						var imageThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__img");
						var animateThumb = $(".bsaProContainer-" + sid + " .bsaProAnimateThumb");
						var innerThumb = $(".bsaProContainer-" + sid + " .bsaProItemInner__thumb");
						var parentWidth = "300";
						var parentHeight = "250";
						var objectWidth = object.parent().outerWidth();
	//					var objectWidth = object.width();
						if ( objectWidth <= parentWidth ) {
							var scale = objectWidth / parentWidth;
							if ( objectWidth > 0 && objectWidth !== 100 && scale > 0 ) {
								animateThumb.height(parentHeight * scale);
								innerThumb.height(parentHeight * scale);
								imageThumb.height(parentHeight * scale);
	//							object.height(parentHeight * scale);
							} else {
								animateThumb.height(parentHeight);
								innerThumb.height(parentHeight);
								imageThumb.height(parentHeight);
	//							object.height(parentHeight);
							}
						} else {
							animateThumb.height(parentHeight);
							innerThumb.height(parentHeight);
							imageThumb.height(parentHeight);
	//						object.height(parentHeight);
						}
					}
					bsaProResize();
					$(window).resize(function(){
						bsaProResize();
					});
				});
			})(jQuery);
		</script>						<script>
							(function ($) {
								var bsaProContainer = $('.bsaProContainer-9');
								var number_show_ads = "0";
								var number_hide_ads = "0";
								if ( number_show_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeIn(); }, number_show_ads * 1000);
								}
								if ( number_hide_ads > 0 ) {
									setTimeout(function () { bsaProContainer.fadeOut(); }, number_hide_ads * 1000);
								}
							})(jQuery);
						</script>
						</div>        </div>

        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '><div class='ads_shortcode'></div></div>        </div>

    </div>
</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-80833 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jeg_sidecontent jeg_sidecontent_center jsc_normal elementor-default elementor-kit-80688"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_custom">
    <div class="jeg_container">
        <div class="jeg_content">
            <div class="jeg_vc_content">
                		<div data-elementor-type="wp-post" data-elementor-id="78320" class="elementor elementor-78320" data-elementor-settings="[]">
							<div class="elementor-section-wrap">
							<section class="elementor-section elementor-top-section elementor-element elementor-element-94f53bf elementor-section-height-min-height elementor-section-boxed elementor-section-height-default elementor-section-items-middle" data-id="94f53bf" data-element_type="section" data-settings="{&quot;background_background&quot;:&quot;classic&quot;}">
						<div class="elementor-container elementor-column-gap-default">
					<div class="elementor-column elementor-col-50 elementor-top-column elementor-element elementor-element-13e8bc1" data-id="13e8bc1" data-element_type="column">
			<div class="elementor-widget-wrap elementor-element-populated">
								<div class="elementor-element elementor-element-8a0008f jeg_footer footer_dark a elementor-widget elementor-widget-text-editor" data-id="8a0008f" data-element_type="widget" data-widget_type="text-editor.default">
				<div class="elementor-widget-container">
								<p>© NOW Grenada. All Rights Reserved. Published by <a href="https://aqua.gd" target="_blank" rel="noopener">Aqua Design Inc.</a> | <a href="https://www.nowgrenada.com/terms/">Terms of Use</a> | <a href="https://www.nowgrenada.com/privacy/">Privacy Policy</a></p>						</div>
				</div>
					</div>
		</div>
				<div class="elementor-column elementor-col-50 elementor-top-column elementor-element elementor-element-567c79f" data-id="567c79f" data-element_type="column">
			<div class="elementor-widget-wrap elementor-element-populated">
								<div class="elementor-element elementor-element-c8ec081 elementor-icon-list--layout-inline elementor-align-right elementor-list-item-link-full_width elementor-widget elementor-widget-icon-list" data-id="c8ec081" data-element_type="widget" data-widget_type="icon-list.default">
				<div class="elementor-widget-container">
					<ul class="elementor-icon-list-items elementor-inline-items">
							<li class="elementor-icon-list-item elementor-inline-item">
					<a href="https://www.facebook.com/NOWGrenada">						<span class="elementor-icon-list-icon">
							<i aria-hidden="true" class="fab fa-facebook-f"></i>						</span>
										<span class="elementor-icon-list-text"></span>
											</a>
									</li>
								<li class="elementor-icon-list-item elementor-inline-item">
					<a href="https://twitter.com/nowgrenada">						<span class="elementor-icon-list-icon">
							<i aria-hidden="true" class="fab fa-twitter"></i>						</span>
										<span class="elementor-icon-list-text"></span>
											</a>
									</li>
								<li class="elementor-icon-list-item elementor-inline-item">
					<a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ">						<span class="elementor-icon-list-icon">
							<i aria-hidden="true" class="fab fa-youtube"></i>						</span>
										<span class="elementor-icon-list-text"></span>
											</a>
									</li>
						</ul>
				</div>
				</div>
					</div>
		</div>
							</div>
		</section>
						</div>
					</div>
		            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://www.nowgrenada.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-78358"><a href="https://www.nowgrenada.com/">Front Page</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-62227"><a href="http://#">Categories</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-62233"><a href="https://www.nowgrenada.com/category/news/">General News</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-62365"><a href="https://www.nowgrenada.com/category/news/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62234"><a href="https://www.nowgrenada.com/category/news/agriculture_fisheries/">Agriculture &#038; Fisheries</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62245"><a href="https://www.nowgrenada.com/category/news/arts_culture_entertainment/">Arts &#038; Culture</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62235"><a href="https://www.nowgrenada.com/category/news/business/">Business</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62237"><a href="https://www.nowgrenada.com/category/news/education/">Education</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62238"><a href="https://www.nowgrenada.com/category/news/environment/">Environment</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62246"><a href="https://www.nowgrenada.com/category/news/health/">Health</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62239"><a href="https://www.nowgrenada.com/category/news/history/">History</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62244"><a href="https://www.nowgrenada.com/category/news/lifestyle/">Lifestyle</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62243"><a href="https://www.nowgrenada.com/category/news/law/">Law</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62247"><a href="https://www.nowgrenada.com/category/news/politics/">Politics</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62240"><a href="https://www.nowgrenada.com/category/news/technology/">Technology</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62241"><a href="https://www.nowgrenada.com/category/news/travel_tourism/">Travel &#038; Tourism</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62242"><a href="https://www.nowgrenada.com/category/news/weather-news/">Weather</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62230"><a href="https://www.nowgrenada.com/category/news/youth/">Youth</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62251"><a href="https://www.nowgrenada.com/category/sports/">Sports</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62369"><a href="https://www.nowgrenada.com/category/sports/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62252"><a href="https://www.nowgrenada.com/category/sports/athletics/">Athletics</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62253"><a href="https://www.nowgrenada.com/category/sports/cricket/">Cricket</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62254"><a href="https://www.nowgrenada.com/category/sports/football-sport/">Football</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62255"><a target="_blank" rel="noopener" href="https://www.nowgrenada.com/category/sports/waterspouts/">Watersports</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62228"><a href="https://www.nowgrenada.com/category/community/">Community</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62363"><a href="https://www.nowgrenada.com/category/community/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62229"><a href="https://www.nowgrenada.com/category/community/tribute/">Tribute</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62236"><a href="https://www.nowgrenada.com/category/news/crime/">Crime</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62231"><a href="https://www.nowgrenada.com/category/feature/">Features</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62364"><a href="https://www.nowgrenada.com/category/feature/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62232"><a href="https://www.nowgrenada.com/category/feature/today-in-history/">Today in History</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62256"><a href="https://www.nowgrenada.com/category/opinion_commentary/">Opinion/Commentary</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-62248"><a href="https://www.nowgrenada.com/category/press-release/">Press Releases</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62368"><a href="https://www.nowgrenada.com/category/press-release/">All</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62249"><a href="https://www.nowgrenada.com/category/press-release/advertisement/">Advertisements</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62250"><a href="https://www.nowgrenada.com/category/press-release/notice-news/">Notices</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62258"><a href="https://www.nowgrenada.com/category/video/">Video</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78192"><a href="https://www.nowgrenada.com/notices/">Notices &#038; Vacancies</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78126"><a href="https://www.nowgrenada.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78125"><a href="https://www.nowgrenada.com/contact/">Contact Us</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Nowgrenada" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/nowgrenada" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a><a href="https://www.youtube.com/channel/UCitLlsbrKJpWAosE1qQkeOQ" target='_blank' rel='external noopener nofollow' class="jeg_youtube"><i class="fa fa-youtube-play"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>Copyright NOW Grenada</p>
</div>    </div>
</div>    </div>
</div><script type="text/javascript">var jfla = []</script><script async src="https://radar.cedexis.com/1/11475/radar.js"></script>
  <aside id="moove_gdpr_cookie_info_bar" class="moove-gdpr-info-bar-hidden moove-gdpr-align-center moove-gdpr-dark-scheme gdpr_infobar_postion_bottom" role="note" aria-label="GDPR Cookie Banner" style="display: none;">
    <div class="moove-gdpr-info-bar-container">
      <div class="moove-gdpr-info-bar-content">
        
<div class="moove-gdpr-cookie-notice">
  <p>We are using cookies to give you the best experience on our website.</p>
<p>You can find out more about which cookies we are using or switch them off in <span data-href="#moove_gdpr_cookie_modal" class="change-settings-button">settings</span>. Visit our <a href="https://www.nowgrenada.com/privacy/">Privacy Policy</a> | <a href="https://www.nowgrenada.com/terms/">Terms of Use</a>.</p>
</div>
<!--  .moove-gdpr-cookie-notice -->        
<div class="moove-gdpr-button-holder">
  <button class="mgbutton moove-gdpr-infobar-allow-all" aria-label="Accept">Accept</button>
  </div>
<!--  .button-container -->      </div>
      <!-- moove-gdpr-info-bar-content -->
    </div>
    <!-- moove-gdpr-info-bar-container -->
  </aside>
  <!-- #moove_gdpr_cookie_info_bar -->
<div id="selectShareContainer">
                        <div class="selectShare-inner">
                            <div class="select_share jeg_share_button">              
                                <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" data-image-url="" data-title="Historic+engagement+between+government+ministers+and+Grenlec+workers" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fwww.nowgrenada.com%2F2021%2F06%2Fhistoric-engagement-between-government-ministers-and-grenlec-workers%2F" data-image-url="" data-title="Historic+engagement+between+government+ministers+and+Grenlec+workers" ><i class="fa fa-twitter"></i></a>
                            </div>
                            <div class="selectShare-arrowClip">
                                <div class="selectShare-arrow"></div>      
                            </div> 
                        </div>      
                      </div>        <script>
        window.OneSignal = window.OneSignal || [];
		/* Why use .push? See: http://stackoverflow.com/a/38466780/555547 */
		window.OneSignal.push(function() {
  		/* Never call init() more than once. An error will occur. */
  		window.OneSignal.init(window._oneSignalInitOptions);
		});
        </script>
    <div class="jeg_read_progress_wrapper"><div class="jeg_progress_container top"><span class="progress-bar"></span></div></div><link rel='stylesheet' id='elementor-frontend-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/css/frontend.min.css?ver=3.2.4' type='text/css' media='all' />
<style id='elementor-frontend-inline-css' type='text/css'>
@font-face{font-family:eicons;src:url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0);src:url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.eot?5.10.0#iefix) format("embedded-opentype"),url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff2?5.10.0) format("woff2"),url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff?5.10.0) format("woff"),url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.ttf?5.10.0) format("truetype"),url(https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.svg?5.10.0#eicon) format("svg");font-weight:400;font-style:normal}
</style>
<link rel='stylesheet' id='elementor-post-78320-css'  href='https://www.nowgrenada.com/wp-content/uploads/elementor/css/post-78320.css?ver=1622125697' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/eicons/css/elementor-icons.min.css?ver=5.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-animations-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/animations/animations.min.css?ver=3.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-post-80688-css'  href='https://www.nowgrenada.com/wp-content/uploads/elementor/css/post-80688.css?ver=1622311848' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-pro-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor-pro/assets/css/frontend.min.css?ver=3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-global-css'  href='https://www.nowgrenada.com/wp-content/uploads/elementor/css/global.css?ver=1622125697' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-1-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic%7CRoboto+Slab%3A100%2C100italic%2C200%2C200italic%2C300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C600%2C600italic%2C700%2C700italic%2C800%2C800italic%2C900%2C900italic&#038;display=auto&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-shared-0-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/fontawesome.min.css?ver=5.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='elementor-icons-fa-brands-css'  href='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/font-awesome/css/brands.min.css?ver=5.15.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/embed-any-document/js/pdfobject.min.js?ver=2.6.1' id='awsm-ead-pdf-object-js'></script>
<script type='text/javascript' id='awsm-ead-public-js-extra'>
/* <![CDATA[ */
var eadPublic = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/embed-any-document/js/embed-public.min.js?ver=2.6.1' id='awsm-ead-public-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/core.min.js?ver=1.11.4-wp' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/datepicker.min.js?ver=1.11.4-wp' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"d MM yy","firstDay":0,"isRTL":false});});
</script>
<script type='text/javascript' id='force-refresh-js-js-extra'>
/* <![CDATA[ */
var forceRefreshLocalizedData = {"apiUrl":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","postId":"80833","nonce":"d34bf15cda","refreshInterval":"30"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/force-refresh/dist/js/force-refresh.js?ver=1615150400' id='force-refresh-js-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.7.2' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.7.2' id='wp-mediaelement-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/isotope.js?ver=1.0.1' id='isotope-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/lazysizes.js?ver=1.0.1' id='lazysizes-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/ls.bgset.js?ver=1.0.1' id='bgset-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/owl-carousel2/owl.carousel.js?ver=1.0.1' id='owlcarousel-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/superfish.js?ver=1.0.1' id='superfish-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/theia-sticky-sidebar.js?ver=1.0.1' id='theia-sticky-sidebar-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.waypoints.js?ver=1.0.1' id='waypoint-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.scrollTo.js?ver=1.0.1' id='scrollto-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.parallax.js?ver=1.0.1' id='parallax-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.okayNav.js?ver=1.0.1' id='okaynav-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.mousewheel.js?ver=1.0.1' id='mousewheel-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/modernizr-custom.js?ver=1.0.1' id='modernizr-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.smartresize.js?ver=1.0.1' id='smartresize-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/chosen.jquery.js?ver=1.0.1' id='chosen-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.magnific-popup.js?ver=1.0.1' id='magnific-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.jnewsgif.js?ver=1.0.1' id='jnews-gif-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.jowlslider.js?ver=1.0.1' id='jnews-owlslider-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.jsticky.js?ver=1.0.1' id='jnews-sticky-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.transit.min.js?ver=1.0.1' id='jquery-transit-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.module.js?ver=1.0.1' id='jnews-landing-module-js'></script>
<script type='text/javascript' id='jnews-main-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/www.nowgrenada.com\/2021\/06\/historic-engagement-between-government-ministers-and-grenlec-workers","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_GB","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"80833","isblog":"1","admin_bar":"0","follow_video":"1","follow_position":"bottom_right","rtl":"0","gif":"1","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"www.nowgrenada.com","zoom_button":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/main.js?ver=1.0.1' id='jnews-main-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/floating-video.js?ver=1.0.1' id='jnews-floating-video-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/zoom-button.js?ver=1.0.1' id='jnews-zoom-button-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/popup-post.js?ver=1.0.1' id='jnews-popup-post-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/jquery.jscrollpane.js?ver=1.0.1' id='jscrollpane-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/sidefeed.js?ver=1.0.1' id='jnews-sidefeed-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/darkmode.js?ver=1.0.1' id='jnews-darkmode-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=1.0.1' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.5' id='page-links-to-js'></script>
<script type='text/javascript' id='moove_gdpr_frontend-js-extra'>
/* <![CDATA[ */
var moove_frontend_gdpr_scripts = {"ajaxurl":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","post_id":"80833","plugin_dir":"https:\/\/www.nowgrenada.com\/wp-content\/plugins\/gdpr-cookie-compliance","show_icons":"all","is_page":"","strict_init":"1","enabled_default":{"third_party":0,"advanced":0},"geo_location":"false","force_reload":"false","is_single":"1","hide_save_btn":"false","current_user":"0","cookie_expiration":"365","script_delay":"2000","wp_lang":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/gdpr-cookie-compliance/dist/scripts/main.js?ver=4.5.5' id='moove_gdpr_frontend-js'></script>
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.7.2' async='async' id='remote_sdk-js'></script>
<script async="async" type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor-pro/assets/js/webpack-pro.runtime.min.js?ver=3.2.2' id='elementor-pro-webpack-runtime-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/js/webpack.runtime.min.js?ver=3.2.4' id='elementor-webpack-runtime-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.2.4' id='elementor-frontend-modules-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor-pro/assets/lib/sticky/jquery.sticky.min.js?ver=3.2.2' id='elementor-sticky-js'></script>
<script type='text/javascript' id='elementor-pro-frontend-js-before'>
var ElementorProFrontendConfig = {"ajaxurl":"https:\/\/www.nowgrenada.com\/wp-admin\/admin-ajax.php","nonce":"0d145ef17c","urls":{"assets":"https:\/\/www.nowgrenada.com\/wp-content\/plugins\/elementor-pro\/assets\/"},"i18n":{"toc_no_headings_found":"No headings were found on this page."},"shareButtonsNetworks":{"facebook":{"title":"Facebook","has_counter":true},"twitter":{"title":"Twitter"},"google":{"title":"Google+","has_counter":true},"linkedin":{"title":"LinkedIn","has_counter":true},"pinterest":{"title":"Pinterest","has_counter":true},"reddit":{"title":"Reddit","has_counter":true},"vk":{"title":"VK","has_counter":true},"odnoklassniki":{"title":"OK","has_counter":true},"tumblr":{"title":"Tumblr"},"digg":{"title":"Digg"},"skype":{"title":"Skype"},"stumbleupon":{"title":"StumbleUpon","has_counter":true},"mix":{"title":"Mix"},"telegram":{"title":"Telegram"},"pocket":{"title":"Pocket","has_counter":true},"xing":{"title":"XING","has_counter":true},"whatsapp":{"title":"WhatsApp"},"email":{"title":"Email"},"print":{"title":"Print"}},"facebook_sdk":{"lang":"en_GB","app_id":""},"lottie":{"defaultAnimationUrl":"https:\/\/www.nowgrenada.com\/wp-content\/plugins\/elementor-pro\/modules\/lottie\/assets\/animations\/default.json"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=3.2.2' id='elementor-pro-frontend-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/waypoints/waypoints.min.js?ver=4.0.2' id='elementor-waypoints-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/position.min.js?ver=1.11.4-wp' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/swiper/swiper.min.js?ver=5.3.6' id='swiper-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/share-link/share-link.min.js?ver=3.2.4' id='share-link-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/lib/dialog/dialog.min.js?ver=4.8.1' id='elementor-dialog-js'></script>
<script type='text/javascript' id='elementor-frontend-js-before'>
var elementorFrontendConfig = {"environmentMode":{"edit":false,"wpPreview":false,"isScriptDebug":false},"i18n":{"shareOnFacebook":"Share on Facebook","shareOnTwitter":"Share on Twitter","pinIt":"Pin it","download":"Download","downloadImage":"Download image","fullscreen":"Fullscreen","zoom":"Zoom","share":"Share","playVideo":"Play Video","previous":"Previous","next":"Next","close":"Close"},"is_rtl":false,"breakpoints":{"xs":0,"sm":480,"md":768,"lg":1025,"xl":1440,"xxl":1600},"responsive":{"breakpoints":{"mobile":{"label":"Mobile","value":767,"direction":"max","is_enabled":true},"mobile_extra":{"label":"Mobile Extra","value":880,"direction":"max","is_enabled":false},"tablet":{"label":"Tablet","value":1024,"direction":"max","is_enabled":true},"tablet_extra":{"label":"Tablet Extra","value":1365,"direction":"max","is_enabled":false},"laptop":{"label":"Laptop","value":1620,"direction":"max","is_enabled":false},"widescreen":{"label":"Widescreen","value":2400,"direction":"min","is_enabled":false}}},"version":"3.2.4","is_static":false,"experimentalFeatures":{"e_dom_optimization":true,"a11y_improvements":true,"landing-pages":true,"form-submissions":true},"urls":{"assets":"https:\/\/www.nowgrenada.com\/wp-content\/plugins\/elementor\/assets\/"},"settings":{"page":[],"editorPreferences":[]},"kit":{"active_breakpoints":["viewport_mobile","viewport_tablet"],"global_image_lightbox":"yes","lightbox_enable_counter":"yes","lightbox_enable_fullscreen":"yes","lightbox_enable_zoom":"yes","lightbox_enable_share":"yes","lightbox_title_src":"title","lightbox_description_src":"description"},"post":{"id":80833,"title":"Historic%20engagement%20between%20government%20ministers%20and%20Grenlec%20workers%20%7C%20NOW%20Grenada","excerpt":"This is the first occasion that such a meeting has taken place and Dr Mitchell thanked the company\u2019s management for arranging it.","featuredImage":"https:\/\/www.nowgrenada.com\/wp-content\/uploads\/2021\/06\/Historic-Meeting-with-GRENLEC-Workers-June-2021.jpg"}};
</script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.2.4' id='elementor-frontend-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=3.2.2' id='pro-preloaded-elements-handlers-js'></script>
<script type='text/javascript' src='https://www.nowgrenada.com/wp-content/plugins/elementor/assets/js/preloaded-modules.min.js?ver=3.2.4' id='preloaded-modules-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div>

<!-- V1 -->
<div id="moove_gdpr_cookie_modal" class="gdpr_lightbox-hide" role="complementary" aria-label="GDPR Settings Screen">
  <div class="moove-gdpr-modal-content moove-clearfix logo-position-left moove_gdpr_modal_theme_v1">
    <button class="moove-gdpr-modal-close" aria-label="Close GDPR Cookie Settings">
      <span class="gdpr-sr-only">Close GDPR Cookie Settings</span>
      <span class="gdpr-icon moovegdpr-arrow-close"></span>
    </button>
    <div class="moove-gdpr-modal-left-content">
      
<div class="moove-gdpr-company-logo-holder">
  <img src="https://www.nowgrenada.com/wp-content/uploads/2020/03/gdpr-logo-red-300x200.jpg" alt="NOW Grenada" title="NOW Grenada"   width="300"  height="200"  class="img-responsive" />
</div>
<!--  .moove-gdpr-company-logo-holder -->      <ul id="moove-gdpr-menu">
        
<li class="menu-item-on menu-item-privacy_overview menu-item-selected">
  <button data-href="#privacy_overview" class="moove-gdpr-tab-nav" aria-label="Privacy Overview">
    <span class="gdpr-svg-icon">
      <svg class="icon icon-privacy-overview" viewBox="0 0 26 32">
        <path d="M11.082 27.443l1.536 0.666 1.715-0.717c5.018-2.099 8.294-7.014 8.294-12.442v-5.734l-9.958-5.325-9.702 5.325v5.862c0 5.376 3.2 10.24 8.115 12.365zM4.502 10.138l8.166-4.506 8.397 4.506v4.813c0 4.838-2.893 9.19-7.347 11.034l-1.101 0.461-0.922-0.41c-4.352-1.894-7.194-6.195-7.194-10.957v-4.941zM12.029 14.259h1.536v7.347h-1.536v-7.347zM12.029 10.394h1.536v2.483h-1.536v-2.483z" fill="currentColor"></path>
      </svg>      
    </span> 
    <span class="gdpr-nav-tab-title">Privacy Overview</span>
  </button>
</li>

  <li class="menu-item-strict-necessary-cookies menu-item-off">
    <button data-href="#strict-necessary-cookies" class="moove-gdpr-tab-nav" aria-label="Strictly Necessary Cookies">
      <span class="gdpr-svg-icon">
        <svg class="icon icon-strict-necessary" viewBox="0 0 26 32">
          <path d="M22.685 5.478l-9.984 10.752-2.97-4.070c-0.333-0.461-0.973-0.538-1.434-0.205-0.435 0.333-0.538 0.947-0.23 1.408l3.686 5.094c0.179 0.256 0.461 0.41 0.768 0.435h0.051c0.282 0 0.538-0.102 0.742-0.307l10.854-11.699c0.358-0.435 0.333-1.075-0.102-1.434-0.384-0.384-0.998-0.358-1.382 0.026v0zM22.301 12.954c-0.563 0.102-0.922 0.64-0.794 1.203 0.128 0.614 0.179 1.229 0.179 1.843 0 5.094-4.122 9.216-9.216 9.216s-9.216-4.122-9.216-9.216 4.122-9.216 9.216-9.216c1.536 0 3.021 0.384 4.378 1.101 0.512 0.23 1.126 0 1.357-0.538 0.205-0.461 0.051-0.998-0.384-1.254-5.478-2.944-12.314-0.922-15.283 4.557s-0.922 12.314 4.557 15.258 12.314 0.922 15.258-4.557c0.896-1.638 1.357-3.482 1.357-5.35 0-0.768-0.077-1.51-0.23-2.253-0.102-0.538-0.64-0.896-1.178-0.794z" fill="currentColor"></path>
        </svg>
      </span> 
      <span class="gdpr-nav-tab-title">Strictly Necessary Cookies</span>
    </button>
  </li>




      </ul>
      
<div class="moove-gdpr-branding-cnt">
  
		<a href="https://wordpress.org/plugins/gdpr-cookie-compliance" target="_blank" rel="noopener noreferrer nofollow" class='moove-gdpr-branding'>Powered by&nbsp; <span>GDPR Cookie Compliance</span></a>
		</div>
<!--  .moove-gdpr-branding -->    </div>
    <!--  .moove-gdpr-modal-left-content -->
    <div class="moove-gdpr-modal-right-content">
      <div class="moove-gdpr-modal-title">
         
      </div>
      <!-- .moove-gdpr-modal-ritle -->
      <div class="main-modal-content">

        <div class="moove-gdpr-tab-content">
          
<div id="privacy_overview" class="moove-gdpr-tab-main">
      <span class="tab-title">Privacy Overview</span>
    <div class="moove-gdpr-tab-main-content">
  	<p>This website uses cookies so that we can provide you with the best user experience possible. Cookie information is stored in your browser and performs functions such as recognising you when you return to our website and helping our team to understand which sections of the website you find most interesting and useful. Visit our <a href="https://www.nowgrenada.com/privacy-policy-2/">Privacy Policy</a> | <a href="https://www.nowgrenada.com/terms/">Terms of Use</a>.</p>
  	  </div>
  <!--  .moove-gdpr-tab-main-content -->

</div>
<!-- #privacy_overview -->          
  <div id="strict-necessary-cookies" class="moove-gdpr-tab-main" style="display:none">
    <span class="tab-title">Strictly Necessary Cookies</span>
    <div class="moove-gdpr-tab-main-content">
      <p>Strictly Necessary Cookie should be enabled at all times so that we can save your preferences for cookie settings.</p>
      <div class="moove-gdpr-status-bar ">
        <div class="gdpr-cc-form-wrap">
          <div class="gdpr-cc-form-fieldset">
            <label class="cookie-switch" for="moove_gdpr_strict_cookies">    
              <span class="gdpr-sr-only">Enable or Disable Cookies</span>        
              <input type="checkbox" aria-label="Strictly Necessary Cookies"  value="check" name="moove_gdpr_strict_cookies" id="moove_gdpr_strict_cookies">
              <span class="cookie-slider cookie-round" data-text-enable="Enabled" data-text-disabled="Disabled"></span>
            </label>
          </div>
          <!-- .gdpr-cc-form-fieldset -->
        </div>
        <!-- .gdpr-cc-form-wrap -->
      </div>
      <!-- .moove-gdpr-status-bar -->
              <div class="moove-gdpr-strict-warning-message" style="margin-top: 10px;">
          <p>If you disable this cookie, we will not be able to save your preferences. This means that every time you visit this website you will need to enable or disable cookies again.</p>
        </div>
        <!--  .moove-gdpr-tab-main-content -->
                                              
    </div>
    <!--  .moove-gdpr-tab-main-content -->
  </div>
  <!-- #strict-necesarry-cookies -->
          
          
          
        </div>
        <!--  .moove-gdpr-tab-content -->
      </div>
      <!--  .main-modal-content -->
      <div class="moove-gdpr-modal-footer-content">
        <div class="moove-gdpr-button-holder">
  <button class="mgbutton moove-gdpr-modal-allow-all button-visible"  aria-label="Enable All">Enable All</button>
  <button class="mgbutton moove-gdpr-modal-save-settings button-visible" aria-label="Save Settings">Save Settings</button>
</div>
<!--  .moove-gdpr-button-holder -->      </div>
      <!--  .moove-gdpr-modal-footer-content -->
    </div>
    <!--  .moove-gdpr-modal-right-content -->

    <div class="moove-clearfix"></div>

  </div>
  <!--  .moove-gdpr-modal-content -->
</div>
<!-- #moove_gdpr_cookie_modal -->			<script type="text/javascript">
				var anr_onloadCallback = function() {
					for ( var i = 0; i < document.forms.length; i++ ) {
						var form = document.forms[i];
						var captcha_div = form.querySelector( '.anr_captcha_field_div' );

						if ( null === captcha_div )
							continue;
						captcha_div.innerHTML = '';
						( function( form ) {
							var anr_captcha = grecaptcha.render( captcha_div,{
								'sitekey' : '6LeHDMAUAAAAAIzX8gvNXFb3J22oGyjK1Du9Ui8_',
								'size'  : 'compact',
								'theme' : 'light'
							});
							if ( typeof jQuery !== 'undefined' ) {
								jQuery( document.body ).on( 'checkout_error', function(){
									grecaptcha.reset(anr_captcha);
								});
							}
							if ( typeof wpcf7 !== 'undefined' ) {
								document.addEventListener( 'wpcf7submit', function() {
									grecaptcha.reset(anr_captcha);
								}, false );
							}
						})(form);
					}
				};
			</script>
						<script src="https://www.google.com/recaptcha/api.js?onload=anr_onloadCallback&#038;render=explicit&#038;hl=en-GB"
				async defer>
			</script>
			    
    <script type="text/javascript">
//<![CDATA[
jQuery(document).ready(function($) {
$('a').each(function() {
var a = new RegExp('/' + window.location.host + '/');
if(!a.test(this.href)) {
$(this).click(function(event) {
event.preventDefault();
event.stopPropagation();
window.open(this.href, '_blank');
});
}
});
});
//]]>
</script>
    
</body>
</html>
